1 |
# $Id: smeserver-print-monitor.spec,v 1.7 2009/09/18 10:22:52 dungog Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-print-monitor |
6 |
%define version 0.0.7 |
7 |
%define release 1 |
8 |
Summary: SME Server print monitor |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: Freely distributable |
13 |
Group: Apache/php/caching |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
BuildRoot: /var/tmp/e-smith-buildroot |
16 |
BuildRequires: e-smith-devtools |
17 |
BuildArchitectures: noarch |
18 |
Requires: smeserver-release >= 7 |
19 |
Obsoletes: smeserver-lprng-monitor |
20 |
Provides: AutoReqProv: no |
21 |
|
22 |
%changelog |
23 |
* Fri Sep 18 2009 Stephen Noble <support@dungog.net> 0.0.7-1.sme |
24 |
- build for sme contribs |
25 |
- rename smeserver-lprng-monitor |
26 |
|
27 |
%description |
28 |
Print monitoring for SME Server |
29 |
|
30 |
%prep |
31 |
%setup |
32 |
|
33 |
%build |
34 |
perl createlinks |
35 |
|
36 |
%install |
37 |
rm -rf $RPM_BUILD_ROOT |
38 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
39 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
40 |
--file '/usr/local/lprng/info/lpinfo.ph' 'attr(755,root,root)' \ |
41 |
--file '/usr/local/lprng/bin/lpinfo' 'attr(755,root,root)' \ |
42 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lpc_suid' 'attr(4755,root,root)' \ |
43 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lpq_nt' 'attr(4755,root,root)' \ |
44 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lprm_suid' 'attr(4755,root,root)' \ |
45 |
--file '/var/www/html/LPRng/admin/cgi-bin/suid.ph' 'attr(4755,root,root)' \ |
46 |
--file '/var/www/html/LPRng/cgi-bin/lpinfo' 'attr(755,root,root)' \ |
47 |
--file '/var/www/html/LPRng/cgi-bin/lpinfo_lprm' 'attr(755,root,root)' \ |
48 |
> %{name}-%{version}-filelist |
49 |
echo "%doc " >> %{name}-%{version}-filelist |
50 |
|
51 |
%clean |
52 |
rm -rf $RPM_BUILD_ROOT |
53 |
|
54 |
%files -f %{name}-%{version}-filelist |
55 |
%defattr(-,root,root) |