1 |
# $Id: smeserver-print-monitor.spec,v 1.2 2016/06/13 15:27:17 unnilennium Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
%define name smeserver-print-monitor |
6 |
%define version 0.0.7 |
7 |
%define release 3 |
8 |
Summary: SME Server print monitor |
9 |
Name: %{name} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: Freely distributable |
13 |
Group: Apache/php/caching |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
Patch0: smeserver-print-monitor-0.0.7-auth.patch |
16 |
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
BuildRequires: e-smith-devtools |
18 |
BuildArchitectures: noarch |
19 |
Requires: smeserver-release >= 7 |
20 |
Obsoletes: smeserver-lprng-monitor |
21 |
Provides: AutoReqProv: no |
22 |
|
23 |
%changelog |
24 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.0.7-3.sme |
25 |
- fix missing AuthBasicProvider external |
26 |
- thank you to Anne aka Ecureuil for providing the fix and testing. |
27 |
|
28 |
* Fri Sep 18 2009 Stephen Noble <support@dungog.net> 0.0.7-1.sme |
29 |
- build for sme contribs |
30 |
- rename smeserver-lprng-monitor |
31 |
|
32 |
%description |
33 |
Print monitoring for SME Server |
34 |
|
35 |
%prep |
36 |
%setup |
37 |
%patch0 -p1 |
38 |
|
39 |
%build |
40 |
perl createlinks |
41 |
|
42 |
%install |
43 |
rm -rf $RPM_BUILD_ROOT |
44 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
45 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
46 |
--file '/usr/local/lprng/info/lpinfo.ph' 'attr(755,root,root)' \ |
47 |
--file '/usr/local/lprng/bin/lpinfo' 'attr(755,root,root)' \ |
48 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lpc_suid' 'attr(4755,root,root)' \ |
49 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lpq_nt' 'attr(4755,root,root)' \ |
50 |
--file '/var/www/html/LPRng/admin/cgi-bin/lpinfo_lprm_suid' 'attr(4755,root,root)' \ |
51 |
--file '/var/www/html/LPRng/admin/cgi-bin/suid.ph' 'attr(4755,root,root)' \ |
52 |
--file '/var/www/html/LPRng/cgi-bin/lpinfo' 'attr(755,root,root)' \ |
53 |
--file '/var/www/html/LPRng/cgi-bin/lpinfo_lprm' 'attr(755,root,root)' \ |
54 |
> %{name}-%{version}-filelist |
55 |
echo "%doc " >> %{name}-%{version}-filelist |
56 |
|
57 |
%clean |
58 |
rm -rf $RPM_BUILD_ROOT |
59 |
|
60 |
%files -f %{name}-%{version}-filelist |
61 |
%defattr(-,root,root) |