1 |
trevorb |
1.1 |
# $Id: smeserver-pxe.spec,v 1.0 2022/04/28 18:45:26 brianr Exp $ |
2 |
|
|
# Authority: nocvs |
3 |
|
|
# Name: Trevor Batley |
4 |
|
|
|
5 |
|
|
Summary: Allow pxeboot of client machines over network |
6 |
|
|
%define name smeserver-pxe |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Network |
14 |
|
|
Source: %{name}-%{version}.tar.xz |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
|
|
BuildArch: noarch |
17 |
|
|
Requires: e-smith-base |
18 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
19 |
|
|
AutoReq: yes |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
Global settings for dhcp to allow clients to network boot. |
23 |
|
|
Assumes sme server is acting as dhcp server. |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Thu Apr 28 2022 Trevor Batley <trevor@batley.id.au> 1.0-1.sme |
27 |
|
|
- Initial release [SME: 10821] |
28 |
|
|
- Split of PXE Global parameters out of smeserver-thinclient |
29 |
|
|
- Allow for different architectures (including UEFI booting) |
30 |
|
|
|
31 |
|
|
%prep |
32 |
|
|
%setup -q -n %{name}-%{version} |
33 |
|
|
|
34 |
|
|
%build |
35 |
|
|
|
36 |
|
|
%install |
37 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
38 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
39 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
40 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
41 |
|
|
|
42 |
|
|
%clean |
43 |
|
|
rm -rf $RPM_BUILD_ROOT |
44 |
|
|
|
45 |
|
|
%files -f %{name}-%{version}-filelist |
46 |
|
|
|
47 |
|
|
%defattr(-,root,root) |
48 |
|
|
|
49 |
|
|
%pre |
50 |
|
|
|
51 |
|
|
%preun |
52 |
|
|
|
53 |
|
|
%post |
54 |
|
|
|
55 |
|
|
%postun |