1 |
%define name smeserver-radicale |
2 |
%define version 0.0.3 |
3 |
%define release 5 |
4 |
|
5 |
Summary: smserver rpm to setup radicale, a carddav and caldav client |
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %{release}%{?dist} |
9 |
Source: %{name}-%{version}.tar.gz |
10 |
Patch0: smeserver-radicale-0.0.3-sme10.patch |
11 |
|
12 |
License: GNU GPL version 2 |
13 |
URL: http://www.contribs.org |
14 |
Group: SMEserver/addon |
15 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
16 |
Prefix: %{_prefix} |
17 |
BuildArchitectures: noarch |
18 |
BuildRequires: e-smith-devtools |
19 |
Requires: e-smith-release >= 10.0 |
20 |
Requires: python36-pip |
21 |
AutoReqProv: no |
22 |
|
23 |
%description |
24 |
smserver rpm to setup the roundcube IMAP mail client. |
25 |
|
26 |
%changelog |
27 |
* Thu Sep 08 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.3-5.sme |
28 |
- fix post scriptlet failing [SME: 12167] |
29 |
|
30 |
* Thu Aug 04 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.3-4.sme |
31 |
- import to SME10 |
32 |
- python 3.6 |
33 |
|
34 |
* Sun Oct 18 2015 stephane de labrusse <stephdl@de-labrusse.fr> 0.0.3-3 |
35 |
- change path and permissions to collections |
36 |
|
37 |
* Sat Oct 17 2015 stephane de labrusse <stephdl@de-labrusse.fr> 0.0.3-2 |
38 |
- /etc/rc.d/init.d/masq & /etc/services are expanding on radicale-update |
39 |
|
40 |
* Sun Oct 4 2015 stephane de labrusse <stephdl@de-labrusse.fr> 0.0.3-1 |
41 |
- specific ssl certificate is used |
42 |
- the user/group radicale run the init script |
43 |
- hosts.allow is used now |
44 |
|
45 |
* Thu Oct 1 2015 stephane de labrusse <stephdl@de-labrusse.fr> 0.0.1-3 |
46 |
- First release to sme9 |
47 |
- Thanks to JM LE CORGUILLE <jean-michel@le-corguille.org> for the code and idea. |
48 |
|
49 |
%prep |
50 |
%setup |
51 |
%patch0 -p1 |
52 |
|
53 |
rm -rf root/etc/rc.d |
54 |
|
55 |
%build |
56 |
perl createlinks |
57 |
%{__mkdir_p} root/home/e-smith/files/radicale/collections |
58 |
%{__mkdir_p} root/etc/radicale/ |
59 |
%{__mkdir_p} root/var/log/radicale |
60 |
%{__mkdir_p} root/run/radicale |
61 |
|
62 |
%install |
63 |
rm -rf $RPM_BUILD_ROOT |
64 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
65 |
rm -f %{name}-%{version}-filelist |
66 |
/sbin/e-smith/genfilelist \ |
67 |
--dir /etc/radicale/ 'attr(0755,root,root)' \ |
68 |
--dir /home/e-smith/files/radicale 'attr(0750,radicale,radicale)' \ |
69 |
--dir /home/e-smith/files/radicale/collections 'attr(0750,radicale,radicale)' \ |
70 |
--dir /var/log/radicale 'attr(0755,radicale,radicale)' \ |
71 |
--file /var/log/radicale/radicale.log 'attr(0755,radicale,radicale)' \ |
72 |
--dir /run/radicale 'attr(0755,radicale,radicale)' \ |
73 |
$RPM_BUILD_ROOT > %{name}-%{version}-filelist |
74 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
75 |
|
76 |
%clean |
77 |
cd .. |
78 |
rm -rf %{name}-%{version} |
79 |
|
80 |
%pre |
81 |
|
82 |
/sbin/e-smith/create-system-user radicale 1948 "Radicale server" /home/e-smith/files/.radicale/ /bin/bash |
83 |
mkdir -p /home/e-smith/files/.radicale |
84 |
chown radicale:radicale /home/e-smith/files/.radicale |
85 |
#echo "### Radicale Installation" |
86 |
#pip install --upgrade pip radicale >/dev/null 2>&1 |
87 |
|
88 |
%preun |
89 |
|
90 |
%post |
91 |
|
92 |
%postun |
93 |
|
94 |
%files -f %{name}-%{version}-filelist |
95 |
%defattr(-,root,root) |