1 |
slords |
1.1 |
%define name smeserver-roundcube |
2 |
|
|
%define version 0.9 |
3 |
|
|
%define release 7 |
4 |
|
|
|
5 |
|
|
Summary: smserver rpm to setup roundcube, an IMAP mail client |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source: %{name}-%{version}.tar.gz |
10 |
|
|
Patch0: smeserver-roundcube-0.9-domain.patch |
11 |
|
|
License: GNU GPL version 2 |
12 |
|
|
URL: http://www.dungog.net/sme |
13 |
|
|
Group: SMEserver/addon |
14 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
15 |
|
|
Prefix: %{_prefix} |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
|
|
Requires: e-smith-release >= 7.0 |
19 |
|
|
Requires: roundcube |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
smserver rpm to setup the roundcube IMAP mail client. |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Thu Jun 28 2007 Stephen Noble <stephen@dungog.net> |
27 |
|
|
- add domain property to use existing host or domain 0.9-7 |
28 |
|
|
|
29 |
|
|
* Thu Jun 21 2007 Stephen Noble <stephen@dungog.net> |
30 |
|
|
- update .spec file 0.9-6 |
31 |
|
|
|
32 |
|
|
* Thu Jun 21 2007 Stephen Noble <stephen@dungog.net> |
33 |
|
|
- automate config file creation |
34 |
|
|
- proxypass to fix https redirect bug |
35 |
|
|
- [0.9-5] |
36 |
|
|
|
37 |
|
|
* Fri Apr 6 2007 Stephen Noble <stephen@dungog.net> |
38 |
|
|
- revert mysql password creation |
39 |
|
|
- [0.9-4] |
40 |
|
|
|
41 |
|
|
* Wed Feb 14 2007 Stephen Noble <stephen@dungog.net> |
42 |
|
|
- remove phpinfo |
43 |
|
|
- simplify mysql password creation |
44 |
|
|
- don't alias / in httpd for nul values in URL |
45 |
|
|
- [0.9-3] |
46 |
|
|
|
47 |
|
|
* Thu Dec 14 2006 Stephen Noble <support@dungog.net> |
48 |
|
|
- php_admin_value eaccelerator enabled |
49 |
|
|
- [0.9-2] |
50 |
|
|
|
51 |
|
|
* Tue Dec 12 2006 Stephen Noble <support@dungog.net> |
52 |
|
|
- initial release |
53 |
|
|
- [0.9-1] |
54 |
|
|
|
55 |
|
|
%prep |
56 |
|
|
%setup |
57 |
|
|
%patch0 -p1 |
58 |
|
|
|
59 |
|
|
%build |
60 |
|
|
#perl createlinks |
61 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/roundcube |
62 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/roundcube/type |
63 |
|
|
|
64 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/roundcube |
65 |
|
|
echo "RoundCube IMAP Client" > root/etc/e-smith/db/configuration/defaults/roundcube/Name |
66 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/roundcube/PublicAccess |
67 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/roundcube/status |
68 |
|
|
echo "roundcube" > root/etc/e-smith/db/configuration/defaults/roundcube/DbName |
69 |
|
|
echo "roundcube" > root/etc/e-smith/db/configuration/defaults/roundcube/DbUser |
70 |
|
|
|
71 |
|
|
%install |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
74 |
|
|
rm -f %{name}-%{version}-filelist |
75 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
76 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
77 |
|
|
|
78 |
|
|
%clean |
79 |
|
|
cd .. |
80 |
|
|
rm -rf %{name}-%{version} |
81 |
|
|
|
82 |
|
|
%pre |
83 |
|
|
%preun |
84 |
|
|
|
85 |
|
|
%post |
86 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
87 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80roundcube |
88 |
|
|
/etc/rc.d/init.d/mysql.init start |
89 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
90 |
|
|
/sbin/e-smith/expand-template /opt/roundcube/config/db.inc.php |
91 |
|
|
/sbin/e-smith/expand-template /opt/roundcube/config/main.inc.php |
92 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
93 |
|
|
|
94 |
|
|
echo "" |
95 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
96 |
|
|
echo "current settings 'config show roundcube'..." |
97 |
|
|
/sbin/e-smith/config show roundcube |
98 |
|
|
|
99 |
|
|
%postun |
100 |
|
|
#uninstall |
101 |
|
|
if [ $1 = 0 ] ; then |
102 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
103 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
104 |
|
|
fi |
105 |
|
|
|
106 |
|
|
%files -f %{name}-%{version}-filelist |
107 |
|
|
%defattr(-,root,root) |
108 |
|
|
|