1 |
slords |
1.3 |
# $Id: smeserver-roundcube.spec,v 1.2 2008/04/02 15:03:59 slords Exp $ |
2 |
slords |
1.2 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
slords |
1.1 |
%define name smeserver-roundcube |
6 |
|
|
%define version 0.9 |
7 |
|
|
%define release 7 |
8 |
|
|
|
9 |
|
|
Summary: smserver rpm to setup roundcube, an IMAP mail client |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
Source: %{name}-%{version}.tar.gz |
14 |
|
|
Patch0: smeserver-roundcube-0.9-domain.patch |
15 |
|
|
License: GNU GPL version 2 |
16 |
|
|
URL: http://www.dungog.net/sme |
17 |
|
|
Group: SMEserver/addon |
18 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
19 |
|
|
Prefix: %{_prefix} |
20 |
|
|
BuildArchitectures: noarch |
21 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
22 |
|
|
Requires: e-smith-release >= 7.0 |
23 |
|
|
Requires: roundcube |
24 |
|
|
AutoReqProv: no |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
smserver rpm to setup the roundcube IMAP mail client. |
28 |
|
|
|
29 |
|
|
%changelog |
30 |
|
|
* Thu Jun 28 2007 Stephen Noble <stephen@dungog.net> |
31 |
|
|
- add domain property to use existing host or domain 0.9-7 |
32 |
|
|
|
33 |
|
|
* Thu Jun 21 2007 Stephen Noble <stephen@dungog.net> |
34 |
|
|
- update .spec file 0.9-6 |
35 |
|
|
|
36 |
|
|
* Thu Jun 21 2007 Stephen Noble <stephen@dungog.net> |
37 |
|
|
- automate config file creation |
38 |
|
|
- proxypass to fix https redirect bug |
39 |
|
|
- [0.9-5] |
40 |
|
|
|
41 |
|
|
* Fri Apr 6 2007 Stephen Noble <stephen@dungog.net> |
42 |
|
|
- revert mysql password creation |
43 |
|
|
- [0.9-4] |
44 |
|
|
|
45 |
|
|
* Wed Feb 14 2007 Stephen Noble <stephen@dungog.net> |
46 |
|
|
- remove phpinfo |
47 |
|
|
- simplify mysql password creation |
48 |
|
|
- don't alias / in httpd for nul values in URL |
49 |
|
|
- [0.9-3] |
50 |
|
|
|
51 |
|
|
* Thu Dec 14 2006 Stephen Noble <support@dungog.net> |
52 |
|
|
- php_admin_value eaccelerator enabled |
53 |
|
|
- [0.9-2] |
54 |
|
|
|
55 |
|
|
* Tue Dec 12 2006 Stephen Noble <support@dungog.net> |
56 |
|
|
- initial release |
57 |
|
|
- [0.9-1] |
58 |
|
|
|
59 |
|
|
%prep |
60 |
|
|
%setup |
61 |
|
|
%patch0 -p1 |
62 |
|
|
|
63 |
|
|
%build |
64 |
|
|
#perl createlinks |
65 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/roundcube |
66 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/roundcube/type |
67 |
|
|
|
68 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/roundcube |
69 |
|
|
echo "RoundCube IMAP Client" > root/etc/e-smith/db/configuration/defaults/roundcube/Name |
70 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/roundcube/PublicAccess |
71 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/roundcube/status |
72 |
|
|
echo "roundcube" > root/etc/e-smith/db/configuration/defaults/roundcube/DbName |
73 |
|
|
echo "roundcube" > root/etc/e-smith/db/configuration/defaults/roundcube/DbUser |
74 |
|
|
|
75 |
|
|
%install |
76 |
|
|
rm -rf $RPM_BUILD_ROOT |
77 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
78 |
|
|
rm -f %{name}-%{version}-filelist |
79 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
80 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
81 |
|
|
|
82 |
|
|
%clean |
83 |
|
|
cd .. |
84 |
|
|
rm -rf %{name}-%{version} |
85 |
|
|
|
86 |
|
|
%pre |
87 |
|
|
%preun |
88 |
|
|
|
89 |
|
|
%post |
90 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
91 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80roundcube |
92 |
|
|
/etc/rc.d/init.d/mysql.init start |
93 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
94 |
|
|
/sbin/e-smith/expand-template /opt/roundcube/config/db.inc.php |
95 |
|
|
/sbin/e-smith/expand-template /opt/roundcube/config/main.inc.php |
96 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
97 |
|
|
|
98 |
|
|
echo "" |
99 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
100 |
|
|
echo "current settings 'config show roundcube'..." |
101 |
|
|
/sbin/e-smith/config show roundcube |
102 |
|
|
|
103 |
|
|
%postun |
104 |
|
|
#uninstall |
105 |
|
|
if [ $1 = 0 ] ; then |
106 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
107 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
108 |
|
|
fi |
109 |
|
|
|
110 |
|
|
%files -f %{name}-%{version}-filelist |
111 |
|
|
%defattr(-,root,root) |
112 |
|
|
|