/[smecontribs]/rpms/smeserver-roundcube/contribs8/smeserver-roundcube.spec
ViewVC logotype

Annotation of /rpms/smeserver-roundcube/contribs8/smeserver-roundcube.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sun Oct 27 17:48:17 2013 UTC (10 years, 7 months ago) by unnilennium
Branch: MAIN
CVS Tags: smeserver-roundcube-0_9-15, smeserver-roundcube-0_9-15_el5_sme
Initial import of srpm

1 unnilennium 1.1 %define name smeserver-roundcube
2     %define version 0.9
3     %define release 15
4    
5     Summary: smserver rpm to setup roundcube, an IMAP mail client
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}%{?dist}
9     Source: %{name}-%{version}.tar.gz
10     Patch0: smeserver-roundcube-0.9-domain.patch
11     Patch1: smeserver-roundcube-0.9-tmp_folder.patch
12     Patch2: smeserver-roundcube-0.9-LdapAdressbooks.patch
13     Patch3: smeserver-roundcube-0.9-calendar-junk-contextmenu.patch
14     Patch4: smeserver-roundcube-0.9-force-https.patch
15     License: GNU GPL version 2
16     URL: http://www.dungog.net/sme
17     Group: SMEserver/addon
18     BuildRoot: %{_tmppath}/%{name}-buildroot
19     Prefix: %{_prefix}
20     BuildArchitectures: noarch
21     BuildRequires: e-smith-devtools
22     Requires: e-smith-release >= 8.0
23     Requires: roundcube
24     AutoReqProv: no
25    
26     %description
27     smserver rpm to setup the roundcube IMAP mail client.
28    
29     %changelog
30     * Sat Oct 26 2013 stephane de labrusse <stephdl@de-labrusse.fr> 0.9.15
31     - Change the version of roundcubemail-plugins-kolab to 3.02 : http://git.kolab.org/roundcubemail-plugins-kolab/
32    
33     * Sun Oct 20 2013 stephane de labrusse <stephdl@de-labrusse.fr> 0.9.14
34     - Change the original https_only
35    
36     * Sat Oct 13 2013 stephane de labrusse <stephdl@de-labrusse.fr> 0.9.13
37     - Add the Kolab calendar plugin : http://git.kolab.org/roundcubemail-plugins-kolab/tree/plugins/calendar
38     - Add the context menu for right click, very useful : http://www.tehinterweb.co.uk/roundcube/#picontextmenu
39     - Add the "Mark as Junk 2" to kick spam to junkmail : http://www.tehinterweb.co.uk/roundcube/#pimarkasjunk2
40    
41     * Sat Oct 5 2013 stephane de Labrusse <stephdl@de-labrusse.fr> 0.9.12
42     - Add the SME Server internal LDAP addressbooks in roundcube
43    
44     * Sat Sep 21 2013 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.9.11
45     - Add carddav functionnality http://www.crash-override.net/carddav.html
46    
47     * Wed Jun 05 2013 Stephane de Labrusse <stephdl@de-labrusse.fr> 0.9.9
48     - add a tmp folder in httpd.conf
49     * Mon Jun 03 2013 Stephane de Labrusse <stephdl@de-labrusse.fr>
50     - requires sme8 0.9-8
51    
52     * Thu Jun 28 2007 Stephen Noble <stephen@dungog.net>
53     - add domain property to use existing host or domain 0.9-7
54    
55     * Thu Jun 21 2007 Stephen Noble <stephen@dungog.net>
56     - update .spec file 0.9-6
57    
58     * Thu Jun 21 2007 Stephen Noble <stephen@dungog.net>
59     - automate config file creation
60     - proxypass to fix https redirect bug
61     - [0.9-5]
62    
63     * Fri Apr 6 2007 Stephen Noble <stephen@dungog.net>
64     - revert mysql password creation
65     - [0.9-4]
66    
67     * Wed Feb 14 2007 Stephen Noble <stephen@dungog.net>
68     - remove phpinfo
69     - simplify mysql password creation
70     - don't alias / in httpd for nul values in URL
71     - [0.9-3]
72    
73     * Thu Dec 14 2006 Stephen Noble <support@dungog.net>
74     - php_admin_value eaccelerator enabled
75     - [0.9-2]
76    
77     * Tue Dec 12 2006 Stephen Noble <support@dungog.net>
78     - initial release
79     - [0.9-1]
80    
81     %prep
82     %setup
83     %patch0 -p1
84     %patch1 -p1
85     %patch2 -p1
86     %patch3 -p1
87     %patch4 -p1
88    
89     %build
90     #perl createlinks
91     mkdir -p root/etc/e-smith/db/accounts/defaults/roundcube
92     echo "reserved" > root/etc/e-smith/db/accounts/defaults/roundcube/type
93    
94     mkdir -p root/etc/e-smith/db/configuration/defaults/roundcube
95     echo "RoundCube IMAP Client" > root/etc/e-smith/db/configuration/defaults/roundcube/Name
96     echo "global" > root/etc/e-smith/db/configuration/defaults/roundcube/PublicAccess
97     echo "enabled" > root/etc/e-smith/db/configuration/defaults/roundcube/status
98     echo "roundcube" > root/etc/e-smith/db/configuration/defaults/roundcube/DbName
99     echo "roundcube" > root/etc/e-smith/db/configuration/defaults/roundcube/DbUser
100    
101     %install
102     rm -rf $RPM_BUILD_ROOT
103     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
104     rm -f %{name}-%{version}-filelist
105     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
106     echo "%doc COPYING" >> %{name}-%{version}-filelist
107    
108     %clean
109     cd ..
110     rm -rf %{name}-%{version}
111    
112     %pre
113     %preun
114    
115     %post
116     /etc/e-smith/events/actions/initialize-default-databases
117     /sbin/e-smith/expand-template /etc/e-smith/sql/init/80roundcube
118     /etc/rc.d/init.d/mysql.init start
119     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
120     /sbin/e-smith/expand-template /opt/roundcube/config/db.inc.php
121     /sbin/e-smith/expand-template /opt/roundcube/config/main.inc.php
122     /usr/local/bin/svc -h /service/httpd-e-smith
123     #load the mysql Table of plugins
124     /usr/bin/mysql roundcube < /opt/roundcube/plugins/carddav/dbinit/mysql.sql
125     /usr/bin/mysql roundcube < /opt/roundcube/plugins/calendar/drivers/database/sql/mysql.sql
126     /usr/bin/mysql roundcube < /opt/roundcube/plugins/calendar/drivers/kolab/SQL/mysql.sql
127    
128     #show the "config show roundcube"
129     echo ""
130     echo "see http://wiki.contribs.org/RoundCube"
131     echo "current settings 'config show roundcube'..."
132     /sbin/e-smith/config show roundcube
133    
134     %postun
135     #uninstall
136     if [ $1 = 0 ] ; then
137     /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf
138     /usr/local/bin/svc -h /service/httpd-e-smith
139     fi
140    
141     %files -f %{name}-%{version}-filelist
142     %defattr(-,root,root)
143    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed