1 |
brianr |
1.1 |
%define name smeserver-rsync |
2 |
|
|
%define version 1.3 |
3 |
brianr |
1.2 |
%define release 3 |
4 |
brianr |
1.1 |
Summary: SMEserver rpm for rsync |
5 |
|
|
Name: %{name} |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
License: GNU GPL version 2 |
9 |
|
|
URL: http://www.contribs.org |
10 |
|
|
Distribution: SME Server |
11 |
|
|
Group: SMEServer/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
Patch1: smeserver-rsync-spelling-update.patch |
14 |
|
|
Packager: Stephen Noble <stephen@dungog.net> |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
Requires: e-smith-release >= 9 |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
SMEserver rpm for setting up rsync jobs with a server panel |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
brianr |
1.2 |
* Mon Dec 28 2020 Brian Read <brianr@bjsystems.co.uk> 1.3-3.sme |
27 |
|
|
- Initial import to SME10 [SME: ] |
28 |
|
|
|
29 |
brianr |
1.1 |
* Thu Apr 17 2018 John Crisp <jcrisp@safeandsoundit.co.uk> |
30 |
|
|
- Set default Options to test |
31 |
|
|
- Fix spelling 'recieve' |
32 |
|
|
- Set default status to Test |
33 |
|
|
- Modify wording [SME:9684] |
34 |
|
|
- [1.3-2] |
35 |
|
|
|
36 |
|
|
* Thu Apr 21 2016 John Crisp <jcrisp@safeandsounit.co.uk> |
37 |
|
|
- First import to smecontribs |
38 |
|
|
|
39 |
|
|
* Thu Jun 8 2006 Stephen Noble <support@dungog.net> |
40 |
|
|
- db option to allow overlaps, db dungog setprop rsync overlap allow |
41 |
|
|
- suggestion added to automate with dungog-cron |
42 |
|
|
- panel simplified, instructions moved to help |
43 |
|
|
- [1.2-7] |
44 |
|
|
|
45 |
|
|
* Tue Jun 6 2006 Stephen Noble <support@dungog.net> |
46 |
|
|
- terminate new jobs if rsync is already running |
47 |
|
|
- [1.2-6] |
48 |
|
|
|
49 |
|
|
* Wed Apr 5 2006 Stephen Noble <support@dungog.net> |
50 |
|
|
- add include and exclude directories for 'rsync to self' |
51 |
|
|
- [1.2-5] |
52 |
|
|
|
53 |
|
|
* Mon Mar 27 2006 Stephen Noble <support@dungog.net> |
54 |
|
|
- expand crontab on saves |
55 |
|
|
- remote is now user@server.net not just server.net |
56 |
|
|
- [1.2-4] |
57 |
|
|
|
58 |
|
|
* Tue Mar 14 2006 Stephen Noble <support@dungog.net> |
59 |
|
|
- fixed incorrect crontab permissions |
60 |
|
|
- [1.2-3] |
61 |
|
|
|
62 |
|
|
* Mon Oct 24 2005 Stephen Noble <support@dungog.net> |
63 |
|
|
- more bandwidth options |
64 |
|
|
- help, Advanced options |
65 |
|
|
- [1.2-2] |
66 |
|
|
|
67 |
|
|
* Thu Sep 15 2005 Stephen Noble <support@dungog.net> |
68 |
|
|
- option to run every 2,4,8,12 hours |
69 |
|
|
- [1.2-1] |
70 |
|
|
|
71 |
|
|
* Thu Aug 11 2005 Stephen Noble <support@dungog.net> |
72 |
|
|
- sme 7 version |
73 |
|
|
- [1.0-7] |
74 |
|
|
|
75 |
|
|
* Thu Aug 29 2002 Stephen Noble <stephen@dungog.net> |
76 |
|
|
- initial release |
77 |
|
|
- [0.1-1] |
78 |
|
|
|
79 |
|
|
|
80 |
|
|
%prep |
81 |
|
|
%setup |
82 |
|
|
|
83 |
|
|
%patch1 -p1 |
84 |
|
|
|
85 |
|
|
%build |
86 |
|
|
perl createlinks |
87 |
|
|
|
88 |
|
|
|
89 |
|
|
%install |
90 |
|
|
rm -rf $RPM_BUILD_ROOT |
91 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
92 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
93 |
|
|
echo "%doc " >> %{name}-%{version}-filelist |
94 |
|
|
|
95 |
|
|
%clean |
96 |
|
|
cd .. |
97 |
|
|
rm -rf %{name}-%{version} |
98 |
|
|
|
99 |
|
|
%pre |
100 |
|
|
%preun |
101 |
|
|
%post |
102 |
|
|
#new installs |
103 |
|
|
if [ $1 = 1 ] ; then |
104 |
|
|
/bin/touch /home/e-smith/db/dungog |
105 |
|
|
|
106 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
107 |
|
|
# for db in $DBS ; do |
108 |
|
|
# /sbin/e-smith/db $db set dungog-rsync panel Description "Rsync" DescriptionWeight 4863 Heading "dungog.net" HeadingWeight 4000 2>/dev/null |
109 |
|
|
# done |
110 |
|
|
fi |
111 |
|
|
|
112 |
|
|
/bin/chmod 644 /etc/crontab |
113 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
114 |
|
|
|
115 |
|
|
echo '' |
116 |
|
|
echo 'Remote server syntax changed for secure transfers from dungog-rsync-1.2-4' |
117 |
|
|
echo 'you now need to enter the user as well as the server' |
118 |
|
|
echo 'this removes the requirement of having the same user on both servers' |
119 |
|
|
echo 'but you may need to update your existing rules' |
120 |
|
|
echo '' |
121 |
|
|
|
122 |
|
|
|
123 |
|
|
%postun |
124 |
|
|
#uninstalls |
125 |
|
|
if [ $1 = 0 ] ; then |
126 |
|
|
/sbin/e-smith/expand-template /etc/crontab |
127 |
|
|
|
128 |
|
|
/bin/rm -rf /usr/bin/dungogrsync-????? |
129 |
|
|
|
130 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
131 |
|
|
# for db in $DBS ; do |
132 |
|
|
# /sbin/e-smith/db $db delete dungog-rsync 2>/dev/null |
133 |
|
|
# done |
134 |
|
|
|
135 |
|
|
fi |
136 |
|
|
|
137 |
|
|
#&upgrades |
138 |
|
|
|
139 |
|
|
|
140 |
|
|
%files -f %{name}-%{version}-filelist |
141 |
|
|
%defattr(-,root,root) |