1 |
%define name smeserver-rsync |
2 |
%define version 1.3 |
3 |
%define release 4 |
4 |
Summary: SMEserver rpm for rsync |
5 |
Name: %{name} |
6 |
Version: %{version} |
7 |
Release: %{release} |
8 |
License: GNU GPL version 2 |
9 |
URL: http://www.contribs.org |
10 |
Distribution: SME Server |
11 |
Group: SMEServer/addon |
12 |
Source: %{name}-%{version}.tar.gz |
13 |
Patch1: smeserver-rsync-spelling-update.patch |
14 |
Patch2: smeserver-rsync-1.3-locale-2024-03-21.patch |
15 |
Packager: Stephen Noble <stephen@dungog.net> |
16 |
BuildRoot: /var/tmp/%{name}-%{version} |
17 |
BuildArchitectures: noarch |
18 |
BuildRequires: e-smith-devtools |
19 |
Requires: e-smith-release >= 9 |
20 |
AutoReqProv: no |
21 |
|
22 |
|
23 |
%description |
24 |
SMEserver rpm for setting up rsync jobs with a server panel |
25 |
|
26 |
%changelog |
27 |
* Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 1.3-4.sme |
28 |
- add locale 2024-03-21.patch |
29 |
|
30 |
* Mon Dec 28 2020 Brian Read <brianr@bjsystems.co.uk> 1.3-3.sme |
31 |
- Initial import to SME10 [SME: ] |
32 |
|
33 |
* Thu Apr 17 2018 John Crisp <jcrisp@safeandsoundit.co.uk> |
34 |
- Set default Options to test |
35 |
- Fix spelling 'recieve' |
36 |
- Set default status to Test |
37 |
- Modify wording [SME:9684] |
38 |
- [1.3-2] |
39 |
|
40 |
* Thu Apr 21 2016 John Crisp <jcrisp@safeandsounit.co.uk> |
41 |
- First import to smecontribs |
42 |
|
43 |
* Thu Jun 8 2006 Stephen Noble <support@dungog.net> |
44 |
- db option to allow overlaps, db dungog setprop rsync overlap allow |
45 |
- suggestion added to automate with dungog-cron |
46 |
- panel simplified, instructions moved to help |
47 |
- [1.2-7] |
48 |
|
49 |
* Tue Jun 6 2006 Stephen Noble <support@dungog.net> |
50 |
- terminate new jobs if rsync is already running |
51 |
- [1.2-6] |
52 |
|
53 |
* Wed Apr 5 2006 Stephen Noble <support@dungog.net> |
54 |
- add include and exclude directories for 'rsync to self' |
55 |
- [1.2-5] |
56 |
|
57 |
* Mon Mar 27 2006 Stephen Noble <support@dungog.net> |
58 |
- expand crontab on saves |
59 |
- remote is now user@server.net not just server.net |
60 |
- [1.2-4] |
61 |
|
62 |
* Tue Mar 14 2006 Stephen Noble <support@dungog.net> |
63 |
- fixed incorrect crontab permissions |
64 |
- [1.2-3] |
65 |
|
66 |
* Mon Oct 24 2005 Stephen Noble <support@dungog.net> |
67 |
- more bandwidth options |
68 |
- help, Advanced options |
69 |
- [1.2-2] |
70 |
|
71 |
* Thu Sep 15 2005 Stephen Noble <support@dungog.net> |
72 |
- option to run every 2,4,8,12 hours |
73 |
- [1.2-1] |
74 |
|
75 |
* Thu Aug 11 2005 Stephen Noble <support@dungog.net> |
76 |
- sme 7 version |
77 |
- [1.0-7] |
78 |
|
79 |
* Thu Aug 29 2002 Stephen Noble <stephen@dungog.net> |
80 |
- initial release |
81 |
- [0.1-1] |
82 |
|
83 |
|
84 |
%prep |
85 |
%setup |
86 |
|
87 |
%patch1 -p1 |
88 |
%patch2 -p1 |
89 |
|
90 |
%build |
91 |
perl createlinks |
92 |
|
93 |
|
94 |
%install |
95 |
rm -rf $RPM_BUILD_ROOT |
96 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
97 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
98 |
echo "%doc " >> %{name}-%{version}-filelist |
99 |
|
100 |
%clean |
101 |
cd .. |
102 |
rm -rf %{name}-%{version} |
103 |
|
104 |
%pre |
105 |
%preun |
106 |
%post |
107 |
#new installs |
108 |
if [ $1 = 1 ] ; then |
109 |
/bin/touch /home/e-smith/db/dungog |
110 |
|
111 |
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
112 |
# for db in $DBS ; do |
113 |
# /sbin/e-smith/db $db set dungog-rsync panel Description "Rsync" DescriptionWeight 4863 Heading "dungog.net" HeadingWeight 4000 2>/dev/null |
114 |
# done |
115 |
fi |
116 |
|
117 |
/bin/chmod 644 /etc/crontab |
118 |
/etc/e-smith/events/actions/initialize-default-databases |
119 |
|
120 |
echo '' |
121 |
echo 'Remote server syntax changed for secure transfers from dungog-rsync-1.2-4' |
122 |
echo 'you now need to enter the user as well as the server' |
123 |
echo 'this removes the requirement of having the same user on both servers' |
124 |
echo 'but you may need to update your existing rules' |
125 |
echo '' |
126 |
|
127 |
|
128 |
%postun |
129 |
#uninstalls |
130 |
if [ $1 = 0 ] ; then |
131 |
/sbin/e-smith/expand-template /etc/crontab |
132 |
|
133 |
/bin/rm -rf /usr/bin/dungogrsync-????? |
134 |
|
135 |
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
136 |
# for db in $DBS ; do |
137 |
# /sbin/e-smith/db $db delete dungog-rsync 2>/dev/null |
138 |
# done |
139 |
|
140 |
fi |
141 |
|
142 |
#&upgrades |
143 |
|
144 |
|
145 |
%files -f %{name}-%{version}-filelist |
146 |
%defattr(-,root,root) |