1 |
%define name smeserver-rsync |
2 |
%define version 1.3 |
3 |
%define release 1 |
4 |
Summary: SMEserver rpm for rsync |
5 |
Name: %{name} |
6 |
Version: %{version} |
7 |
Release: %{release} |
8 |
License: GNU GPL version 2 |
9 |
URL: http://www.contribs.org |
10 |
Distribution: SME Server |
11 |
Group: SMEServer/addon |
12 |
Source: %{name}-%{version}.tar.gz |
13 |
Packager: Stephen Noble <stephen@dungog.net> |
14 |
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
BuildArchitectures: noarch |
16 |
BuildRequires: e-smith-devtools |
17 |
Requires: e-smith-release >= 8 |
18 |
AutoReqProv: no |
19 |
|
20 |
%description |
21 |
SMEserver rpm for setting up rsync jobs with a server panel |
22 |
|
23 |
%changelog |
24 |
* Thu Apr 21 2016 John Crisp <jcrisp@safeandsounit.co.uk> |
25 |
- First import to smecontribs |
26 |
|
27 |
* Thu Jun 8 2006 Stephen Noble <support@dungog.net> |
28 |
- db option to allow overlaps, db dungog setprop rsync overlap allow |
29 |
- suggestion added to automate with dungog-cron |
30 |
- panel simplified, instructions moved to help |
31 |
- [1.2-7] |
32 |
|
33 |
* Tue Jun 6 2006 Stephen Noble <support@dungog.net> |
34 |
- terminate new jobs if rsync is already running |
35 |
- [1.2-6] |
36 |
|
37 |
* Wed Apr 5 2006 Stephen Noble <support@dungog.net> |
38 |
- add include and exclude directories for 'rsync to self' |
39 |
- [1.2-5] |
40 |
|
41 |
* Mon Mar 27 2006 Stephen Noble <support@dungog.net> |
42 |
- expand crontab on saves |
43 |
- remote is now user@server.net not just server.net |
44 |
- [1.2-4] |
45 |
|
46 |
* Tue Mar 14 2006 Stephen Noble <support@dungog.net> |
47 |
- fixed incorrect crontab permissions |
48 |
- [1.2-3] |
49 |
|
50 |
* Mon Oct 24 2005 Stephen Noble <support@dungog.net> |
51 |
- more bandwidth options |
52 |
- help, Advanced options |
53 |
- [1.2-2] |
54 |
|
55 |
* Thu Sep 15 2005 Stephen Noble <support@dungog.net> |
56 |
- option to run every 2,4,8,12 hours |
57 |
- [1.2-1] |
58 |
|
59 |
* Thu Aug 11 2005 Stephen Noble <support@dungog.net> |
60 |
- sme 7 version |
61 |
- [1.0-7] |
62 |
|
63 |
* Thu Aug 29 2002 Stephen Noble <stephen@dungog.net> |
64 |
- initial release |
65 |
- [0.1-1] |
66 |
|
67 |
|
68 |
%prep |
69 |
%setup |
70 |
|
71 |
%build |
72 |
perl createlinks |
73 |
|
74 |
|
75 |
%install |
76 |
rm -rf $RPM_BUILD_ROOT |
77 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
78 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
79 |
echo "%doc " >> %{name}-%{version}-filelist |
80 |
|
81 |
%clean |
82 |
cd .. |
83 |
rm -rf %{name}-%{version} |
84 |
|
85 |
%pre |
86 |
%preun |
87 |
%post |
88 |
#new installs |
89 |
if [ $1 = 1 ] ; then |
90 |
/bin/touch /home/e-smith/db/dungog |
91 |
|
92 |
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
93 |
# for db in $DBS ; do |
94 |
# /sbin/e-smith/db $db set dungog-rsync panel Description "Rsync" DescriptionWeight 4863 Heading "dungog.net" HeadingWeight 4000 2>/dev/null |
95 |
# done |
96 |
fi |
97 |
|
98 |
/bin/chmod 644 /etc/crontab |
99 |
/etc/e-smith/events/actions/initialize-default-databases |
100 |
|
101 |
echo '' |
102 |
echo 'Remote server syntax changed for secure transfers from dungog-rsync-1.2-4' |
103 |
echo 'you now need to enter the user as well as the server' |
104 |
echo 'this removes the requirement of having the same user on both servers' |
105 |
echo 'but you may need to update your existing rules' |
106 |
echo '' |
107 |
|
108 |
|
109 |
%postun |
110 |
#uninstalls |
111 |
if [ $1 = 0 ] ; then |
112 |
/sbin/e-smith/expand-template /etc/crontab |
113 |
|
114 |
/bin/rm -rf /usr/bin/dungogrsync-????? |
115 |
|
116 |
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
117 |
# for db in $DBS ; do |
118 |
# /sbin/e-smith/db $db delete dungog-rsync 2>/dev/null |
119 |
# done |
120 |
|
121 |
fi |
122 |
|
123 |
#&upgrades |
124 |
|
125 |
|
126 |
%files -f %{name}-%{version}-filelist |
127 |
%defattr(-,root,root) |