1 |
%define name smeserver-rsync |
2 |
%define version 1.3 |
3 |
%define release 2 |
4 |
Summary: SMEserver rpm for rsync |
5 |
Name: %{name} |
6 |
Version: %{version} |
7 |
Release: %{release} |
8 |
License: GNU GPL version 2 |
9 |
URL: http://www.contribs.org |
10 |
Distribution: SME Server |
11 |
Group: SMEServer/addon |
12 |
Source: %{name}-%{version}.tar.gz |
13 |
Patch1: smeserver-rsync-spelling-update.patch |
14 |
Packager: Stephen Noble <stephen@dungog.net> |
15 |
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
BuildArchitectures: noarch |
17 |
BuildRequires: e-smith-devtools |
18 |
Requires: e-smith-release >= 9 |
19 |
AutoReqProv: no |
20 |
|
21 |
|
22 |
%description |
23 |
SMEserver rpm for setting up rsync jobs with a server panel |
24 |
|
25 |
%changelog |
26 |
* Thu Apr 17 2018 John Crisp <jcrisp@safeandsoundit.co.uk> |
27 |
- Set default Options to test |
28 |
- Fix spelling 'recieve' |
29 |
- Set default status to Test |
30 |
- Modify wording [SME:9684] |
31 |
- [1.3-2] |
32 |
|
33 |
* Thu Apr 21 2016 John Crisp <jcrisp@safeandsounit.co.uk> |
34 |
- First import to smecontribs |
35 |
|
36 |
* Thu Jun 8 2006 Stephen Noble <support@dungog.net> |
37 |
- db option to allow overlaps, db dungog setprop rsync overlap allow |
38 |
- suggestion added to automate with dungog-cron |
39 |
- panel simplified, instructions moved to help |
40 |
- [1.2-7] |
41 |
|
42 |
* Tue Jun 6 2006 Stephen Noble <support@dungog.net> |
43 |
- terminate new jobs if rsync is already running |
44 |
- [1.2-6] |
45 |
|
46 |
* Wed Apr 5 2006 Stephen Noble <support@dungog.net> |
47 |
- add include and exclude directories for 'rsync to self' |
48 |
- [1.2-5] |
49 |
|
50 |
* Mon Mar 27 2006 Stephen Noble <support@dungog.net> |
51 |
- expand crontab on saves |
52 |
- remote is now user@server.net not just server.net |
53 |
- [1.2-4] |
54 |
|
55 |
* Tue Mar 14 2006 Stephen Noble <support@dungog.net> |
56 |
- fixed incorrect crontab permissions |
57 |
- [1.2-3] |
58 |
|
59 |
* Mon Oct 24 2005 Stephen Noble <support@dungog.net> |
60 |
- more bandwidth options |
61 |
- help, Advanced options |
62 |
- [1.2-2] |
63 |
|
64 |
* Thu Sep 15 2005 Stephen Noble <support@dungog.net> |
65 |
- option to run every 2,4,8,12 hours |
66 |
- [1.2-1] |
67 |
|
68 |
* Thu Aug 11 2005 Stephen Noble <support@dungog.net> |
69 |
- sme 7 version |
70 |
- [1.0-7] |
71 |
|
72 |
* Thu Aug 29 2002 Stephen Noble <stephen@dungog.net> |
73 |
- initial release |
74 |
- [0.1-1] |
75 |
|
76 |
|
77 |
%prep |
78 |
%setup |
79 |
|
80 |
%patch1 -p1 |
81 |
|
82 |
%build |
83 |
perl createlinks |
84 |
|
85 |
|
86 |
%install |
87 |
rm -rf $RPM_BUILD_ROOT |
88 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
89 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
90 |
echo "%doc " >> %{name}-%{version}-filelist |
91 |
|
92 |
%clean |
93 |
cd .. |
94 |
rm -rf %{name}-%{version} |
95 |
|
96 |
%pre |
97 |
%preun |
98 |
%post |
99 |
#new installs |
100 |
if [ $1 = 1 ] ; then |
101 |
/bin/touch /home/e-smith/db/dungog |
102 |
|
103 |
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
104 |
# for db in $DBS ; do |
105 |
# /sbin/e-smith/db $db set dungog-rsync panel Description "Rsync" DescriptionWeight 4863 Heading "dungog.net" HeadingWeight 4000 2>/dev/null |
106 |
# done |
107 |
fi |
108 |
|
109 |
/bin/chmod 644 /etc/crontab |
110 |
/etc/e-smith/events/actions/initialize-default-databases |
111 |
|
112 |
echo '' |
113 |
echo 'Remote server syntax changed for secure transfers from dungog-rsync-1.2-4' |
114 |
echo 'you now need to enter the user as well as the server' |
115 |
echo 'this removes the requirement of having the same user on both servers' |
116 |
echo 'but you may need to update your existing rules' |
117 |
echo '' |
118 |
|
119 |
|
120 |
%postun |
121 |
#uninstalls |
122 |
if [ $1 = 0 ] ; then |
123 |
/sbin/e-smith/expand-template /etc/crontab |
124 |
|
125 |
/bin/rm -rf /usr/bin/dungogrsync-????? |
126 |
|
127 |
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
128 |
# for db in $DBS ; do |
129 |
# /sbin/e-smith/db $db delete dungog-rsync 2>/dev/null |
130 |
# done |
131 |
|
132 |
fi |
133 |
|
134 |
#&upgrades |
135 |
|
136 |
|
137 |
%files -f %{name}-%{version}-filelist |
138 |
%defattr(-,root,root) |