1 |
jpp |
1.1 |
# $Id: smeserver-sarg.spec,v 1.1 2013/03/03 22:03:08 unnilennium Exp $ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: SME server Sarg |
6 |
|
|
%define name smeserver-sarg |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 2.3.1 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache/php/caching |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
Requires: smeserver-release >= 9 |
19 |
|
|
Requires: sarg >= 2.3.1 |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Tue Dec 16 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 2.3.1-1.sme |
24 |
|
|
-first release to sme9 |
25 |
|
|
-thanks to Philippe Desrosiers <pdesrosier@aei.ca> for this work |
26 |
|
|
|
27 |
|
|
* Fri Sep 18 2009 Stephen Noble <support@dungog.net> 2.2.1-6.sme |
28 |
|
|
- allow valid userpanel users access [SME 2931] |
29 |
|
|
|
30 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
31 |
|
|
- add db setting for lastlog correctly |
32 |
|
|
- [2.2.1-4] |
33 |
|
|
|
34 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
35 |
|
|
- remove duplicate access_log [sme 2217] |
36 |
|
|
- add db setting for lastlog, ie 365 = 1yr |
37 |
|
|
- [2.2.1-3] |
38 |
|
|
|
39 |
|
|
* Tue Nov 14 2006 Stephen Noble <support@dungog.net> |
40 |
|
|
- requires sarg >= 2.2 |
41 |
|
|
- cosmetic update of /var/www/sarg/index.htm |
42 |
|
|
- [2.2.1-2] |
43 |
|
|
|
44 |
|
|
* Tue Oct 17 2006 Stephen Noble <support@dungog.net> |
45 |
|
|
- update to sarg 2.2.1 |
46 |
|
|
- removed sarg binary, use seperate sarg rpm + dependancies |
47 |
|
|
- [2.2.1-1] |
48 |
|
|
|
49 |
|
|
* Tue Oct 17 2006 Stephen Noble <support@dungog.net> |
50 |
|
|
- add index.html files to avoid confusion and 404 errors |
51 |
|
|
- removed -p option (ip only) now sorts users as well |
52 |
|
|
- [1.4.1-6] |
53 |
|
|
|
54 |
|
|
* Sun Oct 15 2006 Stephen Noble <support@dungog.net> |
55 |
|
|
- db setting to use dansguardian instead of squid |
56 |
|
|
- /usr/bin/sarglog [squid|dansguardian] |
57 |
|
|
|
58 |
|
|
* Sun Oct 08 2006 Michel Van hees <michel@vanhees.cc> |
59 |
|
|
- Bug fixing in cron script |
60 |
|
|
- Make report by name and by ip |
61 |
|
|
|
62 |
|
|
* Mon May 22 2006 Michel Van hees <michel@vanhees.cc> |
63 |
|
|
- Bug fixing |
64 |
|
|
|
65 |
|
|
* Tue May 9 2006 Michel Van hees <michel@vanhees.cc> |
66 |
|
|
- Integrate binary |
67 |
|
|
|
68 |
|
|
* Sun May 7 2006 Michel Van hees <michel@vanhees.cc> |
69 |
|
|
- Debug cron job |
70 |
|
|
|
71 |
|
|
* Mon May 1 2006 Michel Van hees <michel@vanhees.cc> |
72 |
|
|
- start developpement |
73 |
|
|
|
74 |
|
|
%description |
75 |
|
|
Sarg templates for SME Server release 7 |
76 |
|
|
|
77 |
|
|
%prep |
78 |
|
|
%setup |
79 |
|
|
|
80 |
|
|
%build |
81 |
|
|
perl createlinks |
82 |
|
|
%{__mkdir_p} root/usr/share/sarg/ |
83 |
|
|
#%{__mkdir_p} root/etc/sarg/images/ |
84 |
|
|
#%{__mkdir_p} root/etc/sarg/languages/ |
85 |
|
|
#%{__mkdir_p} root/etc/sarg/fonts/ |
86 |
|
|
|
87 |
|
|
|
88 |
|
|
|
89 |
|
|
#mkdir -p root/etc/e-smith/db/configuration/defaults/sarg |
90 |
|
|
#echo "service" > root/etc/e-smith/db/configuration/defaults/sarg/type |
91 |
|
|
#echo "squid" > root/etc/e-smith/db/configuration/defaults/sarg/logfile |
92 |
|
|
#echo "English" > root/etc/e-smith/db/configuration/defaults/sarg/language |
93 |
|
|
#echo "bytes" > root/etc/e-smith/db/configuration/defaults/sarg/values |
94 |
|
|
|
95 |
|
|
%install |
96 |
|
|
rm -rf $RPM_BUILD_ROOT |
97 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
98 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
99 |
|
|
--file '/usr/bin/sarglog' 'attr(755,root,root)' \ |
100 |
|
|
> %{name}-%{version}-filelist |
101 |
|
|
echo "%doc " >> %{name}-%{version}-filelist |
102 |
|
|
|
103 |
|
|
%clean |
104 |
|
|
rm -rf $RPM_BUILD_ROOT |
105 |
|
|
|
106 |
|
|
%pre |
107 |
|
|
|
108 |
|
|
%preun |
109 |
|
|
%post |
110 |
|
|
if [ $1 = 1 ] ; then |
111 |
|
|
/bin/ln -s /etc/sarg/fonts/ /usr/share/sarg/ |
112 |
|
|
/bin/ln -s /etc/sarg/languages/ /usr/share/sarg/ |
113 |
|
|
/bin/ln -s /etc/sarg/images/ /usr/share/sarg/ |
114 |
|
|
fi |
115 |
|
|
#new installs |
116 |
|
|
#if [ $1 = 1 ] ; then |
117 |
|
|
# /sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
118 |
|
|
# /etc/rc.d/init.d/httpd-e-smith sigusr1 |
119 |
|
|
# /etc/e-smith/events/actions/navigation-conf > /dev/null 2>&1 |
120 |
|
|
#fi |
121 |
|
|
|
122 |
|
|
#/sbin/e-smith/expand-template /etc/sarg/sarg.conf |
123 |
|
|
#/sbin/e-smith/expand-template /etc/cron.daily/sarg |
124 |
|
|
#/sbin/e-smith/expand-template /etc/cron.weekly/sarg |
125 |
|
|
#/sbin/e-smith/expand-template /etc/cron.monthly/sarg |
126 |
|
|
|
127 |
|
|
|
128 |
|
|
#/etc/e-smith/events/actions/initialize-default-databases |
129 |
|
|
|
130 |
|
|
echo '' |
131 |
|
|
echo 'optional settings for sarg, first option is default' |
132 |
|
|
echo '' |
133 |
|
|
#echo 'config setprop sarg language [English|Dutch|French|German|Spanish|Italian|...]' |
134 |
|
|
echo 'config setprop sarg values [bytes|abbreviation]' |
135 |
|
|
echo 'config setprop sarg logfile [squid|dansguardian]' |
136 |
|
|
echo 'config setprop sarg lastlog [0|365|num.of.days.to.keep.logs]' |
137 |
|
|
echo '' |
138 |
|
|
echo 'expand-templates shortcut with /usr/bin/sarglog' |
139 |
|
|
echo "sarglog (squid|dansguardian)" |
140 |
|
|
echo '' |
141 |
|
|
echo 'or' |
142 |
|
|
echo 'config setprop sarg logfile [squid|dansguardian]' |
143 |
|
|
echo 'signal-event sarg-update' |
144 |
|
|
echo '' |
145 |
|
|
|
146 |
|
|
%postun |
147 |
|
|
#uninstalls |
148 |
|
|
if [ $1 = 0 ] ; then |
149 |
|
|
DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
150 |
|
|
for db in $DBS ; do |
151 |
|
|
/sbin/e-smith/db $db delete sarg 2>/dev/null |
152 |
|
|
done |
153 |
|
|
|
154 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
155 |
|
|
/etc/rc.d/init.d/httpd-e-smith sigusr1 |
156 |
|
|
fi |
157 |
|
|
|
158 |
|
|
%files -f %{name}-%{version}-filelist |
159 |
|
|
%defattr(-,root,root) |