1 |
slords |
1.3 |
# $Id: smeserver-sarg.spec,v 1.2 2008/04/02 15:03:59 slords Exp $ |
2 |
slords |
1.2 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: SME server Sarg |
6 |
|
|
%define name smeserver-sarg |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 2.2.1 |
9 |
|
|
%define release 4 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache/php/caching |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
Requires: smeserver-release >= 7 |
19 |
|
|
Requires: sarg >= 2.2 |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
24 |
|
|
- add db setting for lastlog correctly |
25 |
|
|
- [2.2.1-4] |
26 |
|
|
|
27 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
28 |
|
|
- remove duplicate access_log [sme 2217] |
29 |
|
|
- add db setting for lastlog, ie 365 = 1yr |
30 |
|
|
- [2.2.1-3] |
31 |
|
|
|
32 |
|
|
* Tue Nov 14 2006 Stephen Noble <support@dungog.net> |
33 |
|
|
- requires sarg >= 2.2 |
34 |
|
|
- cosmetic update of /var/www/sarg/index.htm |
35 |
|
|
- [2.2.1-2] |
36 |
|
|
|
37 |
|
|
* Tue Oct 17 2006 Stephen Noble <support@dungog.net> |
38 |
|
|
- update to sarg 2.2.1 |
39 |
|
|
- removed sarg binary, use seperate sarg rpm + dependancies |
40 |
|
|
- [2.2.1-1] |
41 |
|
|
|
42 |
|
|
* Tue Oct 17 2006 Stephen Noble <support@dungog.net> |
43 |
|
|
- add index.html files to avoid confusion and 404 errors |
44 |
|
|
- removed -p option (ip only) now sorts users as well |
45 |
|
|
- [1.4.1-6] |
46 |
|
|
|
47 |
|
|
* Sun Oct 15 2006 Stephen Noble <support@dungog.net> |
48 |
|
|
- db setting to use dansguardian instead of squid |
49 |
|
|
- /usr/bin/sarglog [squid|dansguardian] |
50 |
|
|
|
51 |
|
|
* Sun Oct 08 2006 Michel Van hees <michel@vanhees.cc> |
52 |
|
|
- Bug fixing in cron script |
53 |
|
|
- Make report by name and by ip |
54 |
|
|
|
55 |
|
|
* Mon May 22 2006 Michel Van hees <michel@vanhees.cc> |
56 |
|
|
- Bug fixing |
57 |
|
|
|
58 |
|
|
* Tue May 9 2006 Michel Van hees <michel@vanhees.cc> |
59 |
|
|
- Integrate binary |
60 |
|
|
|
61 |
|
|
* Sun May 7 2006 Michel Van hees <michel@vanhees.cc> |
62 |
|
|
- Debug cron job |
63 |
|
|
|
64 |
|
|
* Mon May 1 2006 Michel Van hees <michel@vanhees.cc> |
65 |
|
|
- start developpement |
66 |
|
|
|
67 |
|
|
%description |
68 |
|
|
Sarg templates for SME Server release 7 |
69 |
|
|
|
70 |
|
|
%prep |
71 |
|
|
%setup |
72 |
|
|
|
73 |
|
|
%build |
74 |
|
|
perl createlinks |
75 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/sarg |
76 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/sarg/type |
77 |
|
|
echo "squid" > root/etc/e-smith/db/configuration/defaults/sarg/logfile |
78 |
|
|
echo "English" > root/etc/e-smith/db/configuration/defaults/sarg/language |
79 |
|
|
echo "bytes" > root/etc/e-smith/db/configuration/defaults/sarg/values |
80 |
|
|
|
81 |
|
|
%install |
82 |
|
|
rm -rf $RPM_BUILD_ROOT |
83 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
84 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
85 |
|
|
--file '/usr/bin/sarglog' 'attr(755,root,root)' \ |
86 |
|
|
> %{name}-%{version}-filelist |
87 |
|
|
echo "%doc " >> %{name}-%{version}-filelist |
88 |
|
|
|
89 |
|
|
%clean |
90 |
|
|
rm -rf $RPM_BUILD_ROOT |
91 |
|
|
|
92 |
|
|
%pre |
93 |
|
|
|
94 |
|
|
%preun |
95 |
|
|
%post |
96 |
|
|
#new installs |
97 |
|
|
if [ $1 = 1 ] ; then |
98 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
99 |
|
|
/etc/rc.d/init.d/httpd-e-smith sigusr1 |
100 |
|
|
/etc/e-smith/events/actions/navigation-conf > /dev/null 2>&1 |
101 |
|
|
fi |
102 |
|
|
|
103 |
|
|
/sbin/e-smith/expand-template /etc/sarg/sarg.conf |
104 |
|
|
/sbin/e-smith/expand-template /etc/cron.daily/sarg |
105 |
|
|
/sbin/e-smith/expand-template /etc/cron.weekly/sarg |
106 |
|
|
/sbin/e-smith/expand-template /etc/cron.monthly/sarg |
107 |
|
|
|
108 |
|
|
|
109 |
|
|
#/etc/e-smith/events/actions/initialize-default-databases |
110 |
|
|
|
111 |
|
|
echo '' |
112 |
|
|
echo 'optional settings for sarg, first option is default' |
113 |
|
|
echo '' |
114 |
|
|
echo 'config setprop sarg language [English|Dutch|French|German|Spanish|Italian|...]' |
115 |
|
|
echo 'config setprop sarg values [bytes|abbreviation]' |
116 |
|
|
echo 'config setprop sarg logfile [squid|dansguardian]' |
117 |
|
|
echo 'config setprop sarg lastlog [0|365|num.of.days.to.keep.logs]' |
118 |
|
|
echo '' |
119 |
|
|
echo 'expand-templates shortcut with /usr/bin/sarglog' |
120 |
|
|
echo '' |
121 |
|
|
|
122 |
|
|
|
123 |
|
|
%postun |
124 |
|
|
#uninstalls |
125 |
|
|
if [ $1 = 0 ] ; then |
126 |
|
|
DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
127 |
|
|
for db in $DBS ; do |
128 |
|
|
/sbin/e-smith/db $db delete sarg 2>/dev/null |
129 |
|
|
done |
130 |
|
|
|
131 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
132 |
|
|
/etc/rc.d/init.d/httpd-e-smith sigusr1 |
133 |
|
|
fi |
134 |
|
|
|
135 |
|
|
%files -f %{name}-%{version}-filelist |
136 |
|
|
%defattr(-,root,root) |