1 |
unnilennium |
1.1 |
# $Id: smeserver-sarg.spec,v 1.7 2009/09/18 10:22:52 dungog Exp $ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: SME server Sarg |
6 |
|
|
%define name smeserver-sarg |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 2.2.1 |
9 |
|
|
%define release 6 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache/php/caching |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
Patch0: smeserver-sarg-2.2.1-validuser2.patch |
16 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
Requires: smeserver-release >= 7 |
20 |
|
|
Requires: sarg >= 2.2 |
21 |
|
|
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Fri Sep 18 2009 Stephen Noble <support@dungog.net> 2.2.1-6.sme |
25 |
|
|
- allow valid userpanel users access [SME 2931] |
26 |
|
|
|
27 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
28 |
|
|
- add db setting for lastlog correctly |
29 |
|
|
- [2.2.1-4] |
30 |
|
|
|
31 |
|
|
* Tue Jan 9 2007 Stephen Noble <support@dungog.net> |
32 |
|
|
- remove duplicate access_log [sme 2217] |
33 |
|
|
- add db setting for lastlog, ie 365 = 1yr |
34 |
|
|
- [2.2.1-3] |
35 |
|
|
|
36 |
|
|
* Tue Nov 14 2006 Stephen Noble <support@dungog.net> |
37 |
|
|
- requires sarg >= 2.2 |
38 |
|
|
- cosmetic update of /var/www/sarg/index.htm |
39 |
|
|
- [2.2.1-2] |
40 |
|
|
|
41 |
|
|
* Tue Oct 17 2006 Stephen Noble <support@dungog.net> |
42 |
|
|
- update to sarg 2.2.1 |
43 |
|
|
- removed sarg binary, use seperate sarg rpm + dependancies |
44 |
|
|
- [2.2.1-1] |
45 |
|
|
|
46 |
|
|
* Tue Oct 17 2006 Stephen Noble <support@dungog.net> |
47 |
|
|
- add index.html files to avoid confusion and 404 errors |
48 |
|
|
- removed -p option (ip only) now sorts users as well |
49 |
|
|
- [1.4.1-6] |
50 |
|
|
|
51 |
|
|
* Sun Oct 15 2006 Stephen Noble <support@dungog.net> |
52 |
|
|
- db setting to use dansguardian instead of squid |
53 |
|
|
- /usr/bin/sarglog [squid|dansguardian] |
54 |
|
|
|
55 |
|
|
* Sun Oct 08 2006 Michel Van hees <michel@vanhees.cc> |
56 |
|
|
- Bug fixing in cron script |
57 |
|
|
- Make report by name and by ip |
58 |
|
|
|
59 |
|
|
* Mon May 22 2006 Michel Van hees <michel@vanhees.cc> |
60 |
|
|
- Bug fixing |
61 |
|
|
|
62 |
|
|
* Tue May 9 2006 Michel Van hees <michel@vanhees.cc> |
63 |
|
|
- Integrate binary |
64 |
|
|
|
65 |
|
|
* Sun May 7 2006 Michel Van hees <michel@vanhees.cc> |
66 |
|
|
- Debug cron job |
67 |
|
|
|
68 |
|
|
* Mon May 1 2006 Michel Van hees <michel@vanhees.cc> |
69 |
|
|
- start developpement |
70 |
|
|
|
71 |
|
|
%description |
72 |
|
|
Sarg templates for SME Server release 7 |
73 |
|
|
|
74 |
|
|
%prep |
75 |
|
|
%setup |
76 |
|
|
%patch0 -p1 |
77 |
|
|
|
78 |
|
|
%build |
79 |
|
|
perl createlinks |
80 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/sarg |
81 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/sarg/type |
82 |
|
|
echo "squid" > root/etc/e-smith/db/configuration/defaults/sarg/logfile |
83 |
|
|
echo "English" > root/etc/e-smith/db/configuration/defaults/sarg/language |
84 |
|
|
echo "bytes" > root/etc/e-smith/db/configuration/defaults/sarg/values |
85 |
|
|
|
86 |
|
|
%install |
87 |
|
|
rm -rf $RPM_BUILD_ROOT |
88 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
89 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
90 |
|
|
--file '/usr/bin/sarglog' 'attr(755,root,root)' \ |
91 |
|
|
> %{name}-%{version}-filelist |
92 |
|
|
echo "%doc " >> %{name}-%{version}-filelist |
93 |
|
|
|
94 |
|
|
%clean |
95 |
|
|
rm -rf $RPM_BUILD_ROOT |
96 |
|
|
|
97 |
|
|
%pre |
98 |
|
|
|
99 |
|
|
%preun |
100 |
|
|
%post |
101 |
|
|
#new installs |
102 |
|
|
if [ $1 = 1 ] ; then |
103 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
104 |
|
|
/etc/rc.d/init.d/httpd-e-smith sigusr1 |
105 |
|
|
/etc/e-smith/events/actions/navigation-conf > /dev/null 2>&1 |
106 |
|
|
fi |
107 |
|
|
|
108 |
|
|
/sbin/e-smith/expand-template /etc/sarg/sarg.conf |
109 |
|
|
/sbin/e-smith/expand-template /etc/cron.daily/sarg |
110 |
|
|
/sbin/e-smith/expand-template /etc/cron.weekly/sarg |
111 |
|
|
/sbin/e-smith/expand-template /etc/cron.monthly/sarg |
112 |
|
|
|
113 |
|
|
|
114 |
|
|
#/etc/e-smith/events/actions/initialize-default-databases |
115 |
|
|
|
116 |
|
|
echo '' |
117 |
|
|
echo 'optional settings for sarg, first option is default' |
118 |
|
|
echo '' |
119 |
|
|
echo 'config setprop sarg language [English|Dutch|French|German|Spanish|Italian|...]' |
120 |
|
|
echo 'config setprop sarg values [bytes|abbreviation]' |
121 |
|
|
echo 'config setprop sarg logfile [squid|dansguardian]' |
122 |
|
|
echo 'config setprop sarg lastlog [0|365|num.of.days.to.keep.logs]' |
123 |
|
|
echo '' |
124 |
|
|
echo 'expand-templates shortcut with /usr/bin/sarglog' |
125 |
|
|
echo '' |
126 |
|
|
|
127 |
|
|
|
128 |
|
|
%postun |
129 |
|
|
#uninstalls |
130 |
|
|
if [ $1 = 0 ] ; then |
131 |
|
|
DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
132 |
|
|
for db in $DBS ; do |
133 |
|
|
/sbin/e-smith/db $db delete sarg 2>/dev/null |
134 |
|
|
done |
135 |
|
|
|
136 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
137 |
|
|
/etc/rc.d/init.d/httpd-e-smith sigusr1 |
138 |
|
|
fi |
139 |
|
|
|
140 |
|
|
%files -f %{name}-%{version}-filelist |
141 |
|
|
%defattr(-,root,root) |