1 |
slords |
1.1 |
Summary: smserver rpm to setup scuttle, social bookmarks |
2 |
|
|
%define name smeserver-scuttle |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
|
|
%define release 2 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
Distribution: SME Server |
9 |
|
|
Copyright: GPL |
10 |
|
|
URL: http://www.dungog.net/sme |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
Packager: Stephen Noble <support@dungog.net> |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
Requires: e-smith-release >= 7.0 |
17 |
|
|
Requires: scuttle |
18 |
|
|
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
smserver rpm to setup scuttle : social bookmarks. |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Mon Dec 11 2006 Stephen Noble <support@dungog.net> |
25 |
|
|
- rpm %post events reordered, to enable clean install |
26 |
|
|
- [0.9-2] |
27 |
|
|
|
28 |
|
|
* Tue Nov 28 2006 Stephen Noble <support@dungog.net> |
29 |
|
|
- initial release |
30 |
|
|
- [0.9-1] |
31 |
|
|
|
32 |
|
|
%prep |
33 |
|
|
%setup |
34 |
|
|
|
35 |
|
|
%build |
36 |
|
|
#perl createlinks |
37 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/scuttle |
38 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/scuttle/type |
39 |
|
|
|
40 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/scuttle |
41 |
|
|
echo "Social Bookmarks" > root/etc/e-smith/db/configuration/defaults/scuttle/Name |
42 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/scuttle/PublicAccess |
43 |
|
|
echo "bookmarks" > root/etc/e-smith/db/configuration/defaults/scuttle/URL |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
rm -rf $RPM_BUILD_ROOT |
47 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
48 |
|
|
rm -f %{name}-%{version}-filelist |
49 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
50 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
cd .. |
54 |
|
|
rm -rf %{name}-%{version} |
55 |
|
|
|
56 |
|
|
%pre |
57 |
|
|
|
58 |
|
|
%preun |
59 |
|
|
|
60 |
|
|
%post |
61 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
62 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80scuttle.sql |
63 |
|
|
/etc/rc.d/init.d/mysql.init start |
64 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
65 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
66 |
|
|
|
67 |
|
|
echo "" |
68 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
69 |
|
|
echo "current settings 'config show scuttle'..." |
70 |
|
|
/sbin/e-smith/config show scuttle |
71 |
|
|
|
72 |
|
|
%postun |
73 |
|
|
#uninstall |
74 |
|
|
if [ $1 = 0 ] ; then |
75 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
76 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
77 |
|
|
fi |
78 |
|
|
|
79 |
|
|
%files -f %{name}-%{version}-filelist |
80 |
|
|
%defattr(-,root,root) |
81 |
|
|
|