1 |
slords |
1.1 |
Summary: smserver rpm to setup scuttle, social bookmarks |
2 |
|
|
%define name smeserver-scuttle |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
slords |
1.6 |
%define release 3 |
6 |
slords |
1.1 |
Version: %{version} |
7 |
slords |
1.3 |
Release: %{release}%{?dist} |
8 |
slords |
1.6 |
Distribution: SME Server |
9 |
slords |
1.2 |
License: GPL |
10 |
slords |
1.1 |
URL: http://www.dungog.net/sme |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
slords |
1.6 |
Patch0: ss-scuttle-postinstall.patch |
14 |
slords |
1.1 |
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
Requires: e-smith-release >= 7.0 |
17 |
|
|
Requires: scuttle |
18 |
slords |
1.6 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
19 |
slords |
1.1 |
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
smserver rpm to setup scuttle : social bookmarks. |
23 |
|
|
|
24 |
|
|
%changelog |
25 |
slords |
1.6 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
26 |
|
|
- Clean up spec so package can be built by koji/plague |
27 |
|
|
|
28 |
|
|
* Sat Apr 14 2007 Stephen Noble <support@dungog.net> [0.9-3] |
29 |
|
|
- removed phpinfo |
30 |
|
|
- post events reordered, to enable clean install |
31 |
|
|
|
32 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
33 |
|
|
- Update to new release naming. No functional changes. |
34 |
|
|
- Make Packager generic |
35 |
slords |
1.1 |
|
36 |
|
|
* Tue Nov 28 2006 Stephen Noble <support@dungog.net> |
37 |
|
|
- initial release |
38 |
|
|
- [0.9-1] |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
%setup |
42 |
slords |
1.6 |
%patch0 -p1 |
43 |
slords |
1.1 |
|
44 |
|
|
%build |
45 |
slords |
1.6 |
|
46 |
slords |
1.1 |
mkdir -p root/etc/e-smith/db/accounts/defaults/scuttle |
47 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/scuttle/type |
48 |
|
|
|
49 |
slords |
1.6 |
DEFAULTS=root/etc/e-smith/db/configuration/defaults/scuttle |
50 |
|
|
mkdir -p $DEFAULTS |
51 |
|
|
echo "Social Bookmarks" > $DEFAULTS/Name |
52 |
|
|
echo "global-pw-remote" > $DEFAULTS/PublicAccess |
53 |
|
|
echo "bookmarks" > $DEFAULTS/URL |
54 |
slords |
1.1 |
|
55 |
|
|
%install |
56 |
|
|
rm -rf $RPM_BUILD_ROOT |
57 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
58 |
|
|
rm -f %{name}-%{version}-filelist |
59 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
60 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
61 |
|
|
|
62 |
|
|
%clean |
63 |
|
|
cd .. |
64 |
|
|
rm -rf %{name}-%{version} |
65 |
|
|
|
66 |
|
|
%pre |
67 |
|
|
|
68 |
|
|
%preun |
69 |
|
|
|
70 |
|
|
%post |
71 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
72 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80scuttle.sql |
73 |
|
|
/etc/rc.d/init.d/mysql.init start |
74 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
75 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
76 |
|
|
|
77 |
|
|
echo "" |
78 |
slords |
1.6 |
echo "see http://wiki.contribs.org/Scuttle" |
79 |
slords |
1.1 |
|
80 |
|
|
%postun |
81 |
|
|
#uninstall |
82 |
|
|
if [ $1 = 0 ] ; then |
83 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
84 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
85 |
|
|
fi |
86 |
|
|
|
87 |
|
|
%files -f %{name}-%{version}-filelist |
88 |
|
|
%defattr(-,root,root) |
89 |
|
|
|