1 |
slords |
1.1 |
Summary: smserver rpm to setup scuttle, social bookmarks |
2 |
|
|
%define name smeserver-scuttle |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
slords |
1.6 |
%define release 3 |
6 |
slords |
1.1 |
Version: %{version} |
7 |
slords |
1.3 |
Release: %{release}%{?dist} |
8 |
slords |
1.2 |
License: GPL |
9 |
slords |
1.1 |
URL: http://www.dungog.net/sme |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
slords |
1.6 |
Patch0: ss-scuttle-postinstall.patch |
13 |
slords |
1.1 |
BuildArchitectures: noarch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
Requires: e-smith-release >= 7.0 |
16 |
|
|
Requires: scuttle |
17 |
slords |
1.6 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
slords |
1.1 |
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
smserver rpm to setup scuttle : social bookmarks. |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
slords |
1.6 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
25 |
|
|
- Clean up spec so package can be built by koji/plague |
26 |
|
|
|
27 |
|
|
* Sat Apr 14 2007 Stephen Noble <support@dungog.net> [0.9-3] |
28 |
|
|
- removed phpinfo |
29 |
|
|
- post events reordered, to enable clean install |
30 |
|
|
|
31 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
32 |
|
|
- Update to new release naming. No functional changes. |
33 |
|
|
- Make Packager generic |
34 |
slords |
1.1 |
|
35 |
|
|
* Tue Nov 28 2006 Stephen Noble <support@dungog.net> |
36 |
|
|
- initial release |
37 |
|
|
- [0.9-1] |
38 |
|
|
|
39 |
|
|
%prep |
40 |
|
|
%setup |
41 |
slords |
1.6 |
%patch0 -p1 |
42 |
slords |
1.1 |
|
43 |
|
|
%build |
44 |
slords |
1.6 |
|
45 |
slords |
1.1 |
mkdir -p root/etc/e-smith/db/accounts/defaults/scuttle |
46 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/scuttle/type |
47 |
|
|
|
48 |
slords |
1.6 |
DEFAULTS=root/etc/e-smith/db/configuration/defaults/scuttle |
49 |
|
|
mkdir -p $DEFAULTS |
50 |
|
|
echo "Social Bookmarks" > $DEFAULTS/Name |
51 |
|
|
echo "global-pw-remote" > $DEFAULTS/PublicAccess |
52 |
|
|
echo "bookmarks" > $DEFAULTS/URL |
53 |
slords |
1.1 |
|
54 |
|
|
%install |
55 |
|
|
rm -rf $RPM_BUILD_ROOT |
56 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
57 |
|
|
rm -f %{name}-%{version}-filelist |
58 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
59 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
60 |
|
|
|
61 |
|
|
%clean |
62 |
|
|
cd .. |
63 |
|
|
rm -rf %{name}-%{version} |
64 |
|
|
|
65 |
|
|
%pre |
66 |
|
|
|
67 |
|
|
%preun |
68 |
|
|
|
69 |
|
|
%post |
70 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
71 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80scuttle.sql |
72 |
|
|
/etc/rc.d/init.d/mysql.init start |
73 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
74 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
75 |
|
|
|
76 |
|
|
echo "" |
77 |
slords |
1.6 |
echo "see http://wiki.contribs.org/Scuttle" |
78 |
slords |
1.1 |
|
79 |
|
|
%postun |
80 |
|
|
#uninstall |
81 |
|
|
if [ $1 = 0 ] ; then |
82 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
83 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
84 |
|
|
fi |
85 |
|
|
|
86 |
|
|
%files -f %{name}-%{version}-filelist |
87 |
|
|
%defattr(-,root,root) |
88 |
|
|
|