1 |
# $Id: smeserver-scuttle.spec,v 1.2 2008/04/02 15:03:59 slords Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
Summary: smserver rpm to setup scuttle, social bookmarks |
6 |
%define name smeserver-scuttle |
7 |
Name: %{name} |
8 |
%define version 0.9 |
9 |
%define release 3 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
URL: http://www.dungog.net/sme |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch0: ss-scuttle-postinstall.patch |
17 |
BuildArchitectures: noarch |
18 |
BuildRoot: /var/tmp/%{name}-%{version} |
19 |
Requires: e-smith-release >= 7.0 |
20 |
Requires: scuttle |
21 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
22 |
AutoReqProv: no |
23 |
|
24 |
%description |
25 |
smserver rpm to setup scuttle : social bookmarks. |
26 |
|
27 |
%changelog |
28 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
29 |
- Clean up spec so package can be built by koji/plague |
30 |
|
31 |
* Sat Apr 14 2007 Stephen Noble <support@dungog.net> [0.9-3] |
32 |
- removed phpinfo |
33 |
- post events reordered, to enable clean install |
34 |
|
35 |
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
36 |
- Update to new release naming. No functional changes. |
37 |
- Make Packager generic |
38 |
|
39 |
* Tue Nov 28 2006 Stephen Noble <support@dungog.net> |
40 |
- initial release |
41 |
- [0.9-1] |
42 |
|
43 |
%prep |
44 |
%setup |
45 |
%patch0 -p1 |
46 |
|
47 |
%build |
48 |
|
49 |
mkdir -p root/etc/e-smith/db/accounts/defaults/scuttle |
50 |
echo "reserved" > root/etc/e-smith/db/accounts/defaults/scuttle/type |
51 |
|
52 |
DEFAULTS=root/etc/e-smith/db/configuration/defaults/scuttle |
53 |
mkdir -p $DEFAULTS |
54 |
echo "Social Bookmarks" > $DEFAULTS/Name |
55 |
echo "global-pw-remote" > $DEFAULTS/PublicAccess |
56 |
echo "bookmarks" > $DEFAULTS/URL |
57 |
|
58 |
%install |
59 |
rm -rf $RPM_BUILD_ROOT |
60 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
61 |
rm -f %{name}-%{version}-filelist |
62 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
63 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
64 |
|
65 |
%clean |
66 |
cd .. |
67 |
rm -rf %{name}-%{version} |
68 |
|
69 |
%pre |
70 |
|
71 |
%preun |
72 |
|
73 |
%post |
74 |
/etc/e-smith/events/actions/initialize-default-databases |
75 |
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80scuttle.sql |
76 |
/etc/rc.d/init.d/mysql.init start |
77 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
78 |
/usr/local/bin/svc -h /service/httpd-e-smith |
79 |
|
80 |
echo "" |
81 |
echo "see http://wiki.contribs.org/Scuttle" |
82 |
|
83 |
%postun |
84 |
#uninstall |
85 |
if [ $1 = 0 ] ; then |
86 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
87 |
/usr/local/bin/svc -h /service/httpd-e-smith |
88 |
fi |
89 |
|
90 |
%files -f %{name}-%{version}-filelist |
91 |
%defattr(-,root,root) |
92 |
|