1 |
slords |
1.1 |
# $Id: e-smith-shared-folders.spec,v 1.0 2009/04/08 20:02:28 VIP-ire Exp $ |
2 |
slords |
1.2 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
slords |
1.1 |
|
5 |
|
|
Summary: sme server shared folders module |
6 |
|
|
%define name smeserver-shared-folders |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
|
|
%define release 0.beta3 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
Patch0: smeserver-shared-folders-0.1-maxShareNameLength.patch |
17 |
|
|
Patch1: smeserver-shared-folders-0.1-add_acl_in_fstab.patch |
18 |
|
|
|
19 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
20 |
|
|
BuildArchitectures: noarch |
21 |
|
|
Requires: e-smith-base >= 4.13.15-76 |
22 |
|
|
Requires: perl(CGI::FormMagick) |
23 |
|
|
Requires: e-smith-formmagick >= 1.4.0-12 |
24 |
|
|
|
25 |
|
|
Requires: acl |
26 |
|
|
BuildRequires: perl |
27 |
|
|
BuildRequires: e-smith-devtools >= 1.11.0-03 |
28 |
|
|
|
29 |
|
|
|
30 |
|
|
%description |
31 |
|
|
This module allows you to create network shares (only samba is supported for now) |
32 |
|
|
with more flexibility than ibay as it supports ACLs |
33 |
|
|
|
34 |
|
|
%changelog |
35 |
|
|
* Tue Apr 28 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta3] |
36 |
|
|
- Add acl option in fstab via the template system |
37 |
|
|
(just like usrquota and grpquota) |
38 |
|
|
|
39 |
|
|
* Thu Apr 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta2] |
40 |
|
|
- Rename spec file |
41 |
|
|
|
42 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta1] |
43 |
|
|
- Rename maxIbayNameLength to maxShareNameLength |
44 |
|
|
|
45 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta0] |
46 |
|
|
- Initial release. |
47 |
|
|
|
48 |
|
|
%prep |
49 |
|
|
%setup |
50 |
|
|
|
51 |
|
|
%patch0 -p1 |
52 |
|
|
%patch1 -p1 |
53 |
|
|
|
54 |
|
|
%pre |
55 |
|
|
%post |
56 |
|
|
|
57 |
|
|
%build |
58 |
|
|
# Force creation of potentially empty directories |
59 |
|
|
mkdir -p root/etc/e-smith/web/{common,functions} |
60 |
|
|
mkdir -p root/etc/e-smith/web/panels/manager/{cgi-bin,common,html} |
61 |
|
|
mkdir -p root/home/e-smith/files/shares |
62 |
|
|
|
63 |
|
|
perl createlinks |
64 |
|
|
|
65 |
|
|
%install |
66 |
|
|
rm -rf $RPM_BUILD_ROOT |
67 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
68 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
69 |
|
|
> %{name}-%{version}-%{release}-filelist |
70 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
71 |
|
|
|
72 |
|
|
%clean |
73 |
|
|
rm -rf $RPM_BUILD_ROOT |
74 |
|
|
|
75 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
76 |
|
|
%defattr(-,root,root) |