1 |
slords |
1.1 |
# $Id: e-smith-shared-folders.spec,v 1.0 2009/04/08 20:02:28 VIP-ire Exp $ |
2 |
slords |
1.2 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
slords |
1.1 |
|
5 |
|
|
Summary: sme server shared folders module |
6 |
|
|
%define name smeserver-shared-folders |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
vip-ire |
1.3 |
%define release 1 |
10 |
slords |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
Patch0: smeserver-shared-folders-0.1-maxShareNameLength.patch |
17 |
|
|
Patch1: smeserver-shared-folders-0.1-add_acl_in_fstab.patch |
18 |
vip-ire |
1.3 |
Patch2: smeserver-shared-folders-0.1-locale-2009-05-05.patch |
19 |
slords |
1.1 |
|
20 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
21 |
|
|
BuildArchitectures: noarch |
22 |
|
|
Requires: e-smith-base >= 4.13.15-76 |
23 |
|
|
Requires: perl(CGI::FormMagick) |
24 |
|
|
Requires: e-smith-formmagick >= 1.4.0-12 |
25 |
|
|
|
26 |
|
|
Requires: acl |
27 |
|
|
BuildRequires: perl |
28 |
|
|
BuildRequires: e-smith-devtools >= 1.11.0-03 |
29 |
|
|
|
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
This module allows you to create network shares (only samba is supported for now) |
33 |
|
|
with more flexibility than ibay as it supports ACLs |
34 |
|
|
|
35 |
|
|
%changelog |
36 |
vip-ire |
1.3 |
* Tue May 05 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
37 |
|
|
- Add locale patch 2009-05-05 |
38 |
|
|
|
39 |
slords |
1.1 |
* Tue Apr 28 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta3] |
40 |
|
|
- Add acl option in fstab via the template system |
41 |
|
|
(just like usrquota and grpquota) |
42 |
|
|
|
43 |
|
|
* Thu Apr 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta2] |
44 |
|
|
- Rename spec file |
45 |
|
|
|
46 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta1] |
47 |
|
|
- Rename maxIbayNameLength to maxShareNameLength |
48 |
|
|
|
49 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta0] |
50 |
|
|
- Initial release. |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup |
54 |
|
|
|
55 |
|
|
%patch0 -p1 |
56 |
|
|
%patch1 -p1 |
57 |
vip-ire |
1.3 |
%patch2 -p1 |
58 |
slords |
1.1 |
|
59 |
|
|
%pre |
60 |
|
|
%post |
61 |
|
|
|
62 |
|
|
%build |
63 |
|
|
# Force creation of potentially empty directories |
64 |
|
|
mkdir -p root/etc/e-smith/web/{common,functions} |
65 |
|
|
mkdir -p root/etc/e-smith/web/panels/manager/{cgi-bin,common,html} |
66 |
|
|
mkdir -p root/home/e-smith/files/shares |
67 |
|
|
|
68 |
|
|
perl createlinks |
69 |
|
|
|
70 |
|
|
%install |
71 |
|
|
rm -rf $RPM_BUILD_ROOT |
72 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
73 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
74 |
|
|
> %{name}-%{version}-%{release}-filelist |
75 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
|
80 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
81 |
|
|
%defattr(-,root,root) |