1 |
slords |
1.1 |
# $Id: e-smith-shared-folders.spec,v 1.0 2009/04/08 20:02:28 VIP-ire Exp $ |
2 |
slords |
1.2 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
slords |
1.1 |
|
5 |
|
|
Summary: sme server shared folders module |
6 |
|
|
%define name smeserver-shared-folders |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
vip-ire |
1.4 |
%define release 2 |
10 |
slords |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
Patch0: smeserver-shared-folders-0.1-maxShareNameLength.patch |
17 |
|
|
Patch1: smeserver-shared-folders-0.1-add_acl_in_fstab.patch |
18 |
vip-ire |
1.3 |
Patch2: smeserver-shared-folders-0.1-locale-2009-05-05.patch |
19 |
vip-ire |
1.4 |
Patch3: smeserver-shared-folders-0.1-optimize_permissions.patch |
20 |
|
|
Patch4: smeserver-shared-folders-0.1-extended_access.patch |
21 |
|
|
Patch5: smeserver-shared-folders-0.1-keep_versions_in_panel.patch |
22 |
|
|
Patch6: smeserver-shared-folders-0.1-locale_extended_access.patch |
23 |
|
|
Patch7: smeserver-shared-folders-0.1-locale_add_description.patch |
24 |
|
|
Patch8: smeserver-shared-folders-0.1-remove_desc.patch |
25 |
|
|
Patch9: smeserver-shared-folders-0.1-http_skip_wrong_values.patch |
26 |
slords |
1.1 |
|
27 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
28 |
|
|
BuildArchitectures: noarch |
29 |
|
|
Requires: e-smith-base >= 4.13.15-76 |
30 |
|
|
Requires: perl(CGI::FormMagick) |
31 |
|
|
Requires: e-smith-formmagick >= 1.4.0-12 |
32 |
|
|
|
33 |
|
|
Requires: acl |
34 |
|
|
BuildRequires: perl |
35 |
|
|
BuildRequires: e-smith-devtools >= 1.11.0-03 |
36 |
|
|
|
37 |
|
|
|
38 |
|
|
%description |
39 |
vip-ire |
1.4 |
This module allows you to create network shares |
40 |
|
|
with more flexibility than ibays as it supports ACLs |
41 |
slords |
1.1 |
|
42 |
|
|
%changelog |
43 |
vip-ire |
1.4 |
* Wed May 13 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
44 |
|
|
- add http access, with some options in the panel |
45 |
|
|
- present the keepversion option of the recylcebin in the panel |
46 |
|
|
- changes in db keys |
47 |
|
|
- remove some descriptions in the panel |
48 |
|
|
- optimization in share-modiffy to limit the time needed |
49 |
|
|
to reset permissions |
50 |
|
|
|
51 |
vip-ire |
1.3 |
* Tue May 05 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
52 |
|
|
- Add locale patch 2009-05-05 |
53 |
|
|
|
54 |
slords |
1.1 |
* Tue Apr 28 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta3] |
55 |
|
|
- Add acl option in fstab via the template system |
56 |
|
|
(just like usrquota and grpquota) |
57 |
|
|
|
58 |
|
|
* Thu Apr 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta2] |
59 |
|
|
- Rename spec file |
60 |
|
|
|
61 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta1] |
62 |
|
|
- Rename maxIbayNameLength to maxShareNameLength |
63 |
|
|
|
64 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta0] |
65 |
|
|
- Initial release. |
66 |
|
|
|
67 |
|
|
%prep |
68 |
|
|
%setup |
69 |
|
|
|
70 |
|
|
%patch0 -p1 |
71 |
|
|
%patch1 -p1 |
72 |
vip-ire |
1.3 |
%patch2 -p1 |
73 |
vip-ire |
1.4 |
%patch3 -p1 |
74 |
|
|
%patch4 -p1 |
75 |
|
|
%patch5 -p1 |
76 |
|
|
%patch6 -p1 |
77 |
|
|
%patch7 -p1 |
78 |
|
|
%patch8 -p1 |
79 |
|
|
%patch9 -p1 |
80 |
slords |
1.1 |
|
81 |
|
|
%pre |
82 |
|
|
%post |
83 |
|
|
|
84 |
|
|
%build |
85 |
|
|
# Force creation of potentially empty directories |
86 |
|
|
mkdir -p root/etc/e-smith/web/{common,functions} |
87 |
|
|
mkdir -p root/etc/e-smith/web/panels/manager/{cgi-bin,common,html} |
88 |
|
|
mkdir -p root/home/e-smith/files/shares |
89 |
|
|
|
90 |
|
|
perl createlinks |
91 |
|
|
|
92 |
|
|
%install |
93 |
|
|
rm -rf $RPM_BUILD_ROOT |
94 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
95 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
96 |
|
|
> %{name}-%{version}-%{release}-filelist |
97 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
98 |
|
|
|
99 |
|
|
%clean |
100 |
|
|
rm -rf $RPM_BUILD_ROOT |
101 |
|
|
|
102 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
103 |
|
|
%defattr(-,root,root) |