1 |
slords |
1.1 |
# $Id: e-smith-shared-folders.spec,v 1.0 2009/04/08 20:02:28 VIP-ire Exp $ |
2 |
slords |
1.2 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
slords |
1.1 |
|
5 |
|
|
Summary: sme server shared folders module |
6 |
|
|
%define name smeserver-shared-folders |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
slords |
1.5 |
%define release 3 |
10 |
slords |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
Patch0: smeserver-shared-folders-0.1-maxShareNameLength.patch |
17 |
|
|
Patch1: smeserver-shared-folders-0.1-add_acl_in_fstab.patch |
18 |
vip-ire |
1.3 |
Patch2: smeserver-shared-folders-0.1-locale-2009-05-05.patch |
19 |
vip-ire |
1.4 |
Patch3: smeserver-shared-folders-0.1-optimize_permissions.patch |
20 |
|
|
Patch4: smeserver-shared-folders-0.1-extended_access.patch |
21 |
|
|
Patch5: smeserver-shared-folders-0.1-keep_versions_in_panel.patch |
22 |
|
|
Patch6: smeserver-shared-folders-0.1-locale_extended_access.patch |
23 |
|
|
Patch7: smeserver-shared-folders-0.1-locale_add_description.patch |
24 |
|
|
Patch8: smeserver-shared-folders-0.1-remove_desc.patch |
25 |
|
|
Patch9: smeserver-shared-folders-0.1-http_skip_wrong_values.patch |
26 |
slords |
1.5 |
Patch10: smeserver-shared-folders-0.1-locale-2009-05-20.patch |
27 |
slords |
1.1 |
|
28 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
29 |
|
|
BuildArchitectures: noarch |
30 |
|
|
Requires: e-smith-base >= 4.13.15-76 |
31 |
|
|
Requires: perl(CGI::FormMagick) |
32 |
|
|
Requires: e-smith-formmagick >= 1.4.0-12 |
33 |
|
|
|
34 |
|
|
Requires: acl |
35 |
|
|
BuildRequires: perl |
36 |
|
|
BuildRequires: e-smith-devtools >= 1.11.0-03 |
37 |
|
|
|
38 |
|
|
|
39 |
|
|
%description |
40 |
vip-ire |
1.4 |
This module allows you to create network shares |
41 |
|
|
with more flexibility than ibays as it supports ACLs |
42 |
slords |
1.1 |
|
43 |
|
|
%changelog |
44 |
slords |
1.5 |
* Wed May 20 2009 SME Translation Server <translations@contribs.org> 0.1-3.sme |
45 |
|
|
- apply locale 2009-05-20 patch |
46 |
|
|
|
47 |
vip-ire |
1.4 |
* Wed May 13 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
48 |
|
|
- add http access, with some options in the panel |
49 |
|
|
- present the keepversion option of the recylcebin in the panel |
50 |
|
|
- changes in db keys |
51 |
|
|
- remove some descriptions in the panel |
52 |
|
|
- optimization in share-modiffy to limit the time needed |
53 |
|
|
to reset permissions |
54 |
|
|
|
55 |
vip-ire |
1.3 |
* Tue May 05 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
56 |
|
|
- Add locale patch 2009-05-05 |
57 |
|
|
|
58 |
slords |
1.1 |
* Tue Apr 28 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta3] |
59 |
|
|
- Add acl option in fstab via the template system |
60 |
|
|
(just like usrquota and grpquota) |
61 |
|
|
|
62 |
|
|
* Thu Apr 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta2] |
63 |
|
|
- Rename spec file |
64 |
|
|
|
65 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta1] |
66 |
|
|
- Rename maxIbayNameLength to maxShareNameLength |
67 |
|
|
|
68 |
|
|
* Wed Apr 08 2009 Daniel B. <daniel@firewall-services.com> [0.1-0.beta0] |
69 |
|
|
- Initial release. |
70 |
|
|
|
71 |
|
|
%prep |
72 |
|
|
%setup |
73 |
|
|
|
74 |
|
|
%patch0 -p1 |
75 |
|
|
%patch1 -p1 |
76 |
vip-ire |
1.3 |
%patch2 -p1 |
77 |
vip-ire |
1.4 |
%patch3 -p1 |
78 |
|
|
%patch4 -p1 |
79 |
|
|
%patch5 -p1 |
80 |
|
|
%patch6 -p1 |
81 |
|
|
%patch7 -p1 |
82 |
|
|
%patch8 -p1 |
83 |
|
|
%patch9 -p1 |
84 |
slords |
1.5 |
%patch10 -p1 |
85 |
slords |
1.1 |
|
86 |
|
|
%pre |
87 |
|
|
%post |
88 |
|
|
|
89 |
|
|
%build |
90 |
|
|
# Force creation of potentially empty directories |
91 |
|
|
mkdir -p root/etc/e-smith/web/{common,functions} |
92 |
|
|
mkdir -p root/etc/e-smith/web/panels/manager/{cgi-bin,common,html} |
93 |
|
|
mkdir -p root/home/e-smith/files/shares |
94 |
|
|
|
95 |
|
|
perl createlinks |
96 |
|
|
|
97 |
|
|
%install |
98 |
|
|
rm -rf $RPM_BUILD_ROOT |
99 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
100 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
101 |
|
|
> %{name}-%{version}-%{release}-filelist |
102 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-%{release}-filelist |
103 |
|
|
|
104 |
|
|
%clean |
105 |
|
|
rm -rf $RPM_BUILD_ROOT |
106 |
|
|
|
107 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
108 |
|
|
%defattr(-,root,root) |