/[smecontribs]/rpms/smeserver-sme8admin/contribs8/smeserver-sme8admin.spec
ViewVC logotype

Annotation of /rpms/smeserver-sme8admin/contribs8/smeserver-sme8admin.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Aug 16 00:39:06 2012 UTC (11 years, 9 months ago) by unnilennium
Branch: MAIN
CVS Tags: smeserver-sme8admin-1_3-2_el5_sme
Changes since 1.1: +4 -2 lines
64 bits 2

1 unnilennium 1.2 # $Id: smeserver-sme8admin.spec,v 1.1 2012/06/16 17:08:59 slords Exp $
2 slords 1.1 # Authority: vip-ire
3     # Name: Daniel Berteaud
4     #
5    
6     Summary: A graphical monitor, alert raising, and services supervision tool for your SME Server.
7     %define name smeserver-sme8admin
8     Name: %{name}
9     %define version 1.3
10 unnilennium 1.2 %define release 2
11 slords 1.1 Version: %{version}
12     Release: %{release}%{?dist}
13     License: GPL
14     Group: Networking/Daemons
15     Source: %{name}-%{version}.tgz
16    
17     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
18     BuildArchitectures: noarch
19    
20     BuildRequires: e-smith-devtools
21     BuildRequires: gettext
22    
23     Requires: e-smith-base
24     Requires: smeserver-release >= 8
25     Requires: rrdtool-perl
26     Requires: rrdtool
27     Requires: hddtemp
28     Requires: sysstat
29     Requires: lm_sensors
30    
31     AutoReqProv: no
32    
33     %changelog
34 unnilennium 1.2 * Wed Aug 15 2012 JP Pialasse <test@pialasse.com> 1.3-2.sme
35     - 64 bits [SME 7040]
36 slords 1.1 * Sun Jun 10 2012 JP Pialasse <test@pialasse.com> 1.3-1.sme
37     - Initial version
38    
39     %description
40     The main part of sme8admin is a daemon which gathers informations from logs
41     and other tools like systat, it then feed a mysql database and create RRD
42     graphs about your system state.
43     This daemon can also send periodics mails (with some logs), and alerts mails
44     based on configurable thresolds.
45    
46     A panel is also available in the server-manager, with which you can access gathered
47     data, display the RRD graphs and configure the service.
48    
49     This contrib is a bit inspired by e-smith-sysmon from Shad Lords.
50    
51     %prep
52     %setup
53    
54     %build
55     perl createlinks
56     %{__mkdir_p} root/etc/e-smith/web/panels/manager/html/sme8admin
57     %{__mkdir_p} root/usr/share/locale/en_US/LC_MESSAGES
58    
59     xgettext --from-code UTF-8 -F --no-wrap -L perl \
60     -o root/usr/share/locale/en_US/LC_MESSAGES/sme8admin.po \
61     root/etc/e-smith/web/functions/sme8admin \
62     root/usr/bin/sme8admind
63    
64     /sbin/e-smith/generate-lexicons
65    
66     %install
67     rm -rf $RPM_BUILD_ROOT
68     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
69     rm -f %{name}-%{version}-filelist
70     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
71    
72     %clean
73     rm -rf $RPM_BUILD_ROOT
74    
75     %pre
76     # This is to correct a bug in the previous version
77     if [ -e /etc/e-smith/web/panels/manager/html/sme7admin/sme7admin.conf ]; then
78     cp -a /etc/e-smith/web/panels/manager/html/sme7admin/sme7admin.conf \
79     /etc/e-smith/web/panels/manager/html/sme7admin/_sme7admin.conf
80     fi
81    
82     %preun
83    
84    
85     %post
86    
87     if [ $1 -eq 1 ]
88     then
89    
90     if [ -d /var/lib/sme7admin ] && [ -d /var/lib/mysql/sme7admin/ ]
91     then
92     echo "After post-upgrade and reboot, you may safely remove sme7admin, as datas will be migrated to sme8admin."
93     echo "Execute 'rpm -e smeserver-sme7admin' and maybe 'mysqladmin drop sme7admin' and 'rm -Rf /var/lib/sme7admin' to completely remove sme7admin."
94     fi
95    
96     fi
97    
98     %postun
99    
100     %files -f %{name}-%{version}-filelist
101     %defattr(-,root,root)
102     %attr(755,root,root) /etc/e-smith/sql/init/sme8admin

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed