1 |
jcrisp |
1.1 |
# $Id: smeserver-smeadmin.spec,v 1.17 2019/12/07 04:05:41 jpp Exp $ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
# |
5 |
|
|
|
6 |
|
|
Summary: A graphical monitor, alert raising, and services supervision tool for your SME Server. |
7 |
|
|
%define name smeserver-smeadmin |
8 |
|
|
Name: %{name} |
9 |
|
|
%define version 1.6 |
10 |
jpp |
1.14 |
%define release 11 |
11 |
jcrisp |
1.1 |
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Networking/Daemons |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
jpp |
1.3 |
Patch0: smeserver-smeadmin-1.6-bz11062-initial-import.patch |
17 |
terryfage |
1.5 |
Patch1: smeserver-smeadmin-1.6-locale-2021-08-24.patch |
18 |
terryfage |
1.6 |
Patch2: smeserver-smeadmin-1.6-locale-2021-09-08.patch |
19 |
michel |
1.7 |
Patch3: smeserver-smeadmin-1.6-bz10761_real_ssh_port.patch |
20 |
terryfage |
1.8 |
Patch4: smeserver-smeadmin-1.6-bz11642-bz1159-authproxy-errorlog.patch |
21 |
jpp |
1.9 |
Patch5: smeserver-smeadmin-1.6-locale-2022-07-29.patch |
22 |
jpp |
1.10 |
Patch6: smeserver-smeadmin-1.6-bz12023-backup.patch |
23 |
jpp |
1.12 |
Patch7: smeserver-smeadmin-1.6-bz11643-services.patch |
24 |
jpp |
1.13 |
Patch8: smeserver-smeadmin-1.6-locale-2022-11-11.patch |
25 |
jpp |
1.14 |
Patch9: smeserver-smeadmin-1.6-bz12447-auth-qpsmtpd.patch |
26 |
jcrisp |
1.1 |
|
27 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
28 |
|
|
BuildArchitectures: noarch |
29 |
|
|
|
30 |
|
|
BuildRequires: e-smith-devtools |
31 |
|
|
BuildRequires: gettext |
32 |
|
|
|
33 |
|
|
Requires: e-smith-base |
34 |
|
|
Requires: smeserver-release >= 10 |
35 |
|
|
Requires: rrdtool-perl |
36 |
|
|
Requires: rrdtool |
37 |
|
|
Requires: hddtemp |
38 |
|
|
Requires: sysstat |
39 |
|
|
Requires: lm_sensors |
40 |
|
|
#Obsoletes: smeserver-sme8admin |
41 |
|
|
|
42 |
|
|
AutoReqProv: no |
43 |
jpp |
1.14 |
%description |
44 |
|
|
The main part of smeadmin is a daemon which gathers informations from logs |
45 |
|
|
and other tools like systat, it then feed a mysql database and create RRD |
46 |
|
|
graphs about your system state. |
47 |
|
|
This daemon can also send periodics mails (with some logs), and alerts mails |
48 |
|
|
based on configurable thresolds. |
49 |
|
|
|
50 |
|
|
A panel is also available in the server-manager, with which you can access gathered |
51 |
|
|
data, display the RRD graphs and configure the service. |
52 |
|
|
|
53 |
|
|
This contrib is a bit inspired by e-smith-sysmon from Shad Lords. |
54 |
|
|
|
55 |
|
|
%prep |
56 |
|
|
%setup |
57 |
|
|
%patch0 -p1 |
58 |
|
|
%patch1 -p1 |
59 |
|
|
%patch2 -p1 |
60 |
|
|
%patch3 -p1 |
61 |
|
|
%patch4 -p1 |
62 |
|
|
%patch5 -p1 |
63 |
|
|
%patch6 -p1 |
64 |
|
|
%patch7 -p1 |
65 |
|
|
%patch8 -p1 |
66 |
|
|
%patch9 -p1 |
67 |
|
|
|
68 |
|
|
%build |
69 |
|
|
perl createlinks |
70 |
|
|
%{__mkdir_p} root/etc/e-smith/web/panels/manager/html/smeadmin |
71 |
|
|
%{__mkdir_p} root/usr/share/locale/en_US/LC_MESSAGES |
72 |
|
|
|
73 |
|
|
xgettext --from-code UTF-8 -F --no-wrap -L perl \ |
74 |
|
|
-o root/usr/share/locale/en_US/LC_MESSAGES/smeadmin.po \ |
75 |
|
|
root/etc/e-smith/web/functions/smeadmin \ |
76 |
|
|
root/usr/bin/smeadmind |
77 |
|
|
|
78 |
|
|
/sbin/e-smith/generate-lexicons |
79 |
|
|
|
80 |
|
|
%install |
81 |
|
|
rm -rf $RPM_BUILD_ROOT |
82 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
83 |
|
|
rm -f %{name}-%{version}-filelist |
84 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
85 |
|
|
--file /usr/bin/smeadmind 'attr(755,root,root)' \ |
86 |
|
|
--file /usr/share/doc/smeserver-smeadmin/add_ds_to_rrd.pl 'attr(755,root,root)' \ |
87 |
|
|
> %{name}-%{version}-filelist |
88 |
|
|
|
89 |
|
|
%clean |
90 |
|
|
rm -rf $RPM_BUILD_ROOT |
91 |
|
|
|
92 |
|
|
%pre |
93 |
|
|
|
94 |
|
|
%preun |
95 |
|
|
|
96 |
|
|
%post |
97 |
|
|
|
98 |
|
|
%postun |
99 |
|
|
|
100 |
|
|
%files -f %{name}-%{version}-filelist |
101 |
|
|
%defattr(-,root,root) |
102 |
jcrisp |
1.1 |
|
103 |
|
|
%changelog |
104 |
jpp |
1.14 |
* Mon Dec 18 2023 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-11.sme |
105 |
|
|
- add accounting of auth_failed [SME: 12447] |
106 |
|
|
adding php8* services |
107 |
|
|
|
108 |
jpp |
1.13 |
* Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-10.sme |
109 |
|
|
- apply locale 2022-11-11 patch |
110 |
|
|
|
111 |
jpp |
1.12 |
* Sun Sep 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-9.sme |
112 |
|
|
- fix misisng stopped services [SME: 11643] |
113 |
|
|
|
114 |
brianr |
1.11 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.6-8.sme |
115 |
|
|
- Re-build and link to latest devtools [SME: 11997] |
116 |
|
|
|
117 |
jpp |
1.9 |
* Fri Jul 29 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-7.sme |
118 |
|
|
- apply translation 2022-07-29 |
119 |
jpp |
1.10 |
- add to core backup [SME: 12023] |
120 |
jpp |
1.9 |
|
121 |
terryfage |
1.8 |
* Mon Jul 18 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 1.6-6.sme |
122 |
|
|
- bz11642 authproxy errorlog [SME: 11642] |
123 |
|
|
- bz11590 error log [SME: 11590] |
124 |
|
|
|
125 |
michel |
1.7 |
* Mon Jul 18 2022 Michel Begue <mab974@misouk.com> 1.6-5.sme |
126 |
|
|
- get real ssh port from configuration db. [SME: 10761] |
127 |
|
|
|
128 |
terryfage |
1.6 |
* Wed Sep 08 2021 Terry Fage <terry.fage@gmail.com> 1.6-4.sme |
129 |
|
|
- apply locale 2021-09-08 patch |
130 |
|
|
|
131 |
terryfage |
1.5 |
* Tue Aug 24 2021 Terry Fage <terry.fage@gmail.com> 1.6-3.sme |
132 |
|
|
- apply locale 2021-08-24 patch |
133 |
|
|
|
134 |
jpp |
1.3 |
* Thu Mar 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-2.sme |
135 |
brianr |
1.11 |
- Re-build and link to latest devtools mysql not migrating sme9admind [SME: 11062] |
136 |
|
|
- Re-build and link to latest devtools config db sme9admind not migrated to smeadmind |
137 |
|
|
- Re-build and link to latest devtools /var/lib/sme9admin not migrated |
138 |
jpp |
1.3 |
- add smeserver-smeadmin-update event |
139 |
brianr |
1.11 |
- Re-build and link to latest devtools services diplayed multiple times [SME: 11455] |
140 |
jpp |
1.4 |
- systemd unit |
141 |
|
|
- review new logs locations |
142 |
|
|
- check calls to sysvinit |
143 |
|
|
- TODO implement new VPNs stats |
144 |
jpp |
1.3 |
|
145 |
jcrisp |
1.1 |
* Thu Oct 15 2020 Brian Read <brianr@bjsystems.co.uk> 1.6-1 |
146 |
brianr |
1.2 |
- Move to SME10, rename to smeadmin [SME: 11040, 11062] |
147 |
jcrisp |
1.1 |
|
148 |
|
|
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 1.5-30.sme |
149 |
|
|
- apply locale 2019-12-07 patch |
150 |
|
|
|
151 |
jpp |
1.13 |
* Mon Sep 09 2019 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-29.sme |
152 |
brianr |
1.11 |
- Re-build and link to latest devtools smeadmind die on mysql connection error [SME: 7683] |
153 |
jcrisp |
1.1 |
|
154 |
|
|
* Sat Dec 02 2017 SME Translation Server <translations@contribs.org> 1.5-28.sme |
155 |
|
|
- apply locale 2017-12-02 patch |
156 |
|
|
|
157 |
jpp |
1.13 |
* Mon Aug 14 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-27.sme |
158 |
jcrisp |
1.1 |
- add support for altqmail [SME: 10409] |
159 |
|
|
|
160 |
jpp |
1.13 |
* Mon Jul 10 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-26.sme |
161 |
brianr |
1.11 |
- Re-build and link to latest devtools error after migrating sme8admin db, unable to access mysql db [SME: 10181] |
162 |
jcrisp |
1.1 |
|
163 |
jpp |
1.13 |
* Sat Mar 25 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-25.sme |
164 |
jcrisp |
1.1 |
- apply locale 2017-03-26 patch |
165 |
|
|
|
166 |
jpp |
1.13 |
* Wed Feb 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-24.sme |
167 |
jcrisp |
1.1 |
- apply locale 2017-02-02.patch |
168 |
|
|
|
169 |
jpp |
1.13 |
* Sun Jan 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-23.sme |
170 |
brianr |
1.11 |
- Re-build and link to latest devtools warning related to raid detection code [SME: 9886] |
171 |
|
|
- Re-build and link to latest devtools warning related to non existing services removed sinces previous versions [SME: 9889] |
172 |
jcrisp |
1.1 |
|
173 |
jpp |
1.13 |
* Tue Dec 20 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-22.sme |
174 |
jcrisp |
1.1 |
- make CGI and pictures utf8 compliant [SME: 9894] |
175 |
|
|
- apply smeserver-smeadmin-1.5-locale-2016-12-20.patch |
176 |
|
|
|
177 |
jpp |
1.13 |
* Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-21.sme |
178 |
jcrisp |
1.1 |
- locals smeserver-smeadmin-1.5-locale-2016-12-18.patch |
179 |
|
|
|
180 |
jpp |
1.13 |
* Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-20.sme |
181 |
brianr |
1.11 |
- Re-build and link to latest devtools last patch by adding path to called programs |
182 |
jcrisp |
1.1 |
|
183 |
jpp |
1.13 |
* Thu Dec 15 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-19.sme |
184 |
brianr |
1.11 |
- Re-build and link to latest devtools bad accounting for incoming and outgoing mail [SME: 8818] |
185 |
jcrisp |
1.1 |
- mail_in alert now account for all queued emails from qpsmtpd and sqpsmtpd |
186 |
|
|
- mail_out alert now account for qmail total remote delivery attempts |
187 |
|
|
- known issue : on first run will account more than 5 minutes ( whole log) and will alert for exceeding amount |
188 |
|
|
- added accounting of qpsmtpd and sqpsmtpd code |
189 |
|
|
- TODO: alert on qmail queue too high, alert on too many qpsmtpd connections |
190 |
|
|
|
191 |
jpp |
1.13 |
* Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-18.sme |
192 |
brianr |
1.11 |
- Re-build and link to latest devtools limited size in mysql fields for traffic accounting [SME: 8399] |
193 |
jcrisp |
1.1 |
|
194 |
jpp |
1.13 |
* Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-16.sme |
195 |
jcrisp |
1.1 |
- add more verbose email alert [SME: 9725] |
196 |
|
|
|
197 |
|
|
* Fri Aug 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5-15.sme |
198 |
|
|
- Initial release to contribs9 |
199 |
|
|
|
200 |
|
|
* Wed Dec 24 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-14.sme |
201 |
|
|
- changed $mypid = `cat $mypid` by open(FIC,"<$mypid") [SME:8740] |
202 |
|
|
|
203 |
|
|
* Tue Dec 23 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-13.sme |
204 |
|
|
- Corrected bug of empty pids [SME:8732] |
205 |
|
|
- Added exeption if the server is not in server & gateway [SME:8739] |
206 |
|
|
|
207 |
|
|
* Thu Dec 11 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-12.sme |
208 |
|
|
- corrected the dhcpd lease not reported [SME:8724] |
209 |
|
|
|
210 |
|
|
* Tue Nov 25 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-11.sme |
211 |
|
|
- Added a restart to smeadmind when settings are changed in the smeadmin panel |
212 |
|
|
|
213 |
|
|
* Sat Nov 22 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-10.sme |
214 |
|
|
- added a second fan speed sensors |
215 |
|
|
- added four HD TEMP sensors |
216 |
|
|
- added a new graph only for hd temperature sensor |
217 |
|
|
- added an event smeadmin-update for avoiding to restart the server |
218 |
|
|
- added a tab to check the raid status |
219 |
|
|
|
220 |
|
|
* Sun Nov 16 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-9.sme |
221 |
|
|
- Changed in smeadmind L937 °C in .{1,2} .... Thanks JPP |
222 |
|
|
|
223 |
|
|
* Fri Nov 14 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-8.sme |
224 |
|
|
- Added a service in rc7.d for lm_sensors |
225 |
|
|
- added to sadf the -S to collect swap data |
226 |
|
|
- changed txbyt/rxbyt to rxkB/txkB for collecting network load |
227 |
|
|
|
228 |
|
|
* Mon Sep 01 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-7.sme |
229 |
|
|
- added 755 to /usr/bin/smeadmind |
230 |
|
|
|
231 |
|
|
* Wed Jun 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-6.sme |
232 |
|
|
- Initial release to sme9 |
233 |
|
|
|
234 |
jpp |
1.13 |
* Sun Dec 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-4.sme |
235 |
brianr |
1.11 |
- Re-build and link to latest devtools obsolete missing [SME: 7109] |
236 |
|
|
- Re-build and link to latest devtools pppoe and vpn loging [SME: 8061] |
237 |
jcrisp |
1.1 |
- added monthly ppoe log |
238 |
brianr |
1.11 |
- Re-build and link to latest devtools stop on mysql error too many connections [SME: 7683] |
239 |
jcrisp |
1.1 |
|
240 |
jpp |
1.13 |
* Sun Sep 09 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-3.sme |
241 |
jcrisp |
1.1 |
- startup fix [SME 3022] |
242 |
|
|
|
243 |
jpp |
1.13 |
* Wed Aug 15 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-2.sme |
244 |
jcrisp |
1.1 |
- 64 bits [SME 7040] |
245 |
|
|
|
246 |
jpp |
1.13 |
* Sun Jun 10 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-1.sme |
247 |
jcrisp |
1.1 |
- Initial version |
248 |
|
|
|