/[smecontribs]/rpms/smeserver-smeadmin/contribs10/smeserver-smeadmin.spec
ViewVC logotype

Annotation of /rpms/smeserver-smeadmin/contribs10/smeserver-smeadmin.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.17 - (hide annotations) (download)
Fri Dec 22 15:07:00 2023 UTC (4 months, 3 weeks ago) by jpp
Branch: MAIN
CVS Tags: smeserver-smeadmin-1_6-12_el7_sme, HEAD
Changes since 1.16: +3 -3 lines
* Fri Dec 22 2023 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-12.sme
- add accounting of auth_failed [SME: 12447]
  adding php8* services
- fix translation, reworked [SME: 10244]

1 jcrisp 1.1 # $Id: smeserver-smeadmin.spec,v 1.17 2019/12/07 04:05:41 jpp Exp $
2     # Authority: vip-ire
3     # Name: Daniel Berteaud
4     #
5    
6     Summary: A graphical monitor, alert raising, and services supervision tool for your SME Server.
7     %define name smeserver-smeadmin
8     Name: %{name}
9     %define version 1.6
10 jpp 1.17 %define release 12
11 jcrisp 1.1 Version: %{version}
12     Release: %{release}%{?dist}
13     License: GPL
14     Group: Networking/Daemons
15     Source: %{name}-%{version}.tar.gz
16 jpp 1.3 Patch0: smeserver-smeadmin-1.6-bz11062-initial-import.patch
17 terryfage 1.5 Patch1: smeserver-smeadmin-1.6-locale-2021-08-24.patch
18 terryfage 1.6 Patch2: smeserver-smeadmin-1.6-locale-2021-09-08.patch
19 michel 1.7 Patch3: smeserver-smeadmin-1.6-bz10761_real_ssh_port.patch
20 terryfage 1.8 Patch4: smeserver-smeadmin-1.6-bz11642-bz1159-authproxy-errorlog.patch
21 jpp 1.9 Patch5: smeserver-smeadmin-1.6-locale-2022-07-29.patch
22 jpp 1.10 Patch6: smeserver-smeadmin-1.6-bz12023-backup.patch
23 jpp 1.12 Patch7: smeserver-smeadmin-1.6-bz11643-services.patch
24 jpp 1.13 Patch8: smeserver-smeadmin-1.6-locale-2022-11-11.patch
25 jpp 1.14 Patch9: smeserver-smeadmin-1.6-bz12447-auth-qpsmtpd.patch
26 jpp 1.15 Patch10: smeserver-smeadmin-1.6-bz10244-bz11754-translation.patch
27 jcrisp 1.1
28     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
29     BuildArchitectures: noarch
30    
31     BuildRequires: e-smith-devtools
32     BuildRequires: gettext
33    
34     Requires: e-smith-base
35     Requires: smeserver-release >= 10
36     Requires: rrdtool-perl
37     Requires: rrdtool
38     Requires: hddtemp
39     Requires: sysstat
40     Requires: lm_sensors
41     #Obsoletes: smeserver-sme8admin
42    
43     AutoReqProv: no
44 jpp 1.14 %description
45     The main part of smeadmin is a daemon which gathers informations from logs
46     and other tools like systat, it then feed a mysql database and create RRD
47     graphs about your system state.
48     This daemon can also send periodics mails (with some logs), and alerts mails
49     based on configurable thresolds.
50    
51     A panel is also available in the server-manager, with which you can access gathered
52     data, display the RRD graphs and configure the service.
53    
54     This contrib is a bit inspired by e-smith-sysmon from Shad Lords.
55    
56     %prep
57     %setup
58     %patch0 -p1
59     %patch1 -p1
60     %patch2 -p1
61     %patch3 -p1
62     %patch4 -p1
63     %patch5 -p1
64     %patch6 -p1
65     %patch7 -p1
66     %patch8 -p1
67     %patch9 -p1
68 jpp 1.15 %patch10 -p1
69 jpp 1.14 %build
70     perl createlinks
71     %{__mkdir_p} root/etc/e-smith/web/panels/manager/html/smeadmin
72     %{__mkdir_p} root/usr/share/locale/en_US/LC_MESSAGES
73    
74     xgettext --from-code UTF-8 -F --no-wrap -L perl \
75     -o root/usr/share/locale/en_US/LC_MESSAGES/smeadmin.po \
76     root/etc/e-smith/web/functions/smeadmin \
77     root/usr/bin/smeadmind
78    
79     /sbin/e-smith/generate-lexicons
80    
81     %install
82     rm -rf $RPM_BUILD_ROOT
83     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
84     rm -f %{name}-%{version}-filelist
85     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
86     --file /usr/bin/smeadmind 'attr(755,root,root)' \
87     --file /usr/share/doc/smeserver-smeadmin/add_ds_to_rrd.pl 'attr(755,root,root)' \
88     > %{name}-%{version}-filelist
89    
90     %clean
91     rm -rf $RPM_BUILD_ROOT
92    
93     %pre
94    
95     %preun
96    
97     %post
98    
99     %postun
100    
101     %files -f %{name}-%{version}-filelist
102     %defattr(-,root,root)
103 jcrisp 1.1
104     %changelog
105 jpp 1.17 * Fri Dec 22 2023 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-12.sme
106 jpp 1.14 - add accounting of auth_failed [SME: 12447]
107     adding php8* services
108 jpp 1.17 - fix translation, reworked [SME: 10244]
109 jpp 1.14
110 jpp 1.13 * Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-10.sme
111     - apply locale 2022-11-11 patch
112    
113 jpp 1.12 * Sun Sep 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-9.sme
114     - fix misisng stopped services [SME: 11643]
115    
116 brianr 1.11 * Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.6-8.sme
117     - Re-build and link to latest devtools [SME: 11997]
118    
119 jpp 1.9 * Fri Jul 29 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-7.sme
120     - apply translation 2022-07-29
121 jpp 1.10 - add to core backup [SME: 12023]
122 jpp 1.9
123 terryfage 1.8 * Mon Jul 18 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 1.6-6.sme
124     - bz11642 authproxy errorlog [SME: 11642]
125     - bz11590 error log [SME: 11590]
126    
127 michel 1.7 * Mon Jul 18 2022 Michel Begue <mab974@misouk.com> 1.6-5.sme
128     - get real ssh port from configuration db. [SME: 10761]
129    
130 terryfage 1.6 * Wed Sep 08 2021 Terry Fage <terry.fage@gmail.com> 1.6-4.sme
131     - apply locale 2021-09-08 patch
132    
133 terryfage 1.5 * Tue Aug 24 2021 Terry Fage <terry.fage@gmail.com> 1.6-3.sme
134     - apply locale 2021-08-24 patch
135    
136 jpp 1.3 * Thu Mar 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-2.sme
137 brianr 1.11 - Re-build and link to latest devtools mysql not migrating sme9admind [SME: 11062]
138     - Re-build and link to latest devtools config db sme9admind not migrated to smeadmind
139     - Re-build and link to latest devtools /var/lib/sme9admin not migrated
140 jpp 1.3 - add smeserver-smeadmin-update event
141 brianr 1.11 - Re-build and link to latest devtools services diplayed multiple times [SME: 11455]
142 jpp 1.4 - systemd unit
143     - review new logs locations
144     - check calls to sysvinit
145     - TODO implement new VPNs stats
146 jpp 1.3
147 jcrisp 1.1 * Thu Oct 15 2020 Brian Read <brianr@bjsystems.co.uk> 1.6-1
148 brianr 1.2 - Move to SME10, rename to smeadmin [SME: 11040, 11062]
149 jcrisp 1.1
150     * Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 1.5-30.sme
151     - apply locale 2019-12-07 patch
152    
153 jpp 1.13 * Mon Sep 09 2019 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-29.sme
154 brianr 1.11 - Re-build and link to latest devtools smeadmind die on mysql connection error [SME: 7683]
155 jcrisp 1.1
156     * Sat Dec 02 2017 SME Translation Server <translations@contribs.org> 1.5-28.sme
157     - apply locale 2017-12-02 patch
158    
159 jpp 1.13 * Mon Aug 14 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-27.sme
160 jcrisp 1.1 - add support for altqmail [SME: 10409]
161    
162 jpp 1.13 * Mon Jul 10 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-26.sme
163 brianr 1.11 - Re-build and link to latest devtools error after migrating sme8admin db, unable to access mysql db [SME: 10181]
164 jcrisp 1.1
165 jpp 1.13 * Sat Mar 25 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-25.sme
166 jcrisp 1.1 - apply locale 2017-03-26 patch
167    
168 jpp 1.13 * Wed Feb 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-24.sme
169 jcrisp 1.1 - apply locale 2017-02-02.patch
170    
171 jpp 1.13 * Sun Jan 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-23.sme
172 brianr 1.11 - Re-build and link to latest devtools warning related to raid detection code [SME: 9886]
173     - Re-build and link to latest devtools warning related to non existing services removed sinces previous versions [SME: 9889]
174 jcrisp 1.1
175 jpp 1.13 * Tue Dec 20 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-22.sme
176 jcrisp 1.1 - make CGI and pictures utf8 compliant [SME: 9894]
177     - apply smeserver-smeadmin-1.5-locale-2016-12-20.patch
178    
179 jpp 1.13 * Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-21.sme
180 jcrisp 1.1 - locals smeserver-smeadmin-1.5-locale-2016-12-18.patch
181    
182 jpp 1.13 * Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-20.sme
183 brianr 1.11 - Re-build and link to latest devtools last patch by adding path to called programs
184 jcrisp 1.1
185 jpp 1.13 * Thu Dec 15 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-19.sme
186 brianr 1.11 - Re-build and link to latest devtools bad accounting for incoming and outgoing mail [SME: 8818]
187 jcrisp 1.1 - mail_in alert now account for all queued emails from qpsmtpd and sqpsmtpd
188     - mail_out alert now account for qmail total remote delivery attempts
189     - known issue : on first run will account more than 5 minutes ( whole log) and will alert for exceeding amount
190     - added accounting of qpsmtpd and sqpsmtpd code
191     - TODO: alert on qmail queue too high, alert on too many qpsmtpd connections
192    
193 jpp 1.13 * Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-18.sme
194 brianr 1.11 - Re-build and link to latest devtools limited size in mysql fields for traffic accounting [SME: 8399]
195 jcrisp 1.1
196 jpp 1.13 * Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-16.sme
197 jcrisp 1.1 - add more verbose email alert [SME: 9725]
198    
199     * Fri Aug 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5-15.sme
200     - Initial release to contribs9
201    
202     * Wed Dec 24 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-14.sme
203     - changed $mypid = `cat $mypid` by open(FIC,"<$mypid") [SME:8740]
204    
205     * Tue Dec 23 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-13.sme
206     - Corrected bug of empty pids [SME:8732]
207     - Added exeption if the server is not in server & gateway [SME:8739]
208    
209     * Thu Dec 11 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-12.sme
210     - corrected the dhcpd lease not reported [SME:8724]
211    
212     * Tue Nov 25 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-11.sme
213     - Added a restart to smeadmind when settings are changed in the smeadmin panel
214    
215     * Sat Nov 22 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-10.sme
216     - added a second fan speed sensors
217     - added four HD TEMP sensors
218     - added a new graph only for hd temperature sensor
219     - added an event smeadmin-update for avoiding to restart the server
220     - added a tab to check the raid status
221    
222     * Sun Nov 16 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-9.sme
223     - Changed in smeadmind L937 °C in .{1,2} .... Thanks JPP
224    
225     * Fri Nov 14 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-8.sme
226     - Added a service in rc7.d for lm_sensors
227     - added to sadf the -S to collect swap data
228     - changed txbyt/rxbyt to rxkB/txkB for collecting network load
229    
230     * Mon Sep 01 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-7.sme
231     - added 755 to /usr/bin/smeadmind
232    
233     * Wed Jun 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-6.sme
234     - Initial release to sme9
235    
236 jpp 1.13 * Sun Dec 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-4.sme
237 brianr 1.11 - Re-build and link to latest devtools obsolete missing [SME: 7109]
238     - Re-build and link to latest devtools pppoe and vpn loging [SME: 8061]
239 jcrisp 1.1 - added monthly ppoe log
240 brianr 1.11 - Re-build and link to latest devtools stop on mysql error too many connections [SME: 7683]
241 jcrisp 1.1
242 jpp 1.13 * Sun Sep 09 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-3.sme
243 jcrisp 1.1 - startup fix [SME 3022]
244    
245 jpp 1.13 * Wed Aug 15 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-2.sme
246 jcrisp 1.1 - 64 bits [SME 7040]
247    
248 jpp 1.13 * Sun Jun 10 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-1.sme
249 jcrisp 1.1 - Initial version
250    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed