/[smecontribs]/rpms/smeserver-smeadmin/contribs10/smeserver-smeadmin.spec
ViewVC logotype

Contents of /rpms/smeserver-smeadmin/contribs10/smeserver-smeadmin.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.18 - (show annotations) (download)
Mon May 20 03:12:23 2024 UTC (13 days, 6 hours ago) by jpp
Branch: MAIN
CVS Tags: smeserver-smeadmin-1_6-13_el7_sme, HEAD
Changes since 1.17: +9 -1 lines
* Sun May 19 2024 Jean-Philippe Pialasse <jpp@koozali.org> 1.6-13.sme
- fix pppoe not loging [SME: 12684]
  increase db volume field. filter display to last 24 months
  display in GB/MB instead of GiB/kiB

1 # $Id: smeserver-smeadmin.spec,v 1.17 2019/12/07 04:05:41 jpp Exp $
2 # Authority: vip-ire
3 # Name: Daniel Berteaud
4 #
5
6 Summary: A graphical monitor, alert raising, and services supervision tool for your SME Server.
7 %define name smeserver-smeadmin
8 Name: %{name}
9 %define version 1.6
10 %define release 13
11 Version: %{version}
12 Release: %{release}%{?dist}
13 License: GPL
14 Group: Networking/Daemons
15 Source: %{name}-%{version}.tar.gz
16 Patch0: smeserver-smeadmin-1.6-bz11062-initial-import.patch
17 Patch1: smeserver-smeadmin-1.6-locale-2021-08-24.patch
18 Patch2: smeserver-smeadmin-1.6-locale-2021-09-08.patch
19 Patch3: smeserver-smeadmin-1.6-bz10761_real_ssh_port.patch
20 Patch4: smeserver-smeadmin-1.6-bz11642-bz1159-authproxy-errorlog.patch
21 Patch5: smeserver-smeadmin-1.6-locale-2022-07-29.patch
22 Patch6: smeserver-smeadmin-1.6-bz12023-backup.patch
23 Patch7: smeserver-smeadmin-1.6-bz11643-services.patch
24 Patch8: smeserver-smeadmin-1.6-locale-2022-11-11.patch
25 Patch9: smeserver-smeadmin-1.6-bz12447-auth-qpsmtpd.patch
26 Patch10: smeserver-smeadmin-1.6-bz10244-bz11754-translation.patch
27 Patch11: smeserver-smeadmin-1.6-bz12684-fixppoe-FTTH.patch
28
29 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
30 BuildArchitectures: noarch
31
32 BuildRequires: e-smith-devtools
33 BuildRequires: gettext
34
35 Requires: e-smith-base
36 Requires: smeserver-release >= 10
37 Requires: rrdtool-perl
38 Requires: rrdtool
39 Requires: hddtemp
40 Requires: sysstat
41 Requires: lm_sensors
42 #Obsoletes: smeserver-sme8admin
43
44 AutoReqProv: no
45 %description
46 The main part of smeadmin is a daemon which gathers informations from logs
47 and other tools like systat, it then feed a mysql database and create RRD
48 graphs about your system state.
49 This daemon can also send periodics mails (with some logs), and alerts mails
50 based on configurable thresolds.
51
52 A panel is also available in the server-manager, with which you can access gathered
53 data, display the RRD graphs and configure the service.
54
55 This contrib is a bit inspired by e-smith-sysmon from Shad Lords.
56
57 %prep
58 %setup
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62 %patch3 -p1
63 %patch4 -p1
64 %patch5 -p1
65 %patch6 -p1
66 %patch7 -p1
67 %patch8 -p1
68 %patch9 -p1
69 %patch10 -p1
70 %patch11 -p1
71
72 %build
73 perl createlinks
74 %{__mkdir_p} root/etc/e-smith/web/panels/manager/html/smeadmin
75 %{__mkdir_p} root/usr/share/locale/en_US/LC_MESSAGES
76
77 xgettext --from-code UTF-8 -F --no-wrap -L perl \
78 -o root/usr/share/locale/en_US/LC_MESSAGES/smeadmin.po \
79 root/etc/e-smith/web/functions/smeadmin \
80 root/usr/bin/smeadmind
81
82 /sbin/e-smith/generate-lexicons
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
87 rm -f %{name}-%{version}-filelist
88 /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
89 --file /usr/bin/smeadmind 'attr(755,root,root)' \
90 --file /usr/share/doc/smeserver-smeadmin/add_ds_to_rrd.pl 'attr(755,root,root)' \
91 > %{name}-%{version}-filelist
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %pre
97
98 %preun
99
100 %post
101
102 %postun
103
104 %files -f %{name}-%{version}-filelist
105 %defattr(-,root,root)
106
107 %changelog
108 * Sun May 19 2024 Jean-Philippe Pialasse <jpp@koozali.org> 1.6-13.sme
109 - fix pppoe not loging [SME: 12684]
110 increase db volume field. filter display to last 24 months
111 display in GB/MB instead of GiB/kiB
112
113 * Fri Dec 22 2023 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-12.sme
114 - add accounting of auth_failed [SME: 12447]
115 adding php8* services
116 - fix translation, reworked [SME: 10244]
117
118 * Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-10.sme
119 - apply locale 2022-11-11 patch
120
121 * Sun Sep 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-9.sme
122 - fix misisng stopped services [SME: 11643]
123
124 * Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.6-8.sme
125 - Re-build and link to latest devtools [SME: 11997]
126
127 * Fri Jul 29 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-7.sme
128 - apply translation 2022-07-29
129 - add to core backup [SME: 12023]
130
131 * Mon Jul 18 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 1.6-6.sme
132 - bz11642 authproxy errorlog [SME: 11642]
133 - bz11590 error log [SME: 11590]
134
135 * Mon Jul 18 2022 Michel Begue <mab974@misouk.com> 1.6-5.sme
136 - get real ssh port from configuration db. [SME: 10761]
137
138 * Wed Sep 08 2021 Terry Fage <terry.fage@gmail.com> 1.6-4.sme
139 - apply locale 2021-09-08 patch
140
141 * Tue Aug 24 2021 Terry Fage <terry.fage@gmail.com> 1.6-3.sme
142 - apply locale 2021-08-24 patch
143
144 * Thu Mar 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-2.sme
145 - Re-build and link to latest devtools mysql not migrating sme9admind [SME: 11062]
146 - Re-build and link to latest devtools config db sme9admind not migrated to smeadmind
147 - Re-build and link to latest devtools /var/lib/sme9admin not migrated
148 - add smeserver-smeadmin-update event
149 - Re-build and link to latest devtools services diplayed multiple times [SME: 11455]
150 - systemd unit
151 - review new logs locations
152 - check calls to sysvinit
153 - TODO implement new VPNs stats
154
155 * Thu Oct 15 2020 Brian Read <brianr@bjsystems.co.uk> 1.6-1
156 - Move to SME10, rename to smeadmin [SME: 11040, 11062]
157
158 * Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 1.5-30.sme
159 - apply locale 2019-12-07 patch
160
161 * Mon Sep 09 2019 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-29.sme
162 - Re-build and link to latest devtools smeadmind die on mysql connection error [SME: 7683]
163
164 * Sat Dec 02 2017 SME Translation Server <translations@contribs.org> 1.5-28.sme
165 - apply locale 2017-12-02 patch
166
167 * Mon Aug 14 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-27.sme
168 - add support for altqmail [SME: 10409]
169
170 * Mon Jul 10 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-26.sme
171 - Re-build and link to latest devtools error after migrating sme8admin db, unable to access mysql db [SME: 10181]
172
173 * Sat Mar 25 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-25.sme
174 - apply locale 2017-03-26 patch
175
176 * Wed Feb 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-24.sme
177 - apply locale 2017-02-02.patch
178
179 * Sun Jan 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-23.sme
180 - Re-build and link to latest devtools warning related to raid detection code [SME: 9886]
181 - Re-build and link to latest devtools warning related to non existing services removed sinces previous versions [SME: 9889]
182
183 * Tue Dec 20 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-22.sme
184 - make CGI and pictures utf8 compliant [SME: 9894]
185 - apply smeserver-smeadmin-1.5-locale-2016-12-20.patch
186
187 * Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-21.sme
188 - locals smeserver-smeadmin-1.5-locale-2016-12-18.patch
189
190 * Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-20.sme
191 - Re-build and link to latest devtools last patch by adding path to called programs
192
193 * Thu Dec 15 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-19.sme
194 - Re-build and link to latest devtools bad accounting for incoming and outgoing mail [SME: 8818]
195 - mail_in alert now account for all queued emails from qpsmtpd and sqpsmtpd
196 - mail_out alert now account for qmail total remote delivery attempts
197 - known issue : on first run will account more than 5 minutes ( whole log) and will alert for exceeding amount
198 - added accounting of qpsmtpd and sqpsmtpd code
199 - TODO: alert on qmail queue too high, alert on too many qpsmtpd connections
200
201 * Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-18.sme
202 - Re-build and link to latest devtools limited size in mysql fields for traffic accounting [SME: 8399]
203
204 * Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-16.sme
205 - add more verbose email alert [SME: 9725]
206
207 * Fri Aug 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5-15.sme
208 - Initial release to contribs9
209
210 * Wed Dec 24 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-14.sme
211 - changed $mypid = `cat $mypid` by open(FIC,"<$mypid") [SME:8740]
212
213 * Tue Dec 23 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-13.sme
214 - Corrected bug of empty pids [SME:8732]
215 - Added exeption if the server is not in server & gateway [SME:8739]
216
217 * Thu Dec 11 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-12.sme
218 - corrected the dhcpd lease not reported [SME:8724]
219
220 * Tue Nov 25 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-11.sme
221 - Added a restart to smeadmind when settings are changed in the smeadmin panel
222
223 * Sat Nov 22 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-10.sme
224 - added a second fan speed sensors
225 - added four HD TEMP sensors
226 - added a new graph only for hd temperature sensor
227 - added an event smeadmin-update for avoiding to restart the server
228 - added a tab to check the raid status
229
230 * Sun Nov 16 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-9.sme
231 - Changed in smeadmind L937 °C in .{1,2} .... Thanks JPP
232
233 * Fri Nov 14 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-8.sme
234 - Added a service in rc7.d for lm_sensors
235 - added to sadf the -S to collect swap data
236 - changed txbyt/rxbyt to rxkB/txkB for collecting network load
237
238 * Mon Sep 01 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-7.sme
239 - added 755 to /usr/bin/smeadmind
240
241 * Wed Jun 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-6.sme
242 - Initial release to sme9
243
244 * Sun Dec 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-4.sme
245 - Re-build and link to latest devtools obsolete missing [SME: 7109]
246 - Re-build and link to latest devtools pppoe and vpn loging [SME: 8061]
247 - added monthly ppoe log
248 - Re-build and link to latest devtools stop on mysql error too many connections [SME: 7683]
249
250 * Sun Sep 09 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-3.sme
251 - startup fix [SME 3022]
252
253 * Wed Aug 15 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-2.sme
254 - 64 bits [SME 7040]
255
256 * Sun Jun 10 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-1.sme
257 - Initial version
258

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed