1 |
# $Id: smeserver-smeadmin.spec,v 1.17 2019/12/07 04:05:41 jpp Exp $ |
2 |
# Authority: vip-ire |
3 |
# Name: Daniel Berteaud |
4 |
# |
5 |
|
6 |
Summary: A graphical monitor, alert raising, and services supervision tool for your SME Server. |
7 |
%define name smeserver-smeadmin |
8 |
Name: %{name} |
9 |
%define version 1.6 |
10 |
%define release 14 |
11 |
Version: %{version} |
12 |
Release: %{release}%{?dist} |
13 |
License: GPL |
14 |
Group: Networking/Daemons |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Patch0: smeserver-smeadmin-1.6-bz11062-initial-import.patch |
17 |
Patch1: smeserver-smeadmin-1.6-locale-2021-08-24.patch |
18 |
Patch2: smeserver-smeadmin-1.6-locale-2021-09-08.patch |
19 |
Patch3: smeserver-smeadmin-1.6-bz10761_real_ssh_port.patch |
20 |
Patch4: smeserver-smeadmin-1.6-bz11642-bz1159-authproxy-errorlog.patch |
21 |
Patch5: smeserver-smeadmin-1.6-locale-2022-07-29.patch |
22 |
Patch6: smeserver-smeadmin-1.6-bz12023-backup.patch |
23 |
Patch7: smeserver-smeadmin-1.6-bz11643-services.patch |
24 |
Patch8: smeserver-smeadmin-1.6-locale-2022-11-11.patch |
25 |
Patch9: smeserver-smeadmin-1.6-bz12447-auth-qpsmtpd.patch |
26 |
Patch10: smeserver-smeadmin-1.6-bz10244-bz11754-translation.patch |
27 |
Patch11: smeserver-smeadmin-1.6-bz12684-fixppoe-FTTH.patch |
28 |
Patch12: smeserver-smeadmin-1.6-locale-2024-09-06.patch |
29 |
|
30 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
31 |
BuildArchitectures: noarch |
32 |
|
33 |
BuildRequires: e-smith-devtools |
34 |
BuildRequires: gettext |
35 |
|
36 |
Requires: e-smith-base |
37 |
Requires: smeserver-release >= 10 |
38 |
Requires: rrdtool-perl |
39 |
Requires: rrdtool |
40 |
Requires: hddtemp |
41 |
Requires: sysstat |
42 |
Requires: lm_sensors |
43 |
#Obsoletes: smeserver-sme8admin |
44 |
|
45 |
AutoReqProv: no |
46 |
%description |
47 |
The main part of smeadmin is a daemon which gathers informations from logs |
48 |
and other tools like systat, it then feed a mysql database and create RRD |
49 |
graphs about your system state. |
50 |
This daemon can also send periodics mails (with some logs), and alerts mails |
51 |
based on configurable thresolds. |
52 |
|
53 |
A panel is also available in the server-manager, with which you can access gathered |
54 |
data, display the RRD graphs and configure the service. |
55 |
|
56 |
This contrib is a bit inspired by e-smith-sysmon from Shad Lords. |
57 |
|
58 |
%prep |
59 |
%setup |
60 |
%patch0 -p1 |
61 |
%patch1 -p1 |
62 |
%patch2 -p1 |
63 |
%patch3 -p1 |
64 |
%patch4 -p1 |
65 |
%patch5 -p1 |
66 |
%patch6 -p1 |
67 |
%patch7 -p1 |
68 |
%patch8 -p1 |
69 |
%patch9 -p1 |
70 |
%patch10 -p1 |
71 |
%patch11 -p1 |
72 |
%patch12 -p1 |
73 |
|
74 |
%build |
75 |
perl createlinks |
76 |
%{__mkdir_p} root/etc/e-smith/web/panels/manager/html/smeadmin |
77 |
%{__mkdir_p} root/usr/share/locale/en_US/LC_MESSAGES |
78 |
|
79 |
xgettext --from-code UTF-8 -F --no-wrap -L perl \ |
80 |
-o root/usr/share/locale/en_US/LC_MESSAGES/smeadmin.po \ |
81 |
root/etc/e-smith/web/functions/smeadmin \ |
82 |
root/usr/bin/smeadmind |
83 |
|
84 |
/sbin/e-smith/generate-lexicons |
85 |
|
86 |
%install |
87 |
rm -rf $RPM_BUILD_ROOT |
88 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
89 |
rm -f %{name}-%{version}-filelist |
90 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
91 |
--file /usr/bin/smeadmind 'attr(755,root,root)' \ |
92 |
--file /usr/share/doc/smeserver-smeadmin/add_ds_to_rrd.pl 'attr(755,root,root)' \ |
93 |
> %{name}-%{version}-filelist |
94 |
|
95 |
%clean |
96 |
rm -rf $RPM_BUILD_ROOT |
97 |
|
98 |
%pre |
99 |
|
100 |
%preun |
101 |
|
102 |
%post |
103 |
|
104 |
%postun |
105 |
|
106 |
%files -f %{name}-%{version}-filelist |
107 |
%defattr(-,root,root) |
108 |
|
109 |
%changelog |
110 |
* Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 1.6-14.sme |
111 |
- apply locale 2024-09-06.patch |
112 |
|
113 |
* Sun May 19 2024 Jean-Philippe Pialasse <jpp@koozali.org> 1.6-13.sme |
114 |
- fix pppoe not loging [SME: 12684] |
115 |
increase db volume field. filter display to last 24 months |
116 |
display in GB/MB instead of GiB/kiB |
117 |
|
118 |
* Fri Dec 22 2023 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-12.sme |
119 |
- add accounting of auth_failed [SME: 12447] |
120 |
adding php8* services |
121 |
- fix translation, reworked [SME: 10244] |
122 |
|
123 |
* Fri Nov 11 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-10.sme |
124 |
- apply locale 2022-11-11 patch |
125 |
|
126 |
* Sun Sep 18 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-9.sme |
127 |
- fix misisng stopped services [SME: 11643] |
128 |
|
129 |
* Sat Jul 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.6-8.sme |
130 |
- Re-build and link to latest devtools [SME: 11997] |
131 |
|
132 |
* Fri Jul 29 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-7.sme |
133 |
- apply translation 2022-07-29 |
134 |
- add to core backup [SME: 12023] |
135 |
|
136 |
* Mon Jul 18 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 1.6-6.sme |
137 |
- bz11642 authproxy errorlog [SME: 11642] |
138 |
- bz11590 error log [SME: 11590] |
139 |
|
140 |
* Mon Jul 18 2022 Michel Begue <mab974@misouk.com> 1.6-5.sme |
141 |
- get real ssh port from configuration db. [SME: 10761] |
142 |
|
143 |
* Wed Sep 08 2021 Terry Fage <terry.fage@gmail.com> 1.6-4.sme |
144 |
- apply locale 2021-09-08 patch |
145 |
|
146 |
* Tue Aug 24 2021 Terry Fage <terry.fage@gmail.com> 1.6-3.sme |
147 |
- apply locale 2021-08-24 patch |
148 |
|
149 |
* Thu Mar 25 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.6-2.sme |
150 |
- Re-build and link to latest devtools mysql not migrating sme9admind [SME: 11062] |
151 |
- Re-build and link to latest devtools config db sme9admind not migrated to smeadmind |
152 |
- Re-build and link to latest devtools /var/lib/sme9admin not migrated |
153 |
- add smeserver-smeadmin-update event |
154 |
- Re-build and link to latest devtools services diplayed multiple times [SME: 11455] |
155 |
- systemd unit |
156 |
- review new logs locations |
157 |
- check calls to sysvinit |
158 |
- TODO implement new VPNs stats |
159 |
|
160 |
* Thu Oct 15 2020 Brian Read <brianr@bjsystems.co.uk> 1.6-1 |
161 |
- Move to SME10, rename to smeadmin [SME: 11040, 11062] |
162 |
|
163 |
* Sat Dec 07 2019 SME Translation Server <translations@contribs.org> 1.5-30.sme |
164 |
- apply locale 2019-12-07 patch |
165 |
|
166 |
* Mon Sep 09 2019 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-29.sme |
167 |
- Re-build and link to latest devtools smeadmind die on mysql connection error [SME: 7683] |
168 |
|
169 |
* Sat Dec 02 2017 SME Translation Server <translations@contribs.org> 1.5-28.sme |
170 |
- apply locale 2017-12-02 patch |
171 |
|
172 |
* Mon Aug 14 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-27.sme |
173 |
- add support for altqmail [SME: 10409] |
174 |
|
175 |
* Mon Jul 10 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-26.sme |
176 |
- Re-build and link to latest devtools error after migrating sme8admin db, unable to access mysql db [SME: 10181] |
177 |
|
178 |
* Sat Mar 25 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-25.sme |
179 |
- apply locale 2017-03-26 patch |
180 |
|
181 |
* Wed Feb 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-24.sme |
182 |
- apply locale 2017-02-02.patch |
183 |
|
184 |
* Sun Jan 01 2017 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-23.sme |
185 |
- Re-build and link to latest devtools warning related to raid detection code [SME: 9886] |
186 |
- Re-build and link to latest devtools warning related to non existing services removed sinces previous versions [SME: 9889] |
187 |
|
188 |
* Tue Dec 20 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-22.sme |
189 |
- make CGI and pictures utf8 compliant [SME: 9894] |
190 |
- apply smeserver-smeadmin-1.5-locale-2016-12-20.patch |
191 |
|
192 |
* Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-21.sme |
193 |
- locals smeserver-smeadmin-1.5-locale-2016-12-18.patch |
194 |
|
195 |
* Sat Dec 17 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-20.sme |
196 |
- Re-build and link to latest devtools last patch by adding path to called programs |
197 |
|
198 |
* Thu Dec 15 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-19.sme |
199 |
- Re-build and link to latest devtools bad accounting for incoming and outgoing mail [SME: 8818] |
200 |
- mail_in alert now account for all queued emails from qpsmtpd and sqpsmtpd |
201 |
- mail_out alert now account for qmail total remote delivery attempts |
202 |
- known issue : on first run will account more than 5 minutes ( whole log) and will alert for exceeding amount |
203 |
- added accounting of qpsmtpd and sqpsmtpd code |
204 |
- TODO: alert on qmail queue too high, alert on too many qpsmtpd connections |
205 |
|
206 |
* Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-18.sme |
207 |
- Re-build and link to latest devtools limited size in mysql fields for traffic accounting [SME: 8399] |
208 |
|
209 |
* Wed Nov 23 2016 Jean-Philippe Pialasse <tests@pialasse.com> 1.5-16.sme |
210 |
- add more verbose email alert [SME: 9725] |
211 |
|
212 |
* Fri Aug 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.5-15.sme |
213 |
- Initial release to contribs9 |
214 |
|
215 |
* Wed Dec 24 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-14.sme |
216 |
- changed $mypid = `cat $mypid` by open(FIC,"<$mypid") [SME:8740] |
217 |
|
218 |
* Tue Dec 23 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-13.sme |
219 |
- Corrected bug of empty pids [SME:8732] |
220 |
- Added exeption if the server is not in server & gateway [SME:8739] |
221 |
|
222 |
* Thu Dec 11 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-12.sme |
223 |
- corrected the dhcpd lease not reported [SME:8724] |
224 |
|
225 |
* Tue Nov 25 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-11.sme |
226 |
- Added a restart to smeadmind when settings are changed in the smeadmin panel |
227 |
|
228 |
* Sat Nov 22 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-10.sme |
229 |
- added a second fan speed sensors |
230 |
- added four HD TEMP sensors |
231 |
- added a new graph only for hd temperature sensor |
232 |
- added an event smeadmin-update for avoiding to restart the server |
233 |
- added a tab to check the raid status |
234 |
|
235 |
* Sun Nov 16 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-9.sme |
236 |
- Changed in smeadmind L937 °C in .{1,2} .... Thanks JPP |
237 |
|
238 |
* Fri Nov 14 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-8.sme |
239 |
- Added a service in rc7.d for lm_sensors |
240 |
- added to sadf the -S to collect swap data |
241 |
- changed txbyt/rxbyt to rxkB/txkB for collecting network load |
242 |
|
243 |
* Mon Sep 01 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-7.sme |
244 |
- added 755 to /usr/bin/smeadmind |
245 |
|
246 |
* Wed Jun 18 2014 stephane de labrusse <stephdl@de-labrusse.fr> 1.5-6.sme |
247 |
- Initial release to sme9 |
248 |
|
249 |
* Sun Dec 15 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-4.sme |
250 |
- Re-build and link to latest devtools obsolete missing [SME: 7109] |
251 |
- Re-build and link to latest devtools pppoe and vpn loging [SME: 8061] |
252 |
- added monthly ppoe log |
253 |
- Re-build and link to latest devtools stop on mysql error too many connections [SME: 7683] |
254 |
|
255 |
* Sun Sep 09 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-3.sme |
256 |
- startup fix [SME 3022] |
257 |
|
258 |
* Wed Aug 15 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-2.sme |
259 |
- 64 bits [SME 7040] |
260 |
|
261 |
* Sun Jun 10 2012 Jean-Philippe Pialasse <tests@pialasse.com> 1.3-1.sme |
262 |
- Initial version |
263 |
|