/[smecontribs]/rpms/smeserver-sogo/contribs10/smeserver-sogo.spec
ViewVC logotype

Annotation of /rpms/smeserver-sogo/contribs10/smeserver-sogo.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Jan 3 11:54:04 2023 UTC (17 months, 4 weeks ago) by jpp
Branch: MAIN
CVS Tags: smeserver-sogo-1_5-1_el6_sme
Initial import

1 jpp 1.1 # $Id$
2     %define name smeserver-sogo
3     %define version 1.5
4     %define release 1
5    
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}%{?dist}
9     Summary: SME Server SOGo Groupware
10     Group: Networking/Daemons
11     License: GPLv3+
12     URL: http://www.smeserver.org
13     Source0: %{name}-%{version}.tar.gz
14     BuildArch: noarch
15     BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
16     Epoch: 9
17     BuildRequires: e-smith-devtools
18     Requires: smeserver-release >= 9
19     Requires: e-smith-ldap
20     Requires: sogo >= 2.3.0
21     Requires: sogo-tool
22     Requires: memcached
23     Requires: sogo-activesync
24     Requires: sope49-gdl1-mysql
25     Requires: sogo-ealarms-notify
26     Requires: python-memcached
27     Requires: smeserver-dovecot-extras
28     %description
29     SME Server module for SOGo groupware.
30    
31     %prep
32     ##my bad to remove a bad folder if exists [1.3-6.sme]
33     /bin/rm -rf /var/service/tinydns/root/data/ &> /dev/null
34    
35     %setup -q
36    
37     %build
38     [ -x createlinks ] && ./createlinks
39    
40     %install
41     rm -rf $RPM_BUILD_ROOT
42     rm -f %{name}-%{version}-filelist
43    
44     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
45    
46     /sbin/e-smith/genfilelist \
47     --dir /var/lib/sogo/GNUstep 'attr(0755,sogo,sogo)' \
48     --dir /var/lib/sogo/GNUstep/Defaults 'attr(0755,sogo,sogo)' \
49     $RPM_BUILD_ROOT > %{name}-%{version}-%{release}-filelist
50    
51     %clean
52     rm -rf $RPM_BUILD_ROOT
53    
54    
55     %post
56    
57     if [ $1 == 1 ]; then #first install
58     /etc/e-smith/events/actions/initialize-default-databases &> /dev/null
59     /sbin/e-smith/expand-template \
60     /etc/e-smith/sql/init/30sogo_mysql_create_database
61     /sbin/e-smith/expand-template \
62     /etc/e-smith/sql/init/31sogo_mysql_update_privileges
63     /sbin/e-smith/expand-template \
64     /var/lib/sogo/smeserver/sogo_mysql_update_privileges.sql
65     /sbin/e-smith/expand-template \
66     /etc/e-smith/sql/init/31sogo_upgrade
67     /sbin/e-smith/expand-template \
68     /etc/e-smith/sql/init/32sogo_upgrade_2.3
69     /sbin/service mysql.init start
70     /sbin/e-smith/signal-event sogo-modify
71     elif [ $1 -gt 1 ]; then #update
72     /sbin/e-smith/expand-template \
73     /etc/e-smith/sql/init/31sogo_upgrade
74     /sbin/e-smith/expand-template \
75     /etc/e-smith/sql/init/32sogo_upgrade_2.3
76     /sbin/service mysql.init start
77     /etc/e-smith/events/actions/initialize-default-databases &> /dev/null || :
78     /sbin/e-smith/signal-event sogo-modify || :
79     fi
80    
81     # set sogo password
82     /bin/cat /etc/openldap/ldap.pw | /usr/bin/passwd sogo --stdin &> /dev/null || :
83    
84    
85     %postun
86     if [ $1 = 1 ]; then
87     /etc/e-smith/events/actions/initialize-default-databases &> /dev/null || :
88     /sbin/e-smith/signal-event sogo-modify || :
89     fi
90    
91    
92    
93     %files -f %{name}-%{version}-%{release}-filelist
94    
95    
96     %changelog
97     * Wed Apr 28 2017 Stephane de Labrusse <stephdl@de-labrusse.fr> - 1.5-1.sme
98     - Increase maximum IMAP command line length
99     - Adjusted sogo cron.d, sieve credentials are in /etc/sogo/sieve.creds
100    
101     * Fri Mar 24 2017 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.4-2.sme
102     - Add custom settings to avoid battery drain when using active sync [SME: 10168]
103     - Thank to Michael McCarn <mmccarn-sme@mmsionline.us>
104     - the sogo.conf template is rewritten by fragments
105     - Correction of the backup creation [SME: 9908]
106     - Thank to Nicola Tiana <sistemi@chester-perry.it>
107    
108     * Sun Jul 24 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-19.sme
109     - remove the email of cron for expire-autoreply
110    
111     * Sat Jan 16 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-18.sme
112     - the template-end is created in the sogo.conf to allow the end user to add his settings
113    
114     * Wed Oct 7 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-17.sme
115     - /etc/e-smith/sql/init/32sogo_upgrade_2.3 is now executable
116     - actions sogo_upgrade_2.3 is rewritten, thank to daniel Berteaud
117    
118     * Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-15.sme
119     - Added sogo-modify to mysql.init
120    
121     * Wed Jul 8 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-14.sme
122     - Upgrade to sogo 2.3.0, alteration table needed
123     - thank to ian case <ianc@caseinfo.net>
124    
125     * Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-12.sme
126     - Remove a sogo user when a SME Server user is removed
127    
128     * Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-11.sme
129     - Fix the qpsmtpd fix_headers_case plugin
130    
131     * Tue Jan 6 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-10.sme
132     - Added bindFields parameters to SOGoUserSources based on suggestion of Nicola Tiana in [SME: 7578]
133     - According to SOGo installation guide, the value of bindFields has to be in an array for recent version
134     - Thanks to Mats Schuh <m.schuh@neckargeo.net>
135    
136     * Tue Dec 30 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-9.sme
137     - stop cron email confirmation to the sogo user account [SME: 8756]
138     - code done by Mats Schuh <m.schuh@neckargeo.net>
139    
140     * Mon Dec 29 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-8.sme
141     - Sogo must be an admin of dovecot for expire-autoreply [SME: 8753]
142     - Thanks to Mats Schuh <m.schuh@neckargeo.net>
143    
144     * Sat Nov 01 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-7.sme
145     - removed a bad file 80srvSOGo in the template path of /var/service/tinydns/root/data
146     - added restart and event-template to tinydns with sogo-modify
147    
148     * Sun Sep 21 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-5.sme
149     - SOGoMailMessageCheck has been replaced by SOGoRefreshViewCheck
150    
151     * Sun Aug 31 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-4.sme
152     - Added . separator for imap, instead of / by default
153    
154     * Sun Aug 17 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-3.sme
155     - a bit of clean and new code inspired from ipasserelle-groupware. Thanks to daniel berteaud <daniel@firewall-services.com>
156     - added sieve and acl support (come with smeserver-dovecot-extras)
157     - added a panel in the server-manager with options
158     - added active-sync support
159     - added sogo notifications
160    
161    
162     * Thu May 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.1-2
163     - First release For SME Server 9 Thanks for all previous valorous developers
164     - removed expand-template for bootstrap-console-save in createlink
165     - added an architecture detection for template the file
166     - /etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess
167    
168     * Wed Dec 11 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.1-1
169     - Fixed sogo.conf syntax. Refs #2339
170    
171     * Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.0-1
172     - Release 1.0.0. Refs #2339
173     - Require sogo >= 2.1.1b-1
174    
175     * Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 0.9.1-1
176     - Release 0.9.1
177     - Fixes bug #2372
178    
179     * Mon Dec 2 2013 Davide Principi <davide.principi@nethesis.it> - 0.9-1
180     - sogo home directory moved to /var/lib/sogo to fix #2369
181    
182     * Fri Apr 26 2013 Davide Principi <davide.principi@nethesis.it> - 0.8-2
183     - Create symlink to new SOGo 2.0.x homedir, to support fresh installations
184    
185     * Thu Oct 18 2012 Giacomo Sanchiettti <giacomo.sanchietti@nethesis.it> - 0.8-1
186     - Add support for vacation auto-disable feature
187     - Add memcached requires (previously on sogo package)
188    
189     * Fri Sep 14 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.7-1
190     - Enable notification for calendar modifications (refs #1398)
191     - Customize From header (refs #1339)
192     - Support SharedFolder (refs #1432)
193    
194     * Fri Mar 9 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6.1
195     - Removed bindFields (bug #845)
196     - Fixed backup by sogo-tool (bug #839)
197     - Upgrade SOGo db to 1.3.12
198    
199     * Wed Nov 30 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6
200     - change GNUstep path
201    
202     * Wed Sep 7 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-2
203     - Add CardDAV external access (bug #423)
204    
205     * Wed Jul 20 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-1
206     - Disable sieve support for NethService 8.0
207     - Correct postun
208    
209     * Mon May 16 2011 Giacomo Sanchietti <giacomo@nethesis.it> - 0.5.8-1
210     - Add sieve support
211     - Add configurable prefork option
212     - Enable session folders
213     - Update to SOGo 1.3.4
214    
215     * Thu Aug 5 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.6-1
216     - add configurable option for ACLsSendEMailNotifications
217     - add EnablePublicAccess
218     - change MailingMechanism to SMTP
219     - redirect http requests for sogo to SOGo
220    
221     * Mon Aug 2 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.5-1
222     - upgrade to sogo 1.3.0
223    
224     * Tue Mar 30 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.4-1
225     - escape curly brackets in sogo logrotate template
226    
227     * Fri Mar 19 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.3-1
228     - add logrotate for sogo log files
229     - nethesis smesetup (post/postun) scripts
230    
231     * Tue Mar 16 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.2-2
232     - rej files cleanup
233    
234     * Tue Mar 16 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.2-1
235     - enable groups for ACL
236     - configure admin users from the db
237     - disable bogus notifications (acl and folders)
238     - configure sent and draft imap folders from DB
239     - redirect webmail when imp is disabled (Stephen Noble)
240     - proxypass port from the db (Federico Simoncelli)
241    
242     * Fri Mar 12 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.1-1
243     - anonymous bind is sufficient to authenticate users
244     - limit sogo daemon bind to the loopback interface
245     - SOGo protected with SSL
246     - memcached bind to loopback, port from TCPPort
247     - templates expansion from post-upgrade to bootstrap-console-save
248     - read the ldap port from db
249     - split the local ldap directory in two parts: users and groups
250     - notifications sent by email will have the correct URL
251    
252     * Thu Feb 18 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.0-1
253     - first release
254    
255    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed