1 |
jpp |
1.1 |
# $Id$ |
2 |
|
|
%define name smeserver-sogo |
3 |
brianr |
1.2 |
%define version 1.6 |
4 |
jpp |
1.1 |
%define release 1 |
5 |
|
|
|
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Summary: SME Server SOGo Groupware |
10 |
|
|
Group: Networking/Daemons |
11 |
|
|
License: GPLv3+ |
12 |
|
|
URL: http://www.smeserver.org |
13 |
|
|
Source0: %{name}-%{version}.tar.gz |
14 |
brianr |
1.4 |
Patch0: smeserver-sogo-1.6-Update-to-SME10-Apache-2.4-and-systemd-dropin.patch |
15 |
|
|
|
16 |
jpp |
1.1 |
BuildArch: noarch |
17 |
|
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) |
18 |
|
|
Epoch: 9 |
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
brianr |
1.4 |
Requires: smeserver-release >= 10 |
21 |
jpp |
1.1 |
Requires: e-smith-ldap |
22 |
brianr |
1.4 |
Requires: sogo >= 5.8.0 |
23 |
jpp |
1.1 |
Requires: sogo-tool |
24 |
|
|
Requires: memcached |
25 |
|
|
Requires: sogo-activesync |
26 |
|
|
Requires: sope49-gdl1-mysql |
27 |
|
|
Requires: sogo-ealarms-notify |
28 |
|
|
Requires: python-memcached |
29 |
|
|
Requires: smeserver-dovecot-extras |
30 |
|
|
%description |
31 |
|
|
SME Server module for SOGo groupware. |
32 |
|
|
|
33 |
|
|
%prep |
34 |
|
|
##my bad to remove a bad folder if exists [1.3-6.sme] |
35 |
|
|
/bin/rm -rf /var/service/tinydns/root/data/ &> /dev/null |
36 |
|
|
|
37 |
|
|
%setup -q |
38 |
brianr |
1.4 |
%patch0 -p1 |
39 |
jpp |
1.1 |
|
40 |
|
|
%build |
41 |
|
|
[ -x createlinks ] && ./createlinks |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
rm -f %{name}-%{version}-filelist |
46 |
|
|
|
47 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
48 |
|
|
|
49 |
|
|
/sbin/e-smith/genfilelist \ |
50 |
|
|
--dir /var/lib/sogo/GNUstep 'attr(0755,sogo,sogo)' \ |
51 |
|
|
--dir /var/lib/sogo/GNUstep/Defaults 'attr(0755,sogo,sogo)' \ |
52 |
brianr |
1.4 |
--ignoredir "/var/lib/sogo" \ |
53 |
|
|
$RPM_BUILD_ROOT > %{name}-%{version}-%{release}-filelist |
54 |
jpp |
1.1 |
|
55 |
|
|
%clean |
56 |
|
|
rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
|
61 |
|
|
if [ $1 == 1 ]; then #first install |
62 |
|
|
/etc/e-smith/events/actions/initialize-default-databases &> /dev/null |
63 |
|
|
/sbin/e-smith/expand-template \ |
64 |
|
|
/etc/e-smith/sql/init/30sogo_mysql_create_database |
65 |
|
|
/sbin/e-smith/expand-template \ |
66 |
|
|
/etc/e-smith/sql/init/31sogo_mysql_update_privileges |
67 |
|
|
/sbin/e-smith/expand-template \ |
68 |
|
|
/var/lib/sogo/smeserver/sogo_mysql_update_privileges.sql |
69 |
|
|
/sbin/e-smith/expand-template \ |
70 |
|
|
/etc/e-smith/sql/init/31sogo_upgrade |
71 |
|
|
/sbin/e-smith/expand-template \ |
72 |
|
|
/etc/e-smith/sql/init/32sogo_upgrade_2.3 |
73 |
|
|
/sbin/service mysql.init start |
74 |
|
|
/sbin/e-smith/signal-event sogo-modify |
75 |
|
|
elif [ $1 -gt 1 ]; then #update |
76 |
|
|
/sbin/e-smith/expand-template \ |
77 |
|
|
/etc/e-smith/sql/init/31sogo_upgrade |
78 |
|
|
/sbin/e-smith/expand-template \ |
79 |
|
|
/etc/e-smith/sql/init/32sogo_upgrade_2.3 |
80 |
|
|
/sbin/service mysql.init start |
81 |
|
|
/etc/e-smith/events/actions/initialize-default-databases &> /dev/null || : |
82 |
|
|
/sbin/e-smith/signal-event sogo-modify || : |
83 |
|
|
fi |
84 |
|
|
|
85 |
|
|
# set sogo password |
86 |
|
|
/bin/cat /etc/openldap/ldap.pw | /usr/bin/passwd sogo --stdin &> /dev/null || : |
87 |
|
|
|
88 |
|
|
|
89 |
|
|
%postun |
90 |
|
|
if [ $1 = 1 ]; then |
91 |
|
|
/etc/e-smith/events/actions/initialize-default-databases &> /dev/null || : |
92 |
|
|
/sbin/e-smith/signal-event sogo-modify || : |
93 |
|
|
fi |
94 |
|
|
|
95 |
|
|
|
96 |
|
|
|
97 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
98 |
|
|
|
99 |
|
|
|
100 |
|
|
%changelog |
101 |
brianr |
1.3 |
* Sat Jan 07 2023 Brian Read <brianr@bjsystems.co.uk> - 1.6-1.sme |
102 |
brianr |
1.4 |
- Initial import to SME10 tree [SME: 11629] |
103 |
|
|
- Changes to spec file to avoid clash between sogo rpm directories and this rpm. |
104 |
|
|
- Update permissions to Apache 2.4 |
105 |
|
|
- Add systemd dropin |
106 |
|
|
- Add -update event to createlinks |
107 |
brianr |
1.2 |
|
108 |
|
|
* Fri Apr 28 2017 Stephane de Labrusse <stephdl@de-labrusse.fr> - 1.5-1.sme |
109 |
jpp |
1.1 |
- Increase maximum IMAP command line length |
110 |
|
|
- Adjusted sogo cron.d, sieve credentials are in /etc/sogo/sieve.creds |
111 |
|
|
|
112 |
|
|
* Fri Mar 24 2017 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.4-2.sme |
113 |
|
|
- Add custom settings to avoid battery drain when using active sync [SME: 10168] |
114 |
|
|
- Thank to Michael McCarn <mmccarn-sme@mmsionline.us> |
115 |
|
|
- the sogo.conf template is rewritten by fragments |
116 |
|
|
- Correction of the backup creation [SME: 9908] |
117 |
|
|
- Thank to Nicola Tiana <sistemi@chester-perry.it> |
118 |
|
|
|
119 |
|
|
* Sun Jul 24 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-19.sme |
120 |
|
|
- remove the email of cron for expire-autoreply |
121 |
|
|
|
122 |
|
|
* Sat Jan 16 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-18.sme |
123 |
|
|
- the template-end is created in the sogo.conf to allow the end user to add his settings |
124 |
|
|
|
125 |
|
|
* Wed Oct 7 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-17.sme |
126 |
|
|
- /etc/e-smith/sql/init/32sogo_upgrade_2.3 is now executable |
127 |
|
|
- actions sogo_upgrade_2.3 is rewritten, thank to daniel Berteaud |
128 |
|
|
|
129 |
|
|
* Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-15.sme |
130 |
|
|
- Added sogo-modify to mysql.init |
131 |
|
|
|
132 |
|
|
* Wed Jul 8 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-14.sme |
133 |
|
|
- Upgrade to sogo 2.3.0, alteration table needed |
134 |
|
|
- thank to ian case <ianc@caseinfo.net> |
135 |
|
|
|
136 |
|
|
* Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-12.sme |
137 |
|
|
- Remove a sogo user when a SME Server user is removed |
138 |
|
|
|
139 |
|
|
* Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-11.sme |
140 |
|
|
- Fix the qpsmtpd fix_headers_case plugin |
141 |
|
|
|
142 |
|
|
* Tue Jan 6 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-10.sme |
143 |
|
|
- Added bindFields parameters to SOGoUserSources based on suggestion of Nicola Tiana in [SME: 7578] |
144 |
|
|
- According to SOGo installation guide, the value of bindFields has to be in an array for recent version |
145 |
|
|
- Thanks to Mats Schuh <m.schuh@neckargeo.net> |
146 |
|
|
|
147 |
|
|
* Tue Dec 30 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-9.sme |
148 |
|
|
- stop cron email confirmation to the sogo user account [SME: 8756] |
149 |
|
|
- code done by Mats Schuh <m.schuh@neckargeo.net> |
150 |
|
|
|
151 |
|
|
* Mon Dec 29 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-8.sme |
152 |
|
|
- Sogo must be an admin of dovecot for expire-autoreply [SME: 8753] |
153 |
|
|
- Thanks to Mats Schuh <m.schuh@neckargeo.net> |
154 |
|
|
|
155 |
|
|
* Sat Nov 01 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-7.sme |
156 |
|
|
- removed a bad file 80srvSOGo in the template path of /var/service/tinydns/root/data |
157 |
|
|
- added restart and event-template to tinydns with sogo-modify |
158 |
|
|
|
159 |
|
|
* Sun Sep 21 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-5.sme |
160 |
|
|
- SOGoMailMessageCheck has been replaced by SOGoRefreshViewCheck |
161 |
|
|
|
162 |
|
|
* Sun Aug 31 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-4.sme |
163 |
|
|
- Added . separator for imap, instead of / by default |
164 |
|
|
|
165 |
|
|
* Sun Aug 17 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-3.sme |
166 |
|
|
- a bit of clean and new code inspired from ipasserelle-groupware. Thanks to daniel berteaud <daniel@firewall-services.com> |
167 |
|
|
- added sieve and acl support (come with smeserver-dovecot-extras) |
168 |
|
|
- added a panel in the server-manager with options |
169 |
|
|
- added active-sync support |
170 |
|
|
- added sogo notifications |
171 |
|
|
|
172 |
|
|
|
173 |
|
|
* Thu May 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.1-2 |
174 |
|
|
- First release For SME Server 9 Thanks for all previous valorous developers |
175 |
|
|
- removed expand-template for bootstrap-console-save in createlink |
176 |
|
|
- added an architecture detection for template the file |
177 |
|
|
- /etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess |
178 |
|
|
|
179 |
|
|
* Wed Dec 11 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.1-1 |
180 |
|
|
- Fixed sogo.conf syntax. Refs #2339 |
181 |
|
|
|
182 |
|
|
* Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.0-1 |
183 |
|
|
- Release 1.0.0. Refs #2339 |
184 |
|
|
- Require sogo >= 2.1.1b-1 |
185 |
|
|
|
186 |
|
|
* Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 0.9.1-1 |
187 |
|
|
- Release 0.9.1 |
188 |
|
|
- Fixes bug #2372 |
189 |
|
|
|
190 |
|
|
* Mon Dec 2 2013 Davide Principi <davide.principi@nethesis.it> - 0.9-1 |
191 |
|
|
- sogo home directory moved to /var/lib/sogo to fix #2369 |
192 |
|
|
|
193 |
|
|
* Fri Apr 26 2013 Davide Principi <davide.principi@nethesis.it> - 0.8-2 |
194 |
|
|
- Create symlink to new SOGo 2.0.x homedir, to support fresh installations |
195 |
|
|
|
196 |
|
|
* Thu Oct 18 2012 Giacomo Sanchiettti <giacomo.sanchietti@nethesis.it> - 0.8-1 |
197 |
|
|
- Add support for vacation auto-disable feature |
198 |
|
|
- Add memcached requires (previously on sogo package) |
199 |
|
|
|
200 |
|
|
* Fri Sep 14 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.7-1 |
201 |
|
|
- Enable notification for calendar modifications (refs #1398) |
202 |
|
|
- Customize From header (refs #1339) |
203 |
|
|
- Support SharedFolder (refs #1432) |
204 |
|
|
|
205 |
|
|
* Fri Mar 9 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6.1 |
206 |
|
|
- Removed bindFields (bug #845) |
207 |
|
|
- Fixed backup by sogo-tool (bug #839) |
208 |
|
|
- Upgrade SOGo db to 1.3.12 |
209 |
|
|
|
210 |
|
|
* Wed Nov 30 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6 |
211 |
|
|
- change GNUstep path |
212 |
|
|
|
213 |
|
|
* Wed Sep 7 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-2 |
214 |
|
|
- Add CardDAV external access (bug #423) |
215 |
|
|
|
216 |
|
|
* Wed Jul 20 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-1 |
217 |
|
|
- Disable sieve support for NethService 8.0 |
218 |
|
|
- Correct postun |
219 |
|
|
|
220 |
|
|
* Mon May 16 2011 Giacomo Sanchietti <giacomo@nethesis.it> - 0.5.8-1 |
221 |
|
|
- Add sieve support |
222 |
|
|
- Add configurable prefork option |
223 |
|
|
- Enable session folders |
224 |
|
|
- Update to SOGo 1.3.4 |
225 |
|
|
|
226 |
|
|
* Thu Aug 5 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.6-1 |
227 |
|
|
- add configurable option for ACLsSendEMailNotifications |
228 |
|
|
- add EnablePublicAccess |
229 |
|
|
- change MailingMechanism to SMTP |
230 |
|
|
- redirect http requests for sogo to SOGo |
231 |
|
|
|
232 |
|
|
* Mon Aug 2 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.5-1 |
233 |
|
|
- upgrade to sogo 1.3.0 |
234 |
|
|
|
235 |
|
|
* Tue Mar 30 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.4-1 |
236 |
|
|
- escape curly brackets in sogo logrotate template |
237 |
|
|
|
238 |
|
|
* Fri Mar 19 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.3-1 |
239 |
|
|
- add logrotate for sogo log files |
240 |
|
|
- nethesis smesetup (post/postun) scripts |
241 |
|
|
|
242 |
|
|
* Tue Mar 16 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.2-2 |
243 |
|
|
- rej files cleanup |
244 |
|
|
|
245 |
|
|
* Tue Mar 16 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.2-1 |
246 |
|
|
- enable groups for ACL |
247 |
|
|
- configure admin users from the db |
248 |
|
|
- disable bogus notifications (acl and folders) |
249 |
|
|
- configure sent and draft imap folders from DB |
250 |
|
|
- redirect webmail when imp is disabled (Stephen Noble) |
251 |
|
|
- proxypass port from the db (Federico Simoncelli) |
252 |
|
|
|
253 |
|
|
* Fri Mar 12 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.1-1 |
254 |
|
|
- anonymous bind is sufficient to authenticate users |
255 |
|
|
- limit sogo daemon bind to the loopback interface |
256 |
|
|
- SOGo protected with SSL |
257 |
|
|
- memcached bind to loopback, port from TCPPort |
258 |
|
|
- templates expansion from post-upgrade to bootstrap-console-save |
259 |
|
|
- read the ldap port from db |
260 |
|
|
- split the local ldap directory in two parts: users and groups |
261 |
|
|
- notifications sent by email will have the correct URL |
262 |
|
|
|
263 |
|
|
* Thu Feb 18 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.0-1 |
264 |
|
|
- first release |
265 |
|
|
|
266 |
|
|
|