1 |
jpp |
1.1 |
# $Id$ |
2 |
|
|
%define name smeserver-sogo |
3 |
brianr |
1.2 |
%define version 1.6 |
4 |
brianr |
1.5 |
%define release 2 |
5 |
jpp |
1.1 |
|
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Summary: SME Server SOGo Groupware |
10 |
|
|
Group: Networking/Daemons |
11 |
|
|
License: GPLv3+ |
12 |
|
|
URL: http://www.smeserver.org |
13 |
|
|
Source0: %{name}-%{version}.tar.gz |
14 |
brianr |
1.4 |
Patch0: smeserver-sogo-1.6-Update-to-SME10-Apache-2.4-and-systemd-dropin.patch |
15 |
brianr |
1.5 |
Patch1: smeserver-sogo-1.6-Expand-koozali-preset-on-update.patch |
16 |
brianr |
1.4 |
|
17 |
jpp |
1.1 |
BuildArch: noarch |
18 |
|
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) |
19 |
|
|
Epoch: 9 |
20 |
|
|
BuildRequires: e-smith-devtools |
21 |
brianr |
1.4 |
Requires: smeserver-release >= 10 |
22 |
jpp |
1.1 |
Requires: e-smith-ldap |
23 |
brianr |
1.4 |
Requires: sogo >= 5.8.0 |
24 |
jpp |
1.1 |
Requires: sogo-tool |
25 |
|
|
Requires: memcached |
26 |
|
|
Requires: sogo-activesync |
27 |
|
|
Requires: sope49-gdl1-mysql |
28 |
|
|
Requires: sogo-ealarms-notify |
29 |
|
|
Requires: python-memcached |
30 |
|
|
Requires: smeserver-dovecot-extras |
31 |
|
|
%description |
32 |
|
|
SME Server module for SOGo groupware. |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
##my bad to remove a bad folder if exists [1.3-6.sme] |
36 |
|
|
/bin/rm -rf /var/service/tinydns/root/data/ &> /dev/null |
37 |
|
|
|
38 |
|
|
%setup -q |
39 |
brianr |
1.4 |
%patch0 -p1 |
40 |
brianr |
1.5 |
%patch1 -p1 |
41 |
jpp |
1.1 |
|
42 |
|
|
%build |
43 |
|
|
[ -x createlinks ] && ./createlinks |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
rm -rf $RPM_BUILD_ROOT |
47 |
|
|
rm -f %{name}-%{version}-filelist |
48 |
|
|
|
49 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
50 |
|
|
|
51 |
|
|
/sbin/e-smith/genfilelist \ |
52 |
|
|
--dir /var/lib/sogo/GNUstep 'attr(0755,sogo,sogo)' \ |
53 |
|
|
--dir /var/lib/sogo/GNUstep/Defaults 'attr(0755,sogo,sogo)' \ |
54 |
brianr |
1.4 |
--ignoredir "/var/lib/sogo" \ |
55 |
|
|
$RPM_BUILD_ROOT > %{name}-%{version}-%{release}-filelist |
56 |
jpp |
1.1 |
|
57 |
|
|
%clean |
58 |
|
|
rm -rf $RPM_BUILD_ROOT |
59 |
|
|
|
60 |
|
|
|
61 |
|
|
%post |
62 |
|
|
|
63 |
|
|
if [ $1 == 1 ]; then #first install |
64 |
|
|
/etc/e-smith/events/actions/initialize-default-databases &> /dev/null |
65 |
|
|
/sbin/e-smith/expand-template \ |
66 |
|
|
/etc/e-smith/sql/init/30sogo_mysql_create_database |
67 |
|
|
/sbin/e-smith/expand-template \ |
68 |
|
|
/etc/e-smith/sql/init/31sogo_mysql_update_privileges |
69 |
|
|
/sbin/e-smith/expand-template \ |
70 |
|
|
/var/lib/sogo/smeserver/sogo_mysql_update_privileges.sql |
71 |
|
|
/sbin/e-smith/expand-template \ |
72 |
|
|
/etc/e-smith/sql/init/31sogo_upgrade |
73 |
|
|
/sbin/e-smith/expand-template \ |
74 |
|
|
/etc/e-smith/sql/init/32sogo_upgrade_2.3 |
75 |
|
|
/sbin/service mysql.init start |
76 |
|
|
/sbin/e-smith/signal-event sogo-modify |
77 |
|
|
elif [ $1 -gt 1 ]; then #update |
78 |
|
|
/sbin/e-smith/expand-template \ |
79 |
|
|
/etc/e-smith/sql/init/31sogo_upgrade |
80 |
|
|
/sbin/e-smith/expand-template \ |
81 |
|
|
/etc/e-smith/sql/init/32sogo_upgrade_2.3 |
82 |
|
|
/sbin/service mysql.init start |
83 |
|
|
/etc/e-smith/events/actions/initialize-default-databases &> /dev/null || : |
84 |
|
|
/sbin/e-smith/signal-event sogo-modify || : |
85 |
|
|
fi |
86 |
|
|
|
87 |
|
|
# set sogo password |
88 |
|
|
/bin/cat /etc/openldap/ldap.pw | /usr/bin/passwd sogo --stdin &> /dev/null || : |
89 |
|
|
|
90 |
|
|
|
91 |
|
|
%postun |
92 |
|
|
if [ $1 = 1 ]; then |
93 |
|
|
/etc/e-smith/events/actions/initialize-default-databases &> /dev/null || : |
94 |
|
|
/sbin/e-smith/signal-event sogo-modify || : |
95 |
|
|
fi |
96 |
|
|
|
97 |
|
|
|
98 |
|
|
|
99 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
100 |
|
|
|
101 |
|
|
|
102 |
|
|
%changelog |
103 |
brianr |
1.5 |
* Mon Jan 09 2023 Brian Read <brianr@bjsystems.co.uk> 1.6-2.sme |
104 |
|
|
- Expand Koozali preset for systemd startup [SME: 11629] |
105 |
|
|
- Remove rc.d/rc7.d entries for memcached and sogod |
106 |
|
|
|
107 |
brianr |
1.3 |
* Sat Jan 07 2023 Brian Read <brianr@bjsystems.co.uk> - 1.6-1.sme |
108 |
brianr |
1.4 |
- Initial import to SME10 tree [SME: 11629] |
109 |
|
|
- Changes to spec file to avoid clash between sogo rpm directories and this rpm. |
110 |
|
|
- Update permissions to Apache 2.4 |
111 |
|
|
- Add systemd dropin |
112 |
|
|
- Add -update event to createlinks |
113 |
brianr |
1.2 |
|
114 |
|
|
* Fri Apr 28 2017 Stephane de Labrusse <stephdl@de-labrusse.fr> - 1.5-1.sme |
115 |
jpp |
1.1 |
- Increase maximum IMAP command line length |
116 |
|
|
- Adjusted sogo cron.d, sieve credentials are in /etc/sogo/sieve.creds |
117 |
|
|
|
118 |
|
|
* Fri Mar 24 2017 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.4-2.sme |
119 |
|
|
- Add custom settings to avoid battery drain when using active sync [SME: 10168] |
120 |
|
|
- Thank to Michael McCarn <mmccarn-sme@mmsionline.us> |
121 |
|
|
- the sogo.conf template is rewritten by fragments |
122 |
|
|
- Correction of the backup creation [SME: 9908] |
123 |
|
|
- Thank to Nicola Tiana <sistemi@chester-perry.it> |
124 |
|
|
|
125 |
|
|
* Sun Jul 24 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-19.sme |
126 |
|
|
- remove the email of cron for expire-autoreply |
127 |
|
|
|
128 |
|
|
* Sat Jan 16 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-18.sme |
129 |
|
|
- the template-end is created in the sogo.conf to allow the end user to add his settings |
130 |
|
|
|
131 |
|
|
* Wed Oct 7 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-17.sme |
132 |
|
|
- /etc/e-smith/sql/init/32sogo_upgrade_2.3 is now executable |
133 |
|
|
- actions sogo_upgrade_2.3 is rewritten, thank to daniel Berteaud |
134 |
|
|
|
135 |
|
|
* Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-15.sme |
136 |
|
|
- Added sogo-modify to mysql.init |
137 |
|
|
|
138 |
|
|
* Wed Jul 8 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-14.sme |
139 |
|
|
- Upgrade to sogo 2.3.0, alteration table needed |
140 |
|
|
- thank to ian case <ianc@caseinfo.net> |
141 |
|
|
|
142 |
|
|
* Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-12.sme |
143 |
|
|
- Remove a sogo user when a SME Server user is removed |
144 |
|
|
|
145 |
|
|
* Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-11.sme |
146 |
|
|
- Fix the qpsmtpd fix_headers_case plugin |
147 |
|
|
|
148 |
|
|
* Tue Jan 6 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-10.sme |
149 |
|
|
- Added bindFields parameters to SOGoUserSources based on suggestion of Nicola Tiana in [SME: 7578] |
150 |
|
|
- According to SOGo installation guide, the value of bindFields has to be in an array for recent version |
151 |
|
|
- Thanks to Mats Schuh <m.schuh@neckargeo.net> |
152 |
|
|
|
153 |
|
|
* Tue Dec 30 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-9.sme |
154 |
|
|
- stop cron email confirmation to the sogo user account [SME: 8756] |
155 |
|
|
- code done by Mats Schuh <m.schuh@neckargeo.net> |
156 |
|
|
|
157 |
|
|
* Mon Dec 29 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-8.sme |
158 |
|
|
- Sogo must be an admin of dovecot for expire-autoreply [SME: 8753] |
159 |
|
|
- Thanks to Mats Schuh <m.schuh@neckargeo.net> |
160 |
|
|
|
161 |
|
|
* Sat Nov 01 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-7.sme |
162 |
|
|
- removed a bad file 80srvSOGo in the template path of /var/service/tinydns/root/data |
163 |
|
|
- added restart and event-template to tinydns with sogo-modify |
164 |
|
|
|
165 |
|
|
* Sun Sep 21 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-5.sme |
166 |
|
|
- SOGoMailMessageCheck has been replaced by SOGoRefreshViewCheck |
167 |
|
|
|
168 |
|
|
* Sun Aug 31 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-4.sme |
169 |
|
|
- Added . separator for imap, instead of / by default |
170 |
|
|
|
171 |
|
|
* Sun Aug 17 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-3.sme |
172 |
|
|
- a bit of clean and new code inspired from ipasserelle-groupware. Thanks to daniel berteaud <daniel@firewall-services.com> |
173 |
|
|
- added sieve and acl support (come with smeserver-dovecot-extras) |
174 |
|
|
- added a panel in the server-manager with options |
175 |
|
|
- added active-sync support |
176 |
|
|
- added sogo notifications |
177 |
|
|
|
178 |
|
|
|
179 |
|
|
* Thu May 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.1-2 |
180 |
|
|
- First release For SME Server 9 Thanks for all previous valorous developers |
181 |
|
|
- removed expand-template for bootstrap-console-save in createlink |
182 |
|
|
- added an architecture detection for template the file |
183 |
|
|
- /etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess |
184 |
|
|
|
185 |
|
|
* Wed Dec 11 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.1-1 |
186 |
|
|
- Fixed sogo.conf syntax. Refs #2339 |
187 |
|
|
|
188 |
|
|
* Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.0-1 |
189 |
|
|
- Release 1.0.0. Refs #2339 |
190 |
|
|
- Require sogo >= 2.1.1b-1 |
191 |
|
|
|
192 |
|
|
* Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 0.9.1-1 |
193 |
|
|
- Release 0.9.1 |
194 |
|
|
- Fixes bug #2372 |
195 |
|
|
|
196 |
|
|
* Mon Dec 2 2013 Davide Principi <davide.principi@nethesis.it> - 0.9-1 |
197 |
|
|
- sogo home directory moved to /var/lib/sogo to fix #2369 |
198 |
|
|
|
199 |
|
|
* Fri Apr 26 2013 Davide Principi <davide.principi@nethesis.it> - 0.8-2 |
200 |
|
|
- Create symlink to new SOGo 2.0.x homedir, to support fresh installations |
201 |
|
|
|
202 |
|
|
* Thu Oct 18 2012 Giacomo Sanchiettti <giacomo.sanchietti@nethesis.it> - 0.8-1 |
203 |
|
|
- Add support for vacation auto-disable feature |
204 |
|
|
- Add memcached requires (previously on sogo package) |
205 |
|
|
|
206 |
|
|
* Fri Sep 14 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.7-1 |
207 |
|
|
- Enable notification for calendar modifications (refs #1398) |
208 |
|
|
- Customize From header (refs #1339) |
209 |
|
|
- Support SharedFolder (refs #1432) |
210 |
|
|
|
211 |
|
|
* Fri Mar 9 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6.1 |
212 |
|
|
- Removed bindFields (bug #845) |
213 |
|
|
- Fixed backup by sogo-tool (bug #839) |
214 |
|
|
- Upgrade SOGo db to 1.3.12 |
215 |
|
|
|
216 |
|
|
* Wed Nov 30 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6 |
217 |
|
|
- change GNUstep path |
218 |
|
|
|
219 |
|
|
* Wed Sep 7 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-2 |
220 |
|
|
- Add CardDAV external access (bug #423) |
221 |
|
|
|
222 |
|
|
* Wed Jul 20 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-1 |
223 |
|
|
- Disable sieve support for NethService 8.0 |
224 |
|
|
- Correct postun |
225 |
|
|
|
226 |
|
|
* Mon May 16 2011 Giacomo Sanchietti <giacomo@nethesis.it> - 0.5.8-1 |
227 |
|
|
- Add sieve support |
228 |
|
|
- Add configurable prefork option |
229 |
|
|
- Enable session folders |
230 |
|
|
- Update to SOGo 1.3.4 |
231 |
|
|
|
232 |
|
|
* Thu Aug 5 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.6-1 |
233 |
|
|
- add configurable option for ACLsSendEMailNotifications |
234 |
|
|
- add EnablePublicAccess |
235 |
|
|
- change MailingMechanism to SMTP |
236 |
|
|
- redirect http requests for sogo to SOGo |
237 |
|
|
|
238 |
|
|
* Mon Aug 2 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.5-1 |
239 |
|
|
- upgrade to sogo 1.3.0 |
240 |
|
|
|
241 |
|
|
* Tue Mar 30 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.4-1 |
242 |
|
|
- escape curly brackets in sogo logrotate template |
243 |
|
|
|
244 |
|
|
* Fri Mar 19 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.3-1 |
245 |
|
|
- add logrotate for sogo log files |
246 |
|
|
- nethesis smesetup (post/postun) scripts |
247 |
|
|
|
248 |
|
|
* Tue Mar 16 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.2-2 |
249 |
|
|
- rej files cleanup |
250 |
|
|
|
251 |
|
|
* Tue Mar 16 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.2-1 |
252 |
|
|
- enable groups for ACL |
253 |
|
|
- configure admin users from the db |
254 |
|
|
- disable bogus notifications (acl and folders) |
255 |
|
|
- configure sent and draft imap folders from DB |
256 |
|
|
- redirect webmail when imp is disabled (Stephen Noble) |
257 |
|
|
- proxypass port from the db (Federico Simoncelli) |
258 |
|
|
|
259 |
|
|
* Fri Mar 12 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.1-1 |
260 |
|
|
- anonymous bind is sufficient to authenticate users |
261 |
|
|
- limit sogo daemon bind to the loopback interface |
262 |
|
|
- SOGo protected with SSL |
263 |
|
|
- memcached bind to loopback, port from TCPPort |
264 |
|
|
- templates expansion from post-upgrade to bootstrap-console-save |
265 |
|
|
- read the ldap port from db |
266 |
|
|
- split the local ldap directory in two parts: users and groups |
267 |
|
|
- notifications sent by email will have the correct URL |
268 |
|
|
|
269 |
|
|
* Thu Feb 18 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.0-1 |
270 |
|
|
- first release |
271 |
|
|
|
272 |
|
|
|