/[smecontribs]/rpms/smeserver-sogo/contribs10/smeserver-sogo.spec
ViewVC logotype

Annotation of /rpms/smeserver-sogo/contribs10/smeserver-sogo.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.7 - (hide annotations) (download)
Fri Sep 6 10:34:46 2024 UTC (3 weeks, 2 days ago) by terryfage
Branch: MAIN
CVS Tags: HEAD
Changes since 1.6: +1 -1 lines
* Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 1.6-3.sme
- add update locale 2024-09-06.patch

1 jpp 1.1 # $Id$
2     %define name smeserver-sogo
3 brianr 1.2 %define version 1.6
4 terryfage 1.6 %define release 3
5 jpp 1.1
6     Name: %{name}
7     Version: %{version}
8     Release: %{release}%{?dist}
9     Summary: SME Server SOGo Groupware
10     Group: Networking/Daemons
11     License: GPLv3+
12     URL: http://www.smeserver.org
13     Source0: %{name}-%{version}.tar.gz
14 brianr 1.4 Patch0: smeserver-sogo-1.6-Update-to-SME10-Apache-2.4-and-systemd-dropin.patch
15 brianr 1.5 Patch1: smeserver-sogo-1.6-Expand-koozali-preset-on-update.patch
16 terryfage 1.6 Patch2: smeserver-sogo-1.6-locale-2024-09-06.patch
17 brianr 1.4
18 jpp 1.1 BuildArch: noarch
19     BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
20     Epoch: 9
21     BuildRequires: e-smith-devtools
22 brianr 1.4 Requires: smeserver-release >= 10
23 jpp 1.1 Requires: e-smith-ldap
24 brianr 1.4 Requires: sogo >= 5.8.0
25 jpp 1.1 Requires: sogo-tool
26     Requires: memcached
27     Requires: sogo-activesync
28     Requires: sope49-gdl1-mysql
29     Requires: sogo-ealarms-notify
30     Requires: python-memcached
31     Requires: smeserver-dovecot-extras
32     %description
33     SME Server module for SOGo groupware.
34    
35     %prep
36     ##my bad to remove a bad folder if exists [1.3-6.sme]
37     /bin/rm -rf /var/service/tinydns/root/data/ &> /dev/null
38    
39     %setup -q
40 brianr 1.4 %patch0 -p1
41 brianr 1.5 %patch1 -p1
42 terryfage 1.6 %patch2 -p1
43 jpp 1.1
44     %build
45     [ -x createlinks ] && ./createlinks
46    
47     %install
48     rm -rf $RPM_BUILD_ROOT
49     rm -f %{name}-%{version}-filelist
50    
51     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
52    
53     /sbin/e-smith/genfilelist \
54     --dir /var/lib/sogo/GNUstep 'attr(0755,sogo,sogo)' \
55     --dir /var/lib/sogo/GNUstep/Defaults 'attr(0755,sogo,sogo)' \
56 brianr 1.4 --ignoredir "/var/lib/sogo" \
57     $RPM_BUILD_ROOT > %{name}-%{version}-%{release}-filelist
58 jpp 1.1
59     %clean
60     rm -rf $RPM_BUILD_ROOT
61    
62    
63     %post
64    
65     if [ $1 == 1 ]; then #first install
66     /etc/e-smith/events/actions/initialize-default-databases &> /dev/null
67     /sbin/e-smith/expand-template \
68     /etc/e-smith/sql/init/30sogo_mysql_create_database
69     /sbin/e-smith/expand-template \
70     /etc/e-smith/sql/init/31sogo_mysql_update_privileges
71     /sbin/e-smith/expand-template \
72     /var/lib/sogo/smeserver/sogo_mysql_update_privileges.sql
73     /sbin/e-smith/expand-template \
74     /etc/e-smith/sql/init/31sogo_upgrade
75     /sbin/e-smith/expand-template \
76     /etc/e-smith/sql/init/32sogo_upgrade_2.3
77     /sbin/service mysql.init start
78     /sbin/e-smith/signal-event sogo-modify
79     elif [ $1 -gt 1 ]; then #update
80     /sbin/e-smith/expand-template \
81     /etc/e-smith/sql/init/31sogo_upgrade
82     /sbin/e-smith/expand-template \
83     /etc/e-smith/sql/init/32sogo_upgrade_2.3
84     /sbin/service mysql.init start
85     /etc/e-smith/events/actions/initialize-default-databases &> /dev/null || :
86     /sbin/e-smith/signal-event sogo-modify || :
87     fi
88    
89     # set sogo password
90     /bin/cat /etc/openldap/ldap.pw | /usr/bin/passwd sogo --stdin &> /dev/null || :
91    
92    
93     %postun
94     if [ $1 = 1 ]; then
95     /etc/e-smith/events/actions/initialize-default-databases &> /dev/null || :
96     /sbin/e-smith/signal-event sogo-modify || :
97     fi
98    
99    
100    
101     %files -f %{name}-%{version}-%{release}-filelist
102    
103    
104     %changelog
105 terryfage 1.7 * Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 1.6-3.sme
106 terryfage 1.6 - add update locale 2024-09-06.patch
107    
108 brianr 1.5 * Mon Jan 09 2023 Brian Read <brianr@bjsystems.co.uk> 1.6-2.sme
109     - Expand Koozali preset for systemd startup [SME: 11629]
110     - Remove rc.d/rc7.d entries for memcached and sogod
111    
112 brianr 1.3 * Sat Jan 07 2023 Brian Read <brianr@bjsystems.co.uk> - 1.6-1.sme
113 brianr 1.4 - Initial import to SME10 tree [SME: 11629]
114     - Changes to spec file to avoid clash between sogo rpm directories and this rpm.
115     - Update permissions to Apache 2.4
116     - Add systemd dropin
117     - Add -update event to createlinks
118 brianr 1.2
119     * Fri Apr 28 2017 Stephane de Labrusse <stephdl@de-labrusse.fr> - 1.5-1.sme
120 jpp 1.1 - Increase maximum IMAP command line length
121     - Adjusted sogo cron.d, sieve credentials are in /etc/sogo/sieve.creds
122    
123     * Fri Mar 24 2017 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.4-2.sme
124     - Add custom settings to avoid battery drain when using active sync [SME: 10168]
125     - Thank to Michael McCarn <mmccarn-sme@mmsionline.us>
126     - the sogo.conf template is rewritten by fragments
127     - Correction of the backup creation [SME: 9908]
128     - Thank to Nicola Tiana <sistemi@chester-perry.it>
129    
130     * Sun Jul 24 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-19.sme
131     - remove the email of cron for expire-autoreply
132    
133     * Sat Jan 16 2016 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-18.sme
134     - the template-end is created in the sogo.conf to allow the end user to add his settings
135    
136     * Wed Oct 7 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-17.sme
137     - /etc/e-smith/sql/init/32sogo_upgrade_2.3 is now executable
138     - actions sogo_upgrade_2.3 is rewritten, thank to daniel Berteaud
139    
140     * Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-15.sme
141     - Added sogo-modify to mysql.init
142    
143     * Wed Jul 8 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-14.sme
144     - Upgrade to sogo 2.3.0, alteration table needed
145     - thank to ian case <ianc@caseinfo.net>
146    
147     * Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-12.sme
148     - Remove a sogo user when a SME Server user is removed
149    
150     * Sat Feb 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-11.sme
151     - Fix the qpsmtpd fix_headers_case plugin
152    
153     * Tue Jan 6 2015 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-10.sme
154     - Added bindFields parameters to SOGoUserSources based on suggestion of Nicola Tiana in [SME: 7578]
155     - According to SOGo installation guide, the value of bindFields has to be in an array for recent version
156     - Thanks to Mats Schuh <m.schuh@neckargeo.net>
157    
158     * Tue Dec 30 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-9.sme
159     - stop cron email confirmation to the sogo user account [SME: 8756]
160     - code done by Mats Schuh <m.schuh@neckargeo.net>
161    
162     * Mon Dec 29 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-8.sme
163     - Sogo must be an admin of dovecot for expire-autoreply [SME: 8753]
164     - Thanks to Mats Schuh <m.schuh@neckargeo.net>
165    
166     * Sat Nov 01 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-7.sme
167     - removed a bad file 80srvSOGo in the template path of /var/service/tinydns/root/data
168     - added restart and event-template to tinydns with sogo-modify
169    
170     * Sun Sep 21 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-5.sme
171     - SOGoMailMessageCheck has been replaced by SOGoRefreshViewCheck
172    
173     * Sun Aug 31 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-4.sme
174     - Added . separator for imap, instead of / by default
175    
176     * Sun Aug 17 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.3-3.sme
177     - a bit of clean and new code inspired from ipasserelle-groupware. Thanks to daniel berteaud <daniel@firewall-services.com>
178     - added sieve and acl support (come with smeserver-dovecot-extras)
179     - added a panel in the server-manager with options
180     - added active-sync support
181     - added sogo notifications
182    
183    
184     * Thu May 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> - 1.1-2
185     - First release For SME Server 9 Thanks for all previous valorous developers
186     - removed expand-template for bootstrap-console-save in createlink
187     - added an architecture detection for template the file
188     - /etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess
189    
190     * Wed Dec 11 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.1-1
191     - Fixed sogo.conf syntax. Refs #2339
192    
193     * Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 1.0.0-1
194     - Release 1.0.0. Refs #2339
195     - Require sogo >= 2.1.1b-1
196    
197     * Mon Dec 9 2013 Davide Principi <davide.principi@nethesis.it> - 0.9.1-1
198     - Release 0.9.1
199     - Fixes bug #2372
200    
201     * Mon Dec 2 2013 Davide Principi <davide.principi@nethesis.it> - 0.9-1
202     - sogo home directory moved to /var/lib/sogo to fix #2369
203    
204     * Fri Apr 26 2013 Davide Principi <davide.principi@nethesis.it> - 0.8-2
205     - Create symlink to new SOGo 2.0.x homedir, to support fresh installations
206    
207     * Thu Oct 18 2012 Giacomo Sanchiettti <giacomo.sanchietti@nethesis.it> - 0.8-1
208     - Add support for vacation auto-disable feature
209     - Add memcached requires (previously on sogo package)
210    
211     * Fri Sep 14 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.7-1
212     - Enable notification for calendar modifications (refs #1398)
213     - Customize From header (refs #1339)
214     - Support SharedFolder (refs #1432)
215    
216     * Fri Mar 9 2012 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6.1
217     - Removed bindFields (bug #845)
218     - Fixed backup by sogo-tool (bug #839)
219     - Upgrade SOGo db to 1.3.12
220    
221     * Wed Nov 30 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.6
222     - change GNUstep path
223    
224     * Wed Sep 7 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-2
225     - Add CardDAV external access (bug #423)
226    
227     * Wed Jul 20 2011 Alessio Fattorini <alessio.fattorini@nethesis.it> - 0.5.9-1
228     - Disable sieve support for NethService 8.0
229     - Correct postun
230    
231     * Mon May 16 2011 Giacomo Sanchietti <giacomo@nethesis.it> - 0.5.8-1
232     - Add sieve support
233     - Add configurable prefork option
234     - Enable session folders
235     - Update to SOGo 1.3.4
236    
237     * Thu Aug 5 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.6-1
238     - add configurable option for ACLsSendEMailNotifications
239     - add EnablePublicAccess
240     - change MailingMechanism to SMTP
241     - redirect http requests for sogo to SOGo
242    
243     * Mon Aug 2 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.5-1
244     - upgrade to sogo 1.3.0
245    
246     * Tue Mar 30 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.4-1
247     - escape curly brackets in sogo logrotate template
248    
249     * Fri Mar 19 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.3-1
250     - add logrotate for sogo log files
251     - nethesis smesetup (post/postun) scripts
252    
253     * Tue Mar 16 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.2-2
254     - rej files cleanup
255    
256     * Tue Mar 16 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.2-1
257     - enable groups for ACL
258     - configure admin users from the db
259     - disable bogus notifications (acl and folders)
260     - configure sent and draft imap folders from DB
261     - redirect webmail when imp is disabled (Stephen Noble)
262     - proxypass port from the db (Federico Simoncelli)
263    
264     * Fri Mar 12 2010 Daniel Berteaud <daniel@firewall-services.com> - 0.5.1-1
265     - anonymous bind is sufficient to authenticate users
266     - limit sogo daemon bind to the loopback interface
267     - SOGo protected with SSL
268     - memcached bind to loopback, port from TCPPort
269     - templates expansion from post-upgrade to bootstrap-console-save
270     - read the ldap port from db
271     - split the local ldap directory in two parts: users and groups
272     - notifications sent by email will have the correct URL
273    
274     * Thu Feb 18 2010 Federico Simoncelli <federico@nethesis.it> - 0.5.0-1
275     - first release
276    
277    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed