1 |
# $Id: smeserver-subversion.spec,v 1.6 2022/10/02 02:15:43 jpp Exp $ |
2 |
# Authority: snetram |
3 |
# Name: Jonathan Martens |
4 |
|
5 |
Summary: Subversion for SME Server |
6 |
%define name smeserver-subversion |
7 |
Name: %{name} |
8 |
%define version 1.7 |
9 |
%define release 14 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
Group: Applications/Internet |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
BuildArchitectures: noarch |
16 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
Requires: smeserver-mod_dav subversion >= 1.2 |
18 |
Requires: smeserver-release >= 10.0 |
19 |
Requires: e-smith-apache >= 2.6.0-19 |
20 |
Requires: mod_dav_svn httpd >= 2 |
21 |
Requires: e-smith-formmagick >= 1.4.0-12 |
22 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
23 |
Patch0: smeserver-subversion-1.7-locale-2015-09-12.patch |
24 |
Patch1: smeserver-subversion-1.7-locale-2016-03-09.patch |
25 |
Patch2: smeserver-subversion-1.7-locale-2017-02-02.patch |
26 |
Patch3: smeserver-subversion-1.7-locale-2018-12-14.patch |
27 |
Patch4: smeserver-subversion-1.7-locale-2021-08-24.patch |
28 |
Patch5: smeserver-subversion-1.7-bz12061-24syntax.patch |
29 |
Patch6: smeserver-subversion-1.7-updatevent.patch |
30 |
Patch7: smeserver-subversion-1.7-locale-2024-09-06.patch |
31 |
|
32 |
%description |
33 |
Implementation of Subversion for SME Server 9 using WebDAV. |
34 |
|
35 |
%changelog |
36 |
* Fri Sep 06 2024 Terry Fage <terry@fage.id.au> 1.7-14.sme |
37 |
- apply locale 2024-09-06.patch |
38 |
|
39 |
* Sat Oct 01 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.7-13.sme |
40 |
- rebuild with perl.prov |
41 |
|
42 |
* Mon Aug 01 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.7-12.sme |
43 |
- update to httpd 2.4 access syntax [SME: 12061] |
44 |
thanks to Vasarhelyi Zsolt for the patch |
45 |
- add update event |
46 |
|
47 |
* Tue Aug 24 2021 Terry Fage <terry.fage@gmail.com> 1.7-11.sme |
48 |
- apply locale 2021-08-24 patch |
49 |
|
50 |
* Thu Oct 29 2020 Brian Read <brianr@bjsystems.co.uk> 1.7-10.sme |
51 |
- Initial import to SME10 tree [SME: 11069] |
52 |
|
53 |
* Fri Dec 14 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 1.7-9.sme |
54 |
- apply locale 2018-12-14 patch |
55 |
|
56 |
* Wed Feb 01 2017 Jean-Philipe Pialasse <tests@pialasse.com> 1.7-8.sme |
57 |
- apply locale 2017-02-02.patch |
58 |
|
59 |
* Wed Mar 09 2016 JP Pialasse <tests@pialasse.com> 1.7-7.sme |
60 |
- apply locale 2016-03-09 patch |
61 |
|
62 |
* Sat Sep 12 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.7-6.sme |
63 |
- Added smeserver-subversion-1.7-locale-2015-09-12.patch |
64 |
|
65 |
* Fri Aug 21 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.7-5.sme |
66 |
- Initial release to contribs9 |
67 |
|
68 |
* Tue Aug 11 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.7-4 |
69 |
- change the subversion url to subversion.apache.org |
70 |
|
71 |
* Mon Jul 27 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.7-3 |
72 |
- added AuthBasicProvider external to the http authentication |
73 |
- correct path to pwauth |
74 |
|
75 |
* Fri Jul 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.7-1 |
76 |
- first release to sme9 |
77 |
|
78 |
* Fri Sep 7 2012 Jonathan Martens <smeserver-contribs@snetram.nl> 1.5-3.sme |
79 |
- Fix location of pwauth on 64 bit systems [SME: 7093] |
80 |
|
81 |
* Wed Jun 13 2012 Jonathan Martens <smeserver-contribs@snetram.nl> 1.5-2.sme |
82 |
- Prevent empty description [SME: 6988] |
83 |
- Apply latest locale patch |
84 |
|
85 |
* Sat May 26 2012 Jonathan Martens <smeserver-contribs@snetram.nl> 1.5-1.sme |
86 |
- Initial version |
87 |
|
88 |
%prep |
89 |
%setup |
90 |
%patch0 -p1 |
91 |
%patch1 -p1 |
92 |
%patch2 -p1 |
93 |
%patch3 -p1 |
94 |
%patch4 -p1 |
95 |
%patch5 -p1 |
96 |
%patch6 -p1 |
97 |
%patch7 -p1 |
98 |
|
99 |
%build |
100 |
perl createlinks |
101 |
|
102 |
%install |
103 |
rm -rf $RPM_BUILD_ROOT |
104 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
105 |
rm -f %{name}-%{version}-filelist |
106 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
107 |
|
108 |
%clean |
109 |
rm -rf $RPM_BUILD_ROOT |
110 |
|
111 |
%files -f %{name}-%{version}-filelist |
112 |
%defattr(-,root,root) |