1 |
# $Id: smeserver-sysmon.spec,v 1.7 2022/09/21 07:54:37 trevorb Exp $ |
2 |
# Authority: slords |
3 |
# Name: Shad L. Lords |
4 |
|
5 |
Summary: sme server system monitor |
6 |
%define name smeserver-sysmon |
7 |
Name: %{name} |
8 |
%define version 6.5 |
9 |
%define release 5 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: Freely distributable |
13 |
Group: Service |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
BuildRoot: /var/tmp/e-smith-buildroot |
16 |
BuildRequires: e-smith-devtools |
17 |
BuildArchitectures: noarch |
18 |
Requires: smeserver-release >= 10 |
19 |
Requires: sysstat >= 5 |
20 |
Requires: rrdtool >= 1.2 |
21 |
Requires: perl(RRDs) |
22 |
Requires: fping |
23 |
Requires: perl(File::Find::Rule) |
24 |
Requires: perl(File::Slurp) |
25 |
AutoReqProv: no |
26 |
Patch0: smeserver-sysmon-6.5-bz4449.patch |
27 |
Patch1: smeserver-sysmon-backup-12024.patch |
28 |
Patch2: smeserver-sysmon-systemd-11072.patch |
29 |
Patch3: smeserver-sysmon-remove-unecessary-50koozali-12191.patch |
30 |
|
31 |
%changelog |
32 |
* Wed Sep 21 2022 Trevor Batley <trevor@batley.id.au> 6.5-5.sme |
33 |
- redo patch to remove 50koozali.conf (as not added to cvs) [SME: 12191] |
34 |
|
35 |
* Wed Sep 21 2022 Trevor Batley <trevor@batley.id.au> 6.5-4.sme |
36 |
- remove superflous and incorrect references to 50koozali.conf [SME: 12191] |
37 |
|
38 |
* Mon Aug 15 2022 Trevor Batley <trevor@batley.id.au> 6.5-3.sme |
39 |
- add -U parameter to sadf call to enforce datetime type [SME: 11702] |
40 |
- alter sysmon service to use to use systemd [SME: 11072] |
41 |
- initial release to contribs10 |
42 |
|
43 |
* Sun Jul 31 2022 Trevor Batley <trevor@batley.id.au> 6.5-2.sme |
44 |
- add to backup [SME: 12024] |
45 |
|
46 |
* Fri Dec 27 2019 Jean-Philipe Pialasse <tests@pialasse.com> 6.5-1.sme |
47 |
- fix utf8 error |
48 |
- fix ups not displaying [SME: 4449] |
49 |
- fix broken image when DS not all available for ups, fan, temperature and voltage graphs |
50 |
|
51 |
* Thu Jan 18 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 6.4-6.sme |
52 |
- Fix database backups iunspec file [[SME: 7096]] |
53 |
|
54 |
* Mon Jan 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 6.4-5.sme |
55 |
- Fix missing swap information [[SME: 10493]] |
56 |
- Remove unnecessary daemonising line |
57 |
|
58 |
* Thu Sep 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 6.4-4.sme |
59 |
- Network labels have changed in rrdtools |
60 |
- Added smeserver-sysmon-6.4.change_rrd_network_label.patch |
61 |
|
62 |
* Thu Sep 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 6.4-2.sme |
63 |
- Initial release to contribs9 |
64 |
|
65 |
* Wed Aug 15 2012 JP Pialasse <tests@pialasse.com> 6.2-2.sme |
66 |
- patch for sysstats 7 and for 64 bit systems |
67 |
|
68 |
* Thu Aug 9 2012 Shad L. Lords <slords@mail.com> 6.2-1.sme |
69 |
- Initial version |
70 |
|
71 |
%description |
72 |
System monitor for SME Server version 9 |
73 |
|
74 |
%prep |
75 |
%setup |
76 |
%patch0 -p1 |
77 |
%patch1 -p1 |
78 |
%patch2 -p1 |
79 |
%patch3 -p1 |
80 |
|
81 |
%build |
82 |
perl createlinks |
83 |
|
84 |
%install |
85 |
rm -rf $RPM_BUILD_ROOT |
86 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
87 |
rm -f %{name}-%{version}-filelist |
88 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
89 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
90 |
|
91 |
%clean |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
|
94 |
%pre |
95 |
if [ $1 -ge 1 ]; then |
96 |
/sbin/service sysmon stop &> /dev/null || : |
97 |
fi |
98 |
|
99 |
%post |
100 |
if [ $1 -ge 2 ]; then |
101 |
/sbin/service sysmon restart &> /dev/null || : |
102 |
fi |
103 |
|
104 |
|
105 |
%preun |
106 |
if [ $1 -eq 0 ]; then |
107 |
/sbin/service sysmon stop &> /dev/null || : |
108 |
fi |
109 |
|
110 |
%postun |
111 |
if [ $1 -ge 1 ]; then |
112 |
/sbin/service sysmon restart &> /dev/null || : |
113 |
fi |
114 |
|
115 |
%files -f %{name}-%{version}-filelist |
116 |
%defattr(-,root,root) |