/[smecontribs]/rpms/smeserver-sysmon/contribs8/smeserver-sysmon.spec
ViewVC logotype

Annotation of /rpms/smeserver-sysmon/contribs8/smeserver-sysmon.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Fri Aug 10 03:55:05 2012 UTC (11 years, 9 months ago) by slords
Branch: MAIN
Initial import

1 slords 1.1 # $Id: smeserver-sysmon.spec,v 1.11 2010/12/02 15:42:20 slords Exp $
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5     Summary: sme server system monitor
6     %define name smeserver-sysmon
7     Name: %{name}
8     %define version 6.2
9     %define release 1
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: Freely distributable
13     Group: Service
14     Source: %{name}-%{version}.tgz
15     BuildRoot: /var/tmp/e-smith-buildroot
16     BuildRequires: e-smith-devtools
17     BuildArchitectures: noarch
18     Requires: smeserver-release >= 8
19     Requires: sysstat >= 5
20     Requires: rrdtool >= 1.2
21     Requires: perl(RRDs)
22     Requires: fping
23     AutoReqProv: no
24    
25     %changelog
26     * Thu Aug 9 2012 Shad L. Lords <slords@mail.com> 6.2-1.sme
27     - Initial version
28    
29     %description
30     System monitor for SME Server version 7
31    
32     %prep
33     %setup
34    
35     %build
36     perl createlinks
37    
38     %install
39     rm -rf $RPM_BUILD_ROOT
40     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
41     rm -f %{name}-%{version}-filelist
42     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
43     echo "%doc COPYING" >> %{name}-%{version}-filelist
44    
45     %clean
46     rm -rf $RPM_BUILD_ROOT
47    
48     %pre
49     if [ $1 -ge 1 ]; then
50     /sbin/service sysmon stop &> /dev/null || :
51     fi
52    
53     %post
54     if [ $1 -ge 2 ]; then
55     mkdir -p /var/lib/rrd/backup
56     /bin/mv /var/lib/rrd/*.rrd /var/lib/rrd/backup/ &> /dev/null
57     # FIXME: Fix for broken postun in previous versions (remove later)
58     /sbin/service sysmon restart &> /dev/null || :
59     fi
60    
61     %preun
62     if [ $1 -eq 0 ]; then
63     /sbin/service sysmon stop &> /dev/null || :
64     fi
65    
66     %postun
67     if [ $1 -ge 1 ]; then
68     /sbin/service sysmon restart &> /dev/null || :
69     fi
70    
71     %files -f %{name}-%{version}-filelist
72     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed