1 |
jpp |
1.8 |
# $Id: smeserver-sysmon.spec,v 1.7 2018/01/18 17:28:36 jcrisp Exp $ |
2 |
stephdl |
1.1 |
# Authority: slords |
3 |
|
|
# Name: Shad L. Lords |
4 |
|
|
|
5 |
|
|
Summary: sme server system monitor |
6 |
|
|
%define name smeserver-sysmon |
7 |
|
|
Name: %{name} |
8 |
jpp |
1.8 |
%define version 6.5 |
9 |
|
|
%define release 1 |
10 |
stephdl |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Service |
14 |
stephdl |
1.2 |
Source: %{name}-%{version}.tar.gz |
15 |
stephdl |
1.1 |
BuildRoot: /var/tmp/e-smith-buildroot |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
BuildArchitectures: noarch |
18 |
stephdl |
1.2 |
Requires: smeserver-release >= 9 |
19 |
stephdl |
1.1 |
Requires: sysstat >= 5 |
20 |
|
|
Requires: rrdtool >= 1.2 |
21 |
|
|
Requires: perl(RRDs) |
22 |
|
|
Requires: fping |
23 |
|
|
AutoReqProv: no |
24 |
jpp |
1.8 |
#Patch0: smeserver-sysmon-6.4.change_rrd_network_label.patch |
25 |
|
|
#Patch1: smeserver-sysmon-6.4.fix_swap_information.patch |
26 |
stephdl |
1.1 |
|
27 |
|
|
%changelog |
28 |
jpp |
1.8 |
* Fri Dec 27 2019 Jean-Philipe Pialasse <tests@pialasse.com> 6.5-1.sme |
29 |
|
|
- fix utf8 error |
30 |
|
|
|
31 |
jcrisp |
1.7 |
* Thu Jan 18 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 6.4-6.sme |
32 |
|
|
- Fix database backups iunspec file [[SME: 7096]] |
33 |
|
|
|
34 |
jcrisp |
1.6 |
* Mon Jan 15 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 6.4-5.sme |
35 |
|
|
- Fix missing swap information [[SME: 10493]] |
36 |
|
|
- Remove unnecessary daemonising line |
37 |
|
|
|
38 |
stephdl |
1.5 |
* Thu Sep 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 6.4-4.sme |
39 |
stephdl |
1.4 |
- Network labels have changed in rrdtools |
40 |
|
|
- Added smeserver-sysmon-6.4.change_rrd_network_label.patch |
41 |
|
|
|
42 |
stephdl |
1.3 |
* Thu Sep 24 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 6.4-2.sme |
43 |
stephdl |
1.1 |
- Initial release to contribs9 |
44 |
|
|
|
45 |
|
|
* Wed Aug 15 2012 JP Pialasse <tests@pialasse.com> 6.2-2.sme |
46 |
|
|
- patch for sysstats 7 and for 64 bit systems |
47 |
|
|
|
48 |
|
|
* Thu Aug 9 2012 Shad L. Lords <slords@mail.com> 6.2-1.sme |
49 |
|
|
- Initial version |
50 |
|
|
|
51 |
|
|
%description |
52 |
stephdl |
1.4 |
System monitor for SME Server version 9 |
53 |
stephdl |
1.1 |
|
54 |
|
|
%prep |
55 |
|
|
%setup |
56 |
jpp |
1.8 |
#%patch0 -p1 |
57 |
stephdl |
1.1 |
|
58 |
|
|
%build |
59 |
|
|
perl createlinks |
60 |
|
|
|
61 |
|
|
%install |
62 |
|
|
rm -rf $RPM_BUILD_ROOT |
63 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
64 |
|
|
rm -f %{name}-%{version}-filelist |
65 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
66 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
67 |
|
|
|
68 |
|
|
%clean |
69 |
|
|
rm -rf $RPM_BUILD_ROOT |
70 |
|
|
|
71 |
|
|
%pre |
72 |
|
|
if [ $1 -ge 1 ]; then |
73 |
|
|
/sbin/service sysmon stop &> /dev/null || : |
74 |
|
|
fi |
75 |
|
|
|
76 |
|
|
%post |
77 |
|
|
if [ $1 -ge 2 ]; then |
78 |
|
|
/sbin/service sysmon restart &> /dev/null || : |
79 |
|
|
fi |
80 |
|
|
|
81 |
jcrisp |
1.7 |
|
82 |
stephdl |
1.1 |
%preun |
83 |
|
|
if [ $1 -eq 0 ]; then |
84 |
|
|
/sbin/service sysmon stop &> /dev/null || : |
85 |
|
|
fi |
86 |
|
|
|
87 |
|
|
%postun |
88 |
|
|
if [ $1 -ge 1 ]; then |
89 |
|
|
/sbin/service sysmon restart &> /dev/null || : |
90 |
|
|
fi |
91 |
|
|
|
92 |
|
|
%files -f %{name}-%{version}-filelist |
93 |
|
|
%defattr(-,root,root) |