1 |
%define name smeserver-systemd-control |
2 |
%define version 0.1 |
3 |
%define release 3 |
4 |
Summary: Perl module to check systemd services |
5 |
Name: %{name} |
6 |
Version: %{version} |
7 |
Release: %{release} |
8 |
License: GNU GPL version 2 |
9 |
URL: http://libreswan.org/ |
10 |
Group: SMEserver/addon |
11 |
Source: %{name}-%{version}.tar.gz |
12 |
BuildRoot: /var/tmp/%{name}-%{version} |
13 |
BuildArchitectures: noarch |
14 |
BuildRequires: e-smith-devtools |
15 |
Requires: e-smith-release >= 10.0 |
16 |
Requires: python3 |
17 |
|
18 |
AutoReqProv: no |
19 |
|
20 |
%description |
21 |
This module adds some systemd checks and commands for services |
22 |
https://github.com/NethServer/nethserver-lib/blob/master/lib/perl/NethServer/Service.pm |
23 |
https://raw.githubusercontent.com/NethServer/nethserver-lib/master/lib/perl/NethServer/Service.pm |
24 |
|
25 |
%changelog |
26 |
* Tue Jun 07 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-3.sme |
27 |
- Force update to Description with new release [SME: 11064] |
28 |
|
29 |
* Tue Sep 21 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-2.sme |
30 |
- Updated description [SME: 11064] |
31 |
|
32 |
* Wed Oct 14 2020 John Crisp <jcrisp@safeandsoundit.co.uk> 0.1-1.sme |
33 |
- Initial build [SME: 11064] |
34 |
|
35 |
%prep |
36 |
%setup |
37 |
|
38 |
%build |
39 |
perl createlinks |
40 |
|
41 |
%install |
42 |
rm -rf $RPM_BUILD_ROOT |
43 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
44 |
rm -f %{name}-%{version}-filelist |
45 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
46 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
47 |
|
48 |
|
49 |
%clean |
50 |
cd .. |
51 |
rm -rf %{name}-%{version} |
52 |
|
53 |
%files -f %{name}-%{version}-filelist |
54 |
|
55 |
%defattr(-,root,root) |
56 |
|
57 |
%pre |
58 |
%preun |
59 |
%post |
60 |
|
61 |
|
62 |
echo "****************************************" |
63 |
echo "https://wiki.koozali.org/Systemd-control" |
64 |
echo "****************************************" |
65 |
|
66 |
%postun |