1 |
slords |
1.1 |
Summary: smeserver rpm to setup torrentflux-b4rt torrent client |
2 |
|
|
%define name smeserver-tf-b4rt |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.0 |
5 |
|
|
%define release 1 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
URL: http://www.dungog.net/sme |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source0: %{name}-%{version}.tar.gz |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
|
|
Requires: e-smith-release >= 7.0 |
15 |
|
|
Requires: tf-b4rt |
16 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
17 |
|
|
AutoReqProv: no |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
smserver rpm to setup torrentflux-b4rt torrent client |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Sun Sep 16 2007 Stephen Noble <support@dungog.net> 1.0 |
24 |
|
|
- initial release |
25 |
|
|
|
26 |
|
|
%prep |
27 |
|
|
%setup |
28 |
|
|
|
29 |
|
|
%build |
30 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/b4rt |
31 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/b4rt/type |
32 |
|
|
|
33 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/b4rt |
34 |
|
|
echo "service" > root/etc/e-smith/db/configuration/defaults/b4rt/type |
35 |
|
|
echo "Torrent client" > root/etc/e-smith/db/configuration/defaults/b4rt/Name |
36 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/b4rt/PublicAccess |
37 |
|
|
echo "enabled" > root/etc/e-smith/db/configuration/defaults/b4rt/status |
38 |
|
|
echo "b4rt" > root/etc/e-smith/db/configuration/defaults/b4rt/DbName |
39 |
|
|
echo "b4rt" > root/etc/e-smith/db/configuration/defaults/b4rt/DbUser |
40 |
|
|
|
41 |
|
|
mkdir -p root/etc/e-smith/templates.metadata/etc/e-smith/sql/init |
42 |
|
|
echo "PERMS=0750" > root/etc/e-smith/templates.metadata/etc/e-smith/sql/init/80tf-b4rt |
43 |
|
|
|
44 |
|
|
%install |
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
47 |
|
|
rm -f %{name}-%{version}-filelist |
48 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
49 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
50 |
|
|
|
51 |
|
|
%clean |
52 |
|
|
cd .. |
53 |
|
|
rm -rf %{name}-%{version} |
54 |
|
|
|
55 |
|
|
%pre |
56 |
|
|
|
57 |
|
|
%preun |
58 |
|
|
|
59 |
|
|
%post |
60 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
61 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80tf-b4rt |
62 |
|
|
/etc/rc.d/init.d/mysql.init start |
63 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
64 |
|
|
/sbin/e-smith/expand-template /opt/b4rt/html/inc/config/config.db.php |
65 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
66 |
|
|
|
67 |
|
|
echo "" |
68 |
|
|
echo "see http://wiki.contribs.org/torrentflux" |
69 |
|
|
|
70 |
|
|
%postun |
71 |
|
|
#uninstall |
72 |
|
|
if [ $1 = 0 ] ; then |
73 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
74 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
75 |
|
|
fi |
76 |
|
|
|
77 |
|
|
%files -f %{name}-%{version}-filelist |
78 |
|
|
%defattr(-,root,root) |
79 |
|
|
|