1 |
trevorb |
1.8 |
# $Id: smeserver-tftp-server.spec,v 1.7 2022/06/27 01:59:34 trevorb Exp $ |
2 |
brianr |
1.1 |
# Authority: nocvs |
3 |
|
|
# Name: Trevor Batley |
4 |
|
|
|
5 |
|
|
%define name smeserver-tftp-server |
6 |
|
|
%define version 1.2 |
7 |
trevorb |
1.7 |
%define release 12 |
8 |
brianr |
1.1 |
|
9 |
|
|
Summary: Wrapper for tftp-server for the Trivial File Transfer Protocol (TFTP). |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
License: GPL |
14 |
|
|
Group: Network |
15 |
|
|
Source: %{name}-%{version}.tar.gz |
16 |
jcrisp |
1.5 |
Requires: smeserver-release >= 10.0 |
17 |
|
|
Requires: tftp-server >= 5.0 |
18 |
brianr |
1.1 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
19 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
20 |
|
|
BuildArch: noarch |
21 |
|
|
Requires: ipsvd >= 0.11.1 |
22 |
|
|
Patch1: smeserver-tftp-server-1.2-dbdefaults.patch |
23 |
|
|
Patch2: smeserver-tftp-server-1.2-refuse.patch |
24 |
|
|
Patch3: smeserver-tftp-server-1.2-migrate.patch |
25 |
|
|
Patch4: smeserver-tftp-server-1.2-allow.patch |
26 |
|
|
Patch5: smeserver-tftp-server-1.2-blksize.patch |
27 |
|
|
Patch6: smeserver-tftp-server-1.2-blksize-check.patch |
28 |
brianr |
1.3 |
Patch7: smeserver-tftp-server-1.2-Add-Update-event-to-createlinks.patch |
29 |
brianr |
1.4 |
Patch8: smeserver-tftp-server-1.2-Expand-hosts-allow-in-update-event.patch |
30 |
jcrisp |
1.5 |
Patch9: smeserver-tftp-server-1.2-updated-systemd-unit-files.patch |
31 |
jcrisp |
1.6 |
Patch10: smeserver-tftp-server-1.2-fix-missing-systemd-directories.patch |
32 |
trevorb |
1.7 |
Patch11: smeserver-tftp-server-1.2-12025-backup.patch |
33 |
brianr |
1.1 |
|
34 |
|
|
%description |
35 |
|
|
smeserver wrapper for tftp-server |
36 |
|
|
The Trivial File Transfer Protocol (TFTP) is normally used only for |
37 |
|
|
booting diskless workstations. The tftp package provides the user |
38 |
|
|
interface for TFTP, which allows users to transfer files to and from a |
39 |
|
|
remote machine. This program and TFTP provide very little security, |
40 |
|
|
and should not be enabled unless it is expressly needed. |
41 |
|
|
|
42 |
|
|
%prep |
43 |
|
|
%setup -q -n %{name}-%{version} |
44 |
|
|
%patch1 -p1 |
45 |
|
|
%patch2 -p1 |
46 |
|
|
%patch3 -p1 |
47 |
|
|
%patch4 -p1 |
48 |
|
|
%patch5 -p1 |
49 |
|
|
%patch6 -p1 |
50 |
brianr |
1.3 |
%patch7 -p1 |
51 |
brianr |
1.4 |
%patch8 -p1 |
52 |
jcrisp |
1.5 |
%patch9 -p1 |
53 |
jcrisp |
1.6 |
%patch10 -p1 |
54 |
trevorb |
1.7 |
%patch11 -p1 |
55 |
brianr |
1.1 |
|
56 |
|
|
%build |
57 |
|
|
perl createlinks |
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
61 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
62 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
63 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
64 |
|
|
|
65 |
brianr |
1.2 |
%post |
66 |
brianr |
1.3 |
#systemctl enable tftp |
67 |
|
|
#systemctl start tftp |
68 |
brianr |
1.2 |
|
69 |
|
|
|
70 |
brianr |
1.1 |
%clean |
71 |
|
|
rm -rf $RPM_BUILD_ROOT |
72 |
|
|
|
73 |
|
|
%files -f %{name}-%{version}-filelist |
74 |
|
|
%defattr(-,root,root) |
75 |
|
|
|
76 |
|
|
%changelog |
77 |
trevorb |
1.8 |
* Mon Jun 27 2022 Trevor Batley <trevor@batley.id.au> 1.2-12.sme |
78 |
trevorb |
1.7 |
- Add tftp root directory (/tftpboot) to backups [SME: 12025] |
79 |
|
|
|
80 |
jcrisp |
1.6 |
* Thu Apr 14 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 1.2-11.sme |
81 |
|
|
- Fix missing systemd directories [SME: 11927] |
82 |
|
|
- Add default 50koozali.conf files |
83 |
|
|
|
84 |
jcrisp |
1.5 |
* Mon Apr 11 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 1.2-10.sme |
85 |
|
|
- Update systemd unit files [SME: 11927] |
86 |
|
|
- Migrate db from tftpd to tftp [SME: 11928] |
87 |
|
|
|
88 |
brianr |
1.4 |
* Wed Nov 10 2021 Brian Read <brianr@bjsystems.co.uk> 1.2-9.sme |
89 |
|
|
- Expand-hosts-allow-in-update-event [SME: 11074 ] |
90 |
|
|
|
91 |
brianr |
1.3 |
* Tue Nov 09 2021 Brian Read <brianr@bjsystems.co.uk> 1.2-8.sme |
92 |
|
|
- Add -update event and systemd files [SME: 11074] |
93 |
|
|
|
94 |
brianr |
1.2 |
* Thu Oct 29 2020 Brian Read <brianr@bjsystems.co.uk> 1.2-7.sme |
95 |
|
|
- Initial import to SME10 tree [SME: 11074] |
96 |
|
|
|
97 |
brianr |
1.1 |
* Mon Nov 12 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 1.2-6 |
98 |
|
|
- Add a blksize check [SME:10646] |
99 |
|
|
|
100 |
|
|
* Thu Mar 29 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 1.2-5 |
101 |
|
|
- fix refuse setting when no key is set [10549] |
102 |
|
|
- add blksize option |
103 |
|
|
|
104 |
|
|
* Thu Mar 31 2016 Trevor Batley <trevorbatley@users.sourceforge.net> 1.2-4 |
105 |
|
|
- added whitespace before line in /etc/hosts.allow fragment [9417] |
106 |
|
|
|
107 |
|
|
* Sun Mar 20 2016 Trevor Batley <trevorbatley@users.sourceforge.net> 1.2-3 |
108 |
|
|
- Added migrate fragments for the fixed default values in 9043 [SME 9351] |
109 |
|
|
- Added -r (--refuse) option [SME 9248] |
110 |
|
|
- Fixed -u option on updsvd (missing space after -u) [SME 9316] |
111 |
|
|
- Added disabled option on logging [SME 9317] |
112 |
|
|
|
113 |
|
|
* Thu Mar 10 2016 Trevor Batley <trevorbatley@users.sourceforge.net> 1.2-2 |
114 |
|
|
- Fixed default values [SME 9043] |
115 |
|
|
|
116 |
|
|
* Fri Sep 04 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.2-1.sme |
117 |
|
|
- Initial release to contribs9 |
118 |
|
|
|
119 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
120 |
|
|
- Clean up spec so package can be built by koji/plague |
121 |
|
|
|
122 |
|
|
* Sat Apr 28 2007 Trevor Batley <trevorbatley@users.sourceforge.net> 1.0-1 |
123 |
|
|
- Fixed incorrect createlinks for /etc/rc.d/init.d/supervise/tftpd to daemontools |
124 |
|
|
- Removed symlink from /service/tftpd to /var/service/tftpd and used createlinks instead |
125 |
|
|
- Changed %preun from config to /sbin/e-smith/db config and /etc/init.d to /etc/rc.d/init.d |
126 |
|
|
- Removed %BuildPreReq as this applied when it included tftp-server |
127 |
|
|
- Added %BuildArch: noarch as this wrapper does NOT require any specific architecture |
128 |
|
|
|
129 |
|
|
* Wed Apr 25 2007 Trevor Batley <trevorbatley@users.sourceforge.net> 1.0-1 |
130 |
|
|
- Updated Release tag to new smeserver standard |
131 |
|
|
- Changed contrib to just contain the wrapper code and require tftp-server from centos |
132 |
|
|
- As it's a wrapper, changed verion number to it's own (rather that that of tftp-server) |
133 |
|
|
|
134 |
|
|
* Sun Dec 17 2006 Charlie Brady <charlieb@e-smith.com> |
135 |
|
|
- Replace deprecated Copyright header with License. |
136 |
|
|
|
137 |
|
|
* Tue Apr 4 2006 Trevor Batley <trevorbatley@users.sourceforge.net> |
138 |
|
|
- Set tftpd to disabled and stop as part of pre-uninstall script |
139 |
|
|
- Set default user to root |
140 |
|
|
|
141 |
|
|
* Mon Mar 20 2006 Trevor Batley <trevorbatley@users.sourceforge.net> |
142 |
|
|
- Repackage for smeserver v7.x |
143 |
|
|
- Based on repackaging already done by Daniel Warnet <daniel@tw.co.nz> |
144 |
|
|
|
145 |
|
|
* Mon Sep 13 2004 Elliot Lee <sopwith@redhat.com> 0.39-1 |
146 |
|
|
- Update to new version makes tftp work, says upstream. |
147 |
|
|
- Remove malta patch |
148 |
|
|
|
149 |
|
|
* Mon Sep 13 2004 Elliot Lee <sopwith@redhat.com> 0.38-1 |
150 |
|
|
- Update to new version fixes #131736 |
151 |
|
|
|
152 |
|
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> |
153 |
|
|
- rebuilt |
154 |
|
|
|
155 |
|
|
* Thu Jun 03 2004 Elliot Lee <sopwith@redhat.com> 0.36-1 |
156 |
|
|
- Update version |
157 |
|
|
|
158 |
|
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> |
159 |
|
|
- rebuilt |
160 |
|
|
|
161 |
|
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> |
162 |
|
|
- rebuilt |
163 |
|
|
|
164 |
|
|
* Fri Apr 11 2003 Elliot Lee <sopwith@redhat.com> |
165 |
|
|
- 0.33 |
166 |
|
|
- Add /tftpboot directory (#88204) |
167 |
|
|
|
168 |
|
|
* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com> |
169 |
|
|
- rebuilt |
170 |
|
|
|
171 |
|
|
* Sun Feb 23 2003 Tim Powers <timp@redhat.com> |
172 |
|
|
- add BuildPreReq on tcp_wrappers |
173 |
|
|
|
174 |
|
|
* Wed Jan 22 2003 Tim Powers <timp@redhat.com> |
175 |
|
|
- rebuilt |
176 |
|
|
|
177 |
|
|
* Mon Nov 11 2002 Elliot Lee <sopwith@redhat.com> 0.32-1 |
178 |
|
|
- Update to 0.32 |
179 |
|
|
|
180 |
|
|
* Wed Oct 23 2002 Elliot Lee <sopwith@redhat.com> 0.30-1 |
181 |
|
|
- Fix #55789 |
182 |
|
|
- Update to 0.30 |
183 |
|
|
|
184 |
|
|
* Thu Jun 27 2002 Elliot Lee <sopwith@redhat.com> |
185 |
|
|
- Try applying HJ's patch from #65476 |
186 |
|
|
|
187 |
|
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> |
188 |
|
|
- automated rebuild |
189 |
|
|
|
190 |
|
|
* Mon Jun 17 2002 Elliot Lee <sopwith@redhat.com> |
191 |
|
|
- Update to 0.29 |
192 |
|
|
|
193 |
|
|
* Thu May 23 2002 Tim Powers <timp@redhat.com> |
194 |
|
|
- automated rebuild |
195 |
|
|
|
196 |
|
|
* Wed Jan 09 2002 Tim Powers <timp@redhat.com> |
197 |
|
|
- automated rebuild |
198 |
|
|
|
199 |
|
|
* Tue Dec 18 2001 Elliot Lee <sopwith@redhat.com> 0.17-15 |
200 |
|
|
- Update to tftp-hpa-0.28 (bug #56131) |
201 |
|
|
- Remove include/arpa/tftp.h to fix #57259 |
202 |
|
|
- Add resource limits in tftp-xinetd (#56722) |
203 |
|
|
|
204 |
|
|
* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com> |
205 |
|
|
- Bump release + rebuild. |
206 |
|
|
|
207 |
|
|
* Tue Jun 12 2001 Helge Deller <hdeller@redhat.de> (0.17-13) |
208 |
|
|
- updated tftp-hpa source to tftp-hpa-0.17 |
209 |
|
|
- tweaked specfile with different defines for tftp-netkit and tftp-hpa version |
210 |
|
|
- use hpa's tftpd.8 man page instead of the netkits one |
211 |
|
|
|
212 |
|
|
* Mon May 07 2001 Helge Deller <hdeller@redhat.de> |
213 |
|
|
- rebuilt in 7.1.x |
214 |
|
|
|
215 |
|
|
* Wed Apr 18 2001 Helge Deller <hdeller@redhat.de> |
216 |
|
|
- fix tftp client's put problems (#29529) |
217 |
|
|
- update to tftp-hpa-0.16 |
218 |
|
|
|
219 |
|
|
* Wed Apr 4 2001 Jakub Jelinek <jakub@redhat.com> |
220 |
|
|
- don't let configure to guess compiler, it can pick up egcs |
221 |
|
|
|
222 |
|
|
* Thu Feb 08 2001 Helge Deller <hdeller@redhat.de> |
223 |
|
|
- changed "wait" in xinetd file to "yes" (hpa-tftpd forks and exits) (#26467) |
224 |
|
|
- fixed hpa-tftpd to handle files greater than 32MB (#23725) |
225 |
|
|
- added "-l" flag to hpa-tftpd for file-logging (#26467) |
226 |
|
|
- added description for "-l" to the man-page |
227 |
|
|
|
228 |
|
|
* Thu Feb 08 2001 Helge Deller <hdeller@redhat.de> |
229 |
|
|
- updated tftp client to 0.17 stable (#19640), |
230 |
|
|
- drop dependency on xinetd for tftp client (#25051), |
231 |
|
|
|
232 |
|
|
* Wed Jan 17 2001 Jeff Johnson <jbj@redhat.com> |
233 |
|
|
- xinetd shouldn't wait on tftp (which forks) (#23923). |
234 |
|
|
|
235 |
|
|
* Sat Jan 6 2001 Jeff Johnson <jbj@redhat.com> |
236 |
|
|
- fix to permit tftp put's (#18128). |
237 |
|
|
- startup as root with chroot to /tftpboot with early reversion to nobody |
238 |
|
|
is preferable to starting as nobody w/o ability to chroot. |
239 |
|
|
- %%post is needed by server, not client. Add %%postun for erasure as well. |
240 |
|
|
|
241 |
|
|
* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com> |
242 |
|
|
- default to being disabled |
243 |
|
|
|
244 |
|
|
* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com> |
245 |
|
|
- correct group. |
246 |
|
|
|
247 |
|
|
* Tue Jul 25 2000 Nalin Dahyabhai <nalin@redhat.com> |
248 |
|
|
- change user from root to nobody |
249 |
|
|
|
250 |
|
|
* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com> |
251 |
|
|
- update to tftp-hpa-0.14 (#14003). |
252 |
|
|
- add server_args (#14003). |
253 |
|
|
- remove -D_BSD_SOURCE (#14003). |
254 |
|
|
|
255 |
|
|
* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com> |
256 |
|
|
- cook up an xinetd config file for tftpd |
257 |
|
|
|
258 |
|
|
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com> |
259 |
|
|
- automatic rebuild |
260 |
|
|
|
261 |
|
|
* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com> |
262 |
|
|
- FHS packaging. |
263 |
|
|
- update to 0.17. |
264 |
|
|
|
265 |
|
|
* Fri May 5 2000 Matt Wilson <msw@redhat.com> |
266 |
|
|
- use _BSD_SOURCE for hpa's tftpd so we get BSD signal semantics. |
267 |
|
|
|
268 |
|
|
* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com> |
269 |
|
|
- fix description |
270 |
|
|
|
271 |
|
|
* Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com> |
272 |
|
|
- compress man pages (again). |
273 |
|
|
|
274 |
|
|
* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com> |
275 |
|
|
- man pages are compressed |
276 |
|
|
- fix description and summary |
277 |
|
|
|
278 |
|
|
* Tue Jan 4 2000 Bill Nottingham <notting@redhat.com> |
279 |
|
|
- split client and server |
280 |
|
|
|
281 |
|
|
* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com> |
282 |
|
|
- update to 0.16. |
283 |
|
|
|
284 |
|
|
* Sat Aug 28 1999 Jeff Johnson <jbj@redhat.com> |
285 |
|
|
- update to 0.15. |
286 |
|
|
|
287 |
|
|
* Wed Apr 7 1999 Jeff Johnson <jbj@redhat.com> |
288 |
|
|
- tftpd should truncate file when overwriting (#412) |
289 |
|
|
|
290 |
|
|
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> |
291 |
|
|
- auto rebuild in the new build environment (release 22) |
292 |
|
|
|
293 |
|
|
* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com> |
294 |
|
|
- compile for 6.0. |
295 |
|
|
|
296 |
|
|
* Fri Aug 7 1998 Jeff Johnson <jbj@redhat.com> |
297 |
|
|
- build root |
298 |
|
|
|
299 |
|
|
* Mon Apr 27 1998 Prospector System <bugs@redhat.com> |
300 |
|
|
- translations modified for de, fr, tr |
301 |
|
|
|
302 |
|
|
* Mon Sep 22 1997 Erik Troan <ewt@redhat.com> |
303 |
|
|
- added check for getpwnam() failure |
304 |
|
|
|
305 |
|
|
* Tue Jul 15 1997 Erik Troan <ewt@redhat.com> |
306 |
|
|
- initial build |