1 |
slords |
1.1 |
Summary: smserver rpm to setup The Address Book, an address management system |
2 |
|
|
%define name smeserver-theaddressbook |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.9 |
5 |
|
|
%define release 1 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release} |
8 |
|
|
Distribution: SME Server |
9 |
|
|
Copyright: GPL |
10 |
|
|
URL: http://www.dungog.net/sme |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
Packager: Stephen Noble <support@dungog.net> |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
Requires: e-smith-release >= 7.0 |
17 |
|
|
Requires: theaddressbook |
18 |
|
|
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
smserver rpm to setup The Address Book, an address management system |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Thu Dec 21 2006 Stephen Noble <support@dungog.net> |
25 |
|
|
- initial release |
26 |
|
|
- [0.9-1] |
27 |
|
|
|
28 |
|
|
%prep |
29 |
|
|
%setup |
30 |
|
|
|
31 |
|
|
%build |
32 |
|
|
#perl createlinks |
33 |
|
|
mkdir -p root/etc/e-smith/db/accounts/defaults/addressbook |
34 |
|
|
echo "reserved" > root/etc/e-smith/db/accounts/defaults/addressbook/type |
35 |
|
|
|
36 |
|
|
mkdir -p root/etc/e-smith/db/configuration/defaults/addressbook |
37 |
|
|
echo "The Address Book" > root/etc/e-smith/db/configuration/defaults/addressbook/Name |
38 |
|
|
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/addressbook/PublicAccess |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
rm -rf $RPM_BUILD_ROOT |
42 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
43 |
|
|
rm -f %{name}-%{version}-filelist |
44 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
45 |
|
|
--file '/opt/addressbook/import.pl' 'attr(0755,root,root)' \ |
46 |
|
|
> %{name}-%{version}-filelist |
47 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
48 |
|
|
|
49 |
|
|
%clean |
50 |
|
|
cd .. |
51 |
|
|
rm -rf %{name}-%{version} |
52 |
|
|
|
53 |
|
|
%pre |
54 |
|
|
%preun |
55 |
|
|
|
56 |
|
|
%post |
57 |
|
|
/etc/e-smith/events/actions/initialize-default-databases |
58 |
|
|
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80addressbook.sql |
59 |
|
|
/etc/rc.d/init.d/mysql.init start |
60 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
61 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
62 |
|
|
|
63 |
|
|
echo "" |
64 |
|
|
echo "see www.dungog.net/sme/webapp.php" |
65 |
|
|
echo "current settings 'config show addressbook'..." |
66 |
|
|
/sbin/e-smith/config show addressbook |
67 |
|
|
|
68 |
|
|
%postun |
69 |
|
|
#uninstall |
70 |
|
|
if [ $1 = 0 ] ; then |
71 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
72 |
|
|
/usr/local/bin/svc -h /service/httpd-e-smith |
73 |
|
|
fi |
74 |
|
|
|
75 |
|
|
%files -f %{name}-%{version}-filelist |
76 |
|
|
%defattr(-,root,root) |
77 |
|
|
|