1 |
# $Id: smeserver-theaddressbook.spec,v 1.4 2008/11/25 16:20:32 slords Exp $ |
2 |
# Authority: dungog |
3 |
# Name: Stephen Noble |
4 |
|
5 |
Summary: smserver rpm to setup The Address Book, an address management system |
6 |
%define name smeserver-theaddressbook |
7 |
Name: %{name} |
8 |
%define version 0.9 |
9 |
%define release 1 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
URL: http://www.dungog.net/sme |
14 |
Group: SMEserver/addon |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
BuildArchitectures: noarch |
17 |
BuildRoot: /var/tmp/%{name}-%{version} |
18 |
Requires: e-smith-release >= 7.0 |
19 |
Requires: theaddressbook |
20 |
BuildRequires: e-smith-devtools |
21 |
AutoReqProv: no |
22 |
|
23 |
%description |
24 |
smserver rpm to setup The Address Book, an address management system |
25 |
|
26 |
%changelog |
27 |
* Thu Dec 21 2006 Stephen Noble <support@dungog.net> |
28 |
- initial release |
29 |
- [0.9-1] |
30 |
|
31 |
%prep |
32 |
%setup |
33 |
|
34 |
%build |
35 |
#perl createlinks |
36 |
mkdir -p root/etc/e-smith/db/accounts/defaults/addressbook |
37 |
echo "reserved" > root/etc/e-smith/db/accounts/defaults/addressbook/type |
38 |
|
39 |
mkdir -p root/etc/e-smith/db/configuration/defaults/addressbook |
40 |
echo "The Address Book" > root/etc/e-smith/db/configuration/defaults/addressbook/Name |
41 |
echo "global-pw-remote" > root/etc/e-smith/db/configuration/defaults/addressbook/PublicAccess |
42 |
|
43 |
%install |
44 |
rm -rf $RPM_BUILD_ROOT |
45 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
46 |
rm -f %{name}-%{version}-filelist |
47 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
48 |
--file '/opt/addressbook/import.pl' 'attr(0755,root,root)' \ |
49 |
> %{name}-%{version}-filelist |
50 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
51 |
|
52 |
%clean |
53 |
cd .. |
54 |
rm -rf %{name}-%{version} |
55 |
|
56 |
%pre |
57 |
%preun |
58 |
|
59 |
%post |
60 |
/etc/e-smith/events/actions/initialize-default-databases |
61 |
/sbin/e-smith/expand-template /etc/e-smith/sql/init/80addressbook.sql |
62 |
/etc/rc.d/init.d/mysql.init start |
63 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
64 |
/usr/local/bin/svc -h /service/httpd-e-smith |
65 |
|
66 |
echo "" |
67 |
echo "see www.dungog.net/sme/webapp.php" |
68 |
echo "current settings 'config show addressbook'..." |
69 |
/sbin/e-smith/config show addressbook |
70 |
|
71 |
%postun |
72 |
#uninstall |
73 |
if [ $1 = 0 ] ; then |
74 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
75 |
/usr/local/bin/svc -h /service/httpd-e-smith |
76 |
fi |
77 |
|
78 |
%files -f %{name}-%{version}-filelist |
79 |
%defattr(-,root,root) |
80 |
|