/[smecontribs]/rpms/smeserver-thinclient/contribs10/smeserver-thinclient.spec
ViewVC logotype

Annotation of /rpms/smeserver-thinclient/contribs10/smeserver-thinclient.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.6 - (hide annotations) (download)
Thu Jun 30 04:55:01 2022 UTC (23 months ago) by trevorb
Branch: MAIN
Changes since 1.5: +2 -2 lines
fix date on spec date

1 trevorb 1.6 # $Id: smeserver-thinclient.spec,v 1.5 2022/06/30 04:45:51 trevorb Exp $
2 brianr 1.1 # Authority: nocvs
3     # Name: Trevor Batley
4    
5 trevorb 1.5 Summary: Manage pxeboot of Thin Client workstations over network
6 brianr 1.1 %define name smeserver-thinclient
7     Name: %{name}
8 trevorb 1.3 %define version 2.2
9 trevorb 1.5 %define release 3
10 brianr 1.1 Version: %{version}
11     Release: %{release}%{?dist}
12     License: GPL
13     Group: Network
14     Source: %{name}-%{version}.tar.xz
15     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
16     BuildArch: noarch
17 trevorb 1.3 Requires: e-smith-base, smeserver-pxe
18 brianr 1.1 BuildRequires: e-smith-devtools >= 1.13.1-03
19     AutoReq: yes
20 trevorb 1.4 Patch1: smeserver-thinclient-2.2-migrate_DB_open_RW.patch
21 trevorb 1.5 Patch2: smeserver-thinclient-2.2-12085-workstation_trigger_update.patch
22 brianr 1.1
23     %description
24 trevorb 1.3 Manage diskless workstation/device booting over network.
25 brianr 1.1 PXE capable NIC and BIOS required on target machine
26 trevorb 1.3 Basic PXE booting is enabled via smeserver-pxe. This contrib manages what the pxe clients use.
27     A tftp server is reqired. Can be on sme server (eg smeserver-tftp) or elsewhere in network
28     Requires sme server to be acting as the dhcp server
29 brianr 1.1
30 trevorb 1.5 %prep
31     %setup -q -n %{name}-%{version}
32     %patch1 -p1
33     %patch2 -p1
34    
35     %build
36     perl createlinks
37    
38     %install
39     /bin/rm -rf $RPM_BUILD_ROOT
40     (cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT)
41     /bin/rm -f %{name}-%{version}-filelist
42     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist
43    
44     %clean
45     rm -rf $RPM_BUILD_ROOT
46    
47     %files -f %{name}-%{version}-filelist
48    
49     %defattr(-,root,root)
50    
51     %pre
52    
53     %preun
54    
55     %post
56    
57     %postun
58    
59 brianr 1.1 %changelog
60 trevorb 1.6 * Thu Jun 30 2020 Trevor Batley <trevor@batley.id.au> 2.2-3.sme
61 trevorb 1.5 - trigger update event on all save of workstation [SME 12085]
62     - move templates2expand and services2adjust into createlinks [SME 12086]
63     - move changelog in spec to end
64    
65 trevorb 1.4 * Tue May 10 2022 Trevor Batley <trevor@batley.id.au> 2.2-2.sme
66 trevorb 1.5 - added missing migrate/00openRW fragment for thinslient DB [SME 11967]
67 trevorb 1.4
68 trevorb 1.3 * Thu Apr 28 2022 Trevor Batley <trevor@batley.id.au> 2.2-1.sme
69     - added /etc/dhcpd.thinclient include file for pxe clients
70     - remove core pxe components and add requirement for smeserver-pxe [SME: 11960]
71     - add options for different architectures [SME: 10821]
72     - change back to using / updating tftp [SME: 11939]
73     - fixed some dodgy db parameter processing
74     - rollup patches (archive.patch, tftpd.conf)
75    
76 brianr 1.2 * Thu Oct 29 2020 Brian Read <brianr@bjsystems.co.uk> 2.1-4.sme
77     - Initial import to SME10 tree [SME: 11073]
78    
79 brianr 1.1 * Mon Apr 25 2016 Trevor Batley <trevorbatley@users.sourceforge.net> 2.1-3
80     - Allow upload and extract of 'Distribution' archives for loading into /tftpboot [9481]
81     - Always set tftproot as /tftpboot as default [9441]
82    
83 trevorb 1.3 * Mon Apr 4 2016 Trevor Batley <trevorbatley@users.sourceforge.net> 2.1-2
84 brianr 1.1 - Run tftpd-conf when tftp server is set to Self and tftpd exists [9417]
85     - Also remove the services2adjust restart of tftpd, which was trying to do the same
86    
87     * Tue Nov 12 2013 Daniel Berteaud <daniel@firewall-services.com> 2.1-1
88     - Rebuild for SME9
89    
90     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
91     - Clean up spec so package can be built by koji/plague
92    
93     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
94     - Update to new release naming. No functional changes.
95     - Make Packager generic
96    
97     * Mon Jun 12 2006 Trevor Batley <trevor@batley.id.au> - 2.0-5
98     - Cater for missing tftpd parameter in configuration database
99     - Set dhcpd Bootp parameter in configuration database
100    
101     * Tue Apr 4 2006 Trevor Batley <trevor@batley.id.au> - 2.0-4
102     - Got rid of superfluous 3 level version number and reverted to 2 levels
103    
104 trevorb 1.3 * Sat Apr 1 2006 Trevor Batley <trevor@batley.id.au> - 2.0.0-3
105 brianr 1.1 - Tidied up some of the references to pxe parameters in panel
106     - Changed panel to look for the tftpd{directory} parameter for populating tftproot
107    
108     * Sun Mar 26 2006 Trevor Batley <trevor@batley.id.au> - 2.0.0-2
109     - Change update to tftp key in config database to tftpd to align with tftpd package from Daniel Warnet
110    
111     * Sat Feb 11 2006 Trevor Batley <trevor@batley.id.au> - 2.0.0-1
112     - Amend to work with smeserver v7rc2 +>
113     + rename pxeclients database thinclient
114     + panel - remove hardcoded thinclient & hosts database paths
115     + panel - remove references to dhcpd{DenyBootp} database property
116     + templates - remove /etc/dhcpd.conf/25DenyBootp fragment
117     + events - use services2update for conf-thinclient
118     + actions - remove conf-thinclient script
119     + spec - remove all coding in %pre tag
120     + createlinks - only do panel (remove all other c**p)
121    
122     * Thu Nov 11 2004 Trevor Batley <trevor@batley.id.au> - 1.2.0-5
123     - Fix error when changing distribution and NOT regenerating /etc/dhcpd.config
124     - Added option to allow changing the default filename to be executed (per distribution)
125    
126     * Sat Apr 17 2004 Trevor Batley <trevor@batley.id.au> - 1.2.0-4
127     - Fix error when adding new Workstation and 'Default Distribution' set as 'None'
128    
129     * Wed Apr 14 2004 Trevor Batley <trevor@batley.id.au> - 1.2.0-3
130     - Fix stupid error with use of Self for tftp server (template for /etc/dhcpd.conf/48NextServer)
131    
132     * Wed Apr 14 2004 Trevor Batley <trevor@batley.id.au> - 1.2.0-2
133     - Multiple validation changes
134     - Add log file capture and display for rpm & signal-event handling
135     - Display error messages on Workstation & Distribution panels
136     - Added tick/cross and coloured Operation Status report
137    
138 trevorb 1.3 * Thu Apr 1 2004 Trevor Batley <trevor@batley.id.au> - 1.2.0-1
139 brianr 1.1 - Add functionality into panel to add/remove distributions via rpm (file on local workstation)
140    
141     * Wed Mar 24 2004 Trevor Batley <trevor@batley.id.au>
142     - Removed postun action of navigation-conf-hidden and replaced with correct action of navigation-conf
143    
144     * Fri Mar 19 2004 Trevor Batley <trevor@batley.id.au>
145     - Formatting changes to sub-panels within thinclient server-manager panel and addition of cancel button to workstation settings
146    
147     * Thu Mar 18 2004 Trevor Batley <trevor@batley.id.au>
148     - Removed post action of navigation-conf-hidden and replaced with correct action of navigation-conf
149    
150     * Thu Mar 18 2004 Trevor Batley <trevor@batley.id.au>
151     - Removed tftp components from this rpm and put them in smeserver-tftpd
152     - added requirement to use smeserver-tftpd and removed requirement for generic tftp
153    
154     * Mon Mar 15 2004 Trevor Batley <trevor@batley.id.au>
155     - Fixed bug in mac address checking
156     - included call to navigation-conf-hidden in post install event
157    
158     * Fri Mar 12 2004 Trevor Batley <trevor@batley.id.au>
159     - Revamped rpm build spec file and associated pre & post scripts etc.
160    
161     * Sat Mar 6 2004 Trevor Batley <trevor@batley.id.au>
162     - Updated thinclient server-manager panel using suggestions from Darrell May & Gordon Rowell
163    
164     * Wed Feb 4 2004 Trevor Batley <trevor@batley.id.au>
165     - Initial working (sort of) pxeboot server-manager panel
166    
167     * Wed Feb 4 2004 Trevor Batley <trevor@batley.id.au>
168     - Add initial pxeboot server-manager panel
169    
170     * Tue Feb 3 2004 Trevor Batley <trevor@batley.id.au>
171     - Fix problem with quoting around default tftpboot directory
172    
173     * Sat Jan 31 2004 Trevor Batley <trevor@batley.id.au>
174     - Fix template problem with
175    
176     * Sat Jan 24 2004 Trevor Batley <trevor@batley.id.au>
177     - Initial release
178    
179     * Sat Jan 24 2004 Trevor Batley <trevor@batley.id.au>
180     - Initial release
181    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed