/[smecontribs]/rpms/smeserver-tw-logonscript/contribs7/smeserver-tw-logonscript.spec
ViewVC logotype

Annotation of /rpms/smeserver-tw-logonscript/contribs7/smeserver-tw-logonscript.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.13 - (hide annotations) (download)
Wed Jan 27 03:42:49 2010 UTC (14 years, 4 months ago) by chriscosta
Branch: MAIN
CVS Tags: smeserver-tw-logonscript-1_3-14_el4_sme
Changes since 1.12: +26 -2 lines
* Wed Jan 27 2010 Christian Costa <christian@tw.co.nz> 1.3-14
- Created a new configuration database for tw-logonscript. Two properties MountPointsPath and UserHomeMountPointName have been added.
- Changed the spec file to set the default properties automatically

1 chriscosta 1.13 # $Id: smeserver-tw-logonscript.spec,v 1.12 2009/12/01 02:24:41 chriscosta Exp $
2 slords 1.1 # Authority: chriscosta
3     # Name: Christian Costa
4    
5     %define name smeserver-tw-logonscript
6     %define version 1.3
7 chriscosta 1.13 %define release 14
8 slords 1.1 Summary: TechnologyWise Windows/Linux logon script for Samba
9     Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     Source: smeserver-tw-logonscript-%{version}.tar.gz
13 chriscosta 1.3 Patch0: smeserver-tw-logonscript-1.3-removeblank.patch
14 vip-ire 1.5 Patch1: smeserver-tw-logonscript-1.3-locale-2009-10-21.patch
15 slords 1.6 Patch2: smeserver-tw-logonscript-1.3-locale-2009-10-27.patch
16 chriscosta 1.7 Patch3: smeserver-tw-logonscript-1.3-PamMountOptsFix-HomeNameChange.patch
17 chriscosta 1.8 Patch4: smeserver-tw-logonscript-1.3-SecurityFixBatchEdit.patch
18 chriscosta 1.9 Patch5: smeserver-tw-logonscript-1.3-en_us_patch1.patch
19     Patch6: smeserver-tw-logonscript-1.3-functionsPrintGroupTable.patch
20     Patch7: smeserver-tw-logonscript-1.3-panelPrintGroupTable.patch
21 chriscosta 1.10 Patch8: smeserver-tw-logonscript-1.3-TemplateWarningFix.patch
22 chriscosta 1.11 Patch9: smeserver-tw-logonscript-1.3-signalEventPatch.patch
23 chriscosta 1.12 Patch10: smeserver-tw-logonscript-1.3-signalEventPatch2.patch
24 chriscosta 1.13 Patch11: smeserver-tw-logonscript-1.3-pathDBSettings.patch
25 slords 1.1 License: GNU GPL version 2
26 chriscosta 1.3 Group: Networking/Daemons
27 slords 1.1 BuildArchitectures: noarch
28     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
29 chriscosta 1.4 BuildRequires: e-smith-devtools
30 slords 1.1
31     %description
32     TechnologyWise Windows/Linux logon script for Samba
33    
34     %prep
35     %setup
36 chriscosta 1.3 %patch0 -p1
37 vip-ire 1.5 %patch1 -p1
38 slords 1.6 %patch2 -p1
39 chriscosta 1.7 %patch3 -p1
40 chriscosta 1.8 %patch4 -p1
41 chriscosta 1.9 %patch5 -p1
42     %patch6 -p1
43     %patch7 -p1
44 chriscosta 1.10 %patch8 -p1
45 chriscosta 1.11 %patch9 -p1
46 chriscosta 1.12 %patch10 -p1
47 chriscosta 1.13 %patch11 -p1
48 slords 1.1 %build
49     perl createlinks
50    
51     %install
52     rm -rf $RPM_BUILD_ROOT
53     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
54     rm -f %{name}-%{version}-filelist
55     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
56     > %{name}-%{version}-filelist
57    
58     %clean
59     cd ..
60     rm -rf %{name}
61    
62 chriscosta 1.13
63     %pre
64     UPDATE=$(/sbin/e-smith/db configuration get tw-logonscript)
65    
66     case $UPDATE in
67     0)
68     echo "tw-logonscript configuration db found, not touching anything"
69     ;;
70    
71     1)
72     /sbin/e-smith/db configuration set tw-logonscript configuration
73     /sbin/e-smith/db configuration setprop tw-logonscript MountPointsPath /mnt UserHomeMountPointName user_data
74     ;;
75     esac
76    
77     %preun
78     /sbin/e-smith/db configuration delete tw-logonscript
79    
80 slords 1.1 %files -f %{name}-%{version}-filelist
81     %defattr(-,root,root)
82    
83     %changelog
84 chriscosta 1.13 * Wed Jan 27 2010 Christian Costa <christian@tw.co.nz> 1.3-14
85     - Created a new configuration database for tw-logonscript. Two properties MountPointsPath and UserHomeMountPointName have been added.
86     - Changed the spec file to set the default properties automatically
87    
88 chriscosta 1.12 * Tue Dec 1 2009 Christian Costa <christian@tw.co.nz> 1.3-13
89     - Changed event name on createlinks to bootstrap-console-save instead of post-upgrade.
90    
91 chriscosta 1.11 * Tue Dec 1 2009 Christian Costa <christian@tw.co.nz> 1.3-12
92     - Changed the createlinks script to correctly set up the templates to expand so that netlogon.bat will be expanded with workgroup-update and post-upgrade
93    
94 chriscosta 1.10 * Thu Nov 19 2009 Christian Costa <christian@tw.co.nz> 1.3-11
95     - Changes to the netlogon.bat template. If no drive letters were associate to I-bays it generated errors. Also defaulted the home drive to H: in case none is set.
96     - Added two missing files to the workgroup-update and post-upgrade events.
97    
98 chriscosta 1.9 * Mon Nov 16 2009 Christian Costa <christian@tw.co.nz> 1.3-10
99     - Changes to the SME Server panel. Now it displays a list with all groups that allows custom group batch files to be edited/created for all groups not only the ones associated with i-bays.
100     - Added a new lexicon to the en_us file
101    
102 chriscosta 1.8 * Wed Nov 4 2009 Christian Costa <christian@tw.co.nz> 1.3-9
103     - Fixed a security problem that would allow the creation of arbitrary files on the system.
104    
105     * Thu Oct 29 2009 Christian Costa <christian@tw.co.nz> 1.3-8
106 chriscosta 1.7 - Added additional pam_mount options to the .pam_mount.xml generation routine
107     - Changed the user's home dir mount point name from home to win_home
108    
109 slords 1.6 * Tue Oct 27 2009 SME Translation Server <translations@contribs.org> 1.3-7.sme
110     - apply locale 2009-10-27 patch
111    
112 vip-ire 1.5 * Wed Oct 21 2009 SME Translation Server <translations@contribs.org> 1.3-6.sme
113     - apply locale 2009-10-21 patch
114     - cleanup changelog to be more readable
115    
116 chriscosta 1.4 * Tue Oct 20 2009 Christian Costa <christian@tw.co.nz> 1.3-5
117 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
118     Added e-smith-devtools as a build requirement
119    
120     =======
121 vip-ire 1.5 - Added e-smith-devtools as a build requirement
122    
123 chriscosta 1.7 >>>>>>> 1.6
124 chriscosta 1.3 * Tue Oct 20 2009 Christian Costa <christian@tw.co.nz> 1.3-04
125 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
126     Removed a blank space from the source code for testing purposes
127    
128     =======
129 vip-ire 1.5 - Removed a blank space from the source code for testing purposes
130    
131 chriscosta 1.7 >>>>>>> 1.6
132 slords 1.1 * Thu Oct 8 2009 Christian Costa <christian@tw.co.nz>
133 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
134     Added localisation support
135     Added server-manager embedded custom group batch file editing
136     Fixed a bug with user custom scripts that were being executed more than once
137    
138     =======
139 vip-ire 1.5 - Added localisation support
140     - Added server-manager embedded custom group batch file editing
141     - Fixed a bug with user custom scripts that were being executed more than once
142    
143 chriscosta 1.7 >>>>>>> 1.6
144 slords 1.1 * Thu Sep 3 2009 Christian Costa <christian@tw.co.nz>
145 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
146     New specs file, new version number
147    
148     =======
149 vip-ire 1.5 - New specs file, new version number
150    
151 chriscosta 1.7 >>>>>>> 1.6
152 slords 1.1 * Mon Aug 10 2009 Christian Costa <christian@tw.co.nz>
153 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
154     Branched out from the 61netlogonshare custom script and added a new db property for smb called LogonScript
155    
156     =======
157 vip-ire 1.5 - Branched out from the 61netlogonshare custom script and added a new db property for smb called LogonScript
158    
159 chriscosta 1.7 >>>>>>> 1.6
160 slords 1.1 * Wed Jul 8 2009 Christian Costa <christian@tw.co.nz>
161 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
162     Added .pam_mount.conf.xml generation for Linux clients using libpam-mount.
163    
164     =======
165 vip-ire 1.5 - Added .pam_mount.conf.xml generation for Linux clients using libpam-mount.
166    
167 chriscosta 1.7 >>>>>>> 1.6
168 slords 1.1 * Wed Jul 29 2008 Christian Costa <christian@tw.co.nz>
169 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
170     Added a feature that maps the drive if all users are allowed to read an I-bay.
171     Extended the drive letter range from F to Z.
172    
173     =======
174 vip-ire 1.5 - Added a feature that maps the drive if all users are allowed to read an I-bay.
175     - Extended the drive letter range from F to Z.
176    
177 chriscosta 1.7 >>>>>>> 1.6
178 slords 1.1 * Wed Jul 9 2008 Christian Costa <christian@tw.co.nz>
179 chriscosta 1.7 <<<<<<< smeserver-tw-logonscript.spec
180     Added the server-manager web interface to the package.
181     =======
182 vip-ire 1.5 - Added the server-manager web interface to the package.
183 slords 1.1
184 chriscosta 1.7 >>>>>>> 1.6

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed