1 |
brianr |
1.2 |
# $Id: smeserver-updates.spec,v 1.1 2020/10/29 19:16:03 brianr Exp $ |
2 |
brianr |
1.1 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: Update system panel for SMEserver รง |
6 |
|
|
%define name smeserver-updates |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.4 |
9 |
brianr |
1.2 |
%define release 3 |
10 |
brianr |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: System/Administration |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
Requires: e-smith-release >= 9.0 |
18 |
|
|
BuildRequires: e-smith-devtools |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
Update system panel for sme server 9 |
23 |
|
|
permitting the uploading and installing of .rpms |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
brianr |
1.2 |
* Thu Oct 29 2020 Brian Read <brianr@bjsystems.co.uk> 1.4-3.sme |
27 |
|
|
- Initial import to SME10 tree [SME: 11075] |
28 |
|
|
|
29 |
brianr |
1.1 |
* Sat Aug 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.4-2.sme |
30 |
|
|
- Initial release to contribs9 |
31 |
|
|
|
32 |
|
|
* Mon Jun 23 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 1.4-1.sme |
33 |
|
|
- Initial release to sme9 |
34 |
|
|
|
35 |
|
|
* Wed Jun 26 2013 JP Pialasse <tests@pialasse.com> 1.2-5.sme |
36 |
|
|
- fixing spec file |
37 |
|
|
|
38 |
|
|
* Tue Jun 25 2013 JP Pialasse <tests@pialasse.com> 1.2-4.sme |
39 |
|
|
- fix yum path [SME: 7478] |
40 |
|
|
- patch0 |
41 |
|
|
|
42 |
|
|
* Tue Jan 23 2007 Stephen Noble <support@dungog.net> |
43 |
|
|
- install with 'yum localinstall' |
44 |
|
|
- [1.2-3] |
45 |
|
|
|
46 |
|
|
* Mon Mar 13 2006 Stephen Noble <support@dungog.net> |
47 |
|
|
- sme7 version |
48 |
|
|
- uploading and installing an rpm fixed |
49 |
|
|
- [1.2-2] |
50 |
|
|
|
51 |
|
|
* Tue Dec 13 2005 Stephen Noble <support@dungog.net> |
52 |
|
|
- sme7 version |
53 |
|
|
- removed all functions except for uploading and installing a rpm |
54 |
|
|
- yum is usually a better option |
55 |
|
|
- [1.2-1] |
56 |
|
|
|
57 |
|
|
* Tue Feb 19 2002 Darrell May <dmay@netsourced.com> |
58 |
|
|
- initial release based on: |
59 |
|
|
- eneo-update-1.0-01.noarch.rpm |
60 |
|
|
- Vendor: Eneo Tecnologia SC. |
61 |
|
|
- Packager: Juan Jesus Prieto <juanprieto@jazzfree.com> |
62 |
|
|
- [0.0.1-1] |
63 |
|
|
|
64 |
|
|
%prep |
65 |
|
|
%setup |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
%build |
69 |
|
|
perl createlinks |
70 |
|
|
|
71 |
|
|
%install |
72 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
73 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
74 |
|
|
/bin/rm -f e-smith-%{version}-filelist |
75 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
cd .. |
79 |
|
|
/bin/rm -rf %{name}-%{version} |
80 |
|
|
|
81 |
|
|
%files -f %{name}-%{version}-filelist |
82 |
|
|
|
83 |
|
|
%defattr(-,root,root) |
84 |
|
|
|
85 |
|
|
%pre |
86 |
|
|
|
87 |
|
|
%post |
88 |
|
|
#new installs |
89 |
|
|
|
90 |
|
|
#echo " If panel doesnt appear run /etc/e-smith/events/actions/navigation-conf" |
91 |
|
|
|
92 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
93 |
|
|
# for db in $DBS ; do |
94 |
|
|
# r=`/sbin/e-smith/db $db get update-system` |
95 |
|
|
# if [ -z "$r" ] ; then |
96 |
|
|
# /sbin/e-smith/db $db set update-system panel Description "Update system" DescriptionWeight 4390 Heading "Administration" HeadingWeight 4000 |
97 |
|
|
# fi |
98 |
|
|
# done |
99 |
|
|
|
100 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
101 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
102 |
|
|
#fi |
103 |
|
|
|
104 |
|
|
%preun |
105 |
|
|
|
106 |
|
|
%postun |
107 |
|
|
#uninstalls |
108 |
|
|
#if [ $1 = 0 ] ; then |
109 |
|
|
# |
110 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
111 |
|
|
# for db in $DBS ; do |
112 |
|
|
# /sbin/e-smith/db $db delete update-system |
113 |
|
|
# done |
114 |
|
|
# |
115 |
|
|
# #if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
116 |
|
|
# # /sbin/e-smith/signal-event conf-userpanel |
117 |
|
|
# #fi |
118 |
|
|
# |
119 |
|
|
#fi |