1 |
slords |
1.1 |
Summary: Update system panel for SMEserver 7 |
2 |
|
|
%define name smeserver-updates |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.2 |
5 |
|
|
%define release 3 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: System/Administration |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
12 |
|
|
BuildArchitectures: noarch |
13 |
|
|
Requires: e-smith-release >= 7.0 |
14 |
|
|
BuildRequires: e-smith-devtools |
15 |
|
|
AutoReqProv: no |
16 |
|
|
|
17 |
|
|
%description |
18 |
|
|
Update system panel for sme server 7 |
19 |
|
|
permitting the uploading and installing of .rpms |
20 |
|
|
|
21 |
|
|
%changelog |
22 |
|
|
* Tue Jan 23 2007 Stephen Noble <support@dungog.net> |
23 |
|
|
- install with 'yum localinstall' |
24 |
|
|
- [1.2-3] |
25 |
|
|
|
26 |
|
|
* Mon Mar 13 2006 Stephen Noble <support@dungog.net> |
27 |
|
|
- sme7 version |
28 |
|
|
- uploading and installing an rpm fixed |
29 |
|
|
- [1.2-2] |
30 |
|
|
|
31 |
|
|
* Tue Dec 13 2005 Stephen Noble <support@dungog.net> |
32 |
|
|
- sme7 version |
33 |
|
|
- removed all functions except for uploading and installing a rpm |
34 |
|
|
- yum is usually a better option |
35 |
|
|
- [1.2-1] |
36 |
|
|
|
37 |
|
|
* Tue Feb 19 2002 Darrell May <dmay@netsourced.com> |
38 |
|
|
- initial release based on: |
39 |
|
|
- eneo-update-1.0-01.noarch.rpm |
40 |
|
|
- Vendor: Eneo Tecnologia SC. |
41 |
|
|
- Packager: Juan Jesus Prieto <juanprieto@jazzfree.com> |
42 |
|
|
- [0.0.1-1] |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
%setup |
46 |
|
|
|
47 |
|
|
%build |
48 |
|
|
perl createlinks |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
/bin/rm -f e-smith-%{version}-filelist |
54 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
55 |
|
|
|
56 |
|
|
%clean |
57 |
|
|
cd .. |
58 |
|
|
/bin/rm -rf %{name}-%{version} |
59 |
|
|
|
60 |
|
|
%files -f %{name}-%{version}-filelist |
61 |
|
|
|
62 |
|
|
%defattr(-,root,root) |
63 |
|
|
|
64 |
|
|
%pre |
65 |
|
|
|
66 |
|
|
%post |
67 |
|
|
#new installs |
68 |
|
|
|
69 |
|
|
echo " If panel doesnt appear run /etc/e-smith/events/actions/navigation-conf" |
70 |
|
|
|
71 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
72 |
|
|
# for db in $DBS ; do |
73 |
|
|
# r=`/sbin/e-smith/db $db get update-system` |
74 |
|
|
# if [ -z "$r" ] ; then |
75 |
|
|
# /sbin/e-smith/db $db set update-system panel Description "Update system" DescriptionWeight 4390 Heading "Administration" HeadingWeight 4000 |
76 |
|
|
# fi |
77 |
|
|
# done |
78 |
|
|
|
79 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
80 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
81 |
|
|
#fi |
82 |
|
|
|
83 |
|
|
%preun |
84 |
|
|
|
85 |
|
|
%postun |
86 |
|
|
#uninstalls |
87 |
|
|
#if [ $1 = 0 ] ; then |
88 |
|
|
# |
89 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
90 |
|
|
# for db in $DBS ; do |
91 |
|
|
# /sbin/e-smith/db $db delete update-system |
92 |
|
|
# done |
93 |
|
|
# |
94 |
|
|
# #if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
95 |
|
|
# # /sbin/e-smith/signal-event conf-userpanel |
96 |
|
|
# #fi |
97 |
|
|
# |
98 |
|
|
#fi |