1 |
unnilennium |
1.1 |
# $Id: smeserver-updates.spec,v 1.4 2008/11/25 16:20:33 slords Exp $ |
2 |
|
|
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: Update system panel for SMEserver 7 |
6 |
|
|
%define name smeserver-updates |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.2 |
9 |
|
|
%define release 3 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: System/Administration |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
Requires: e-smith-release >= 7.0 |
18 |
|
|
BuildRequires: e-smith-devtools |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
Update system panel for sme server 7 |
23 |
|
|
permitting the uploading and installing of .rpms |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Tue Jan 23 2007 Stephen Noble <support@dungog.net> |
27 |
|
|
- install with 'yum localinstall' |
28 |
|
|
- [1.2-3] |
29 |
|
|
|
30 |
|
|
* Mon Mar 13 2006 Stephen Noble <support@dungog.net> |
31 |
|
|
- sme7 version |
32 |
|
|
- uploading and installing an rpm fixed |
33 |
|
|
- [1.2-2] |
34 |
|
|
|
35 |
|
|
* Tue Dec 13 2005 Stephen Noble <support@dungog.net> |
36 |
|
|
- sme7 version |
37 |
|
|
- removed all functions except for uploading and installing a rpm |
38 |
|
|
- yum is usually a better option |
39 |
|
|
- [1.2-1] |
40 |
|
|
|
41 |
|
|
* Tue Feb 19 2002 Darrell May <dmay@netsourced.com> |
42 |
|
|
- initial release based on: |
43 |
|
|
- eneo-update-1.0-01.noarch.rpm |
44 |
|
|
- Vendor: Eneo Tecnologia SC. |
45 |
|
|
- Packager: Juan Jesus Prieto <juanprieto@jazzfree.com> |
46 |
|
|
- [0.0.1-1] |
47 |
|
|
|
48 |
|
|
%prep |
49 |
|
|
%setup |
50 |
|
|
|
51 |
|
|
%build |
52 |
|
|
perl createlinks |
53 |
|
|
|
54 |
|
|
%install |
55 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
56 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
57 |
|
|
/bin/rm -f e-smith-%{version}-filelist |
58 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
59 |
|
|
|
60 |
|
|
%clean |
61 |
|
|
cd .. |
62 |
|
|
/bin/rm -rf %{name}-%{version} |
63 |
|
|
|
64 |
|
|
%files -f %{name}-%{version}-filelist |
65 |
|
|
|
66 |
|
|
%defattr(-,root,root) |
67 |
|
|
|
68 |
|
|
%pre |
69 |
|
|
|
70 |
|
|
%post |
71 |
|
|
#new installs |
72 |
|
|
|
73 |
|
|
echo " If panel doesnt appear run /etc/e-smith/events/actions/navigation-conf" |
74 |
|
|
|
75 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
76 |
|
|
# for db in $DBS ; do |
77 |
|
|
# r=`/sbin/e-smith/db $db get update-system` |
78 |
|
|
# if [ -z "$r" ] ; then |
79 |
|
|
# /sbin/e-smith/db $db set update-system panel Description "Update system" DescriptionWeight 4390 Heading "Administration" HeadingWeight 4000 |
80 |
|
|
# fi |
81 |
|
|
# done |
82 |
|
|
|
83 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
84 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
85 |
|
|
#fi |
86 |
|
|
|
87 |
|
|
%preun |
88 |
|
|
|
89 |
|
|
%postun |
90 |
|
|
#uninstalls |
91 |
|
|
#if [ $1 = 0 ] ; then |
92 |
|
|
# |
93 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
94 |
|
|
# for db in $DBS ; do |
95 |
|
|
# /sbin/e-smith/db $db delete update-system |
96 |
|
|
# done |
97 |
|
|
# |
98 |
|
|
# #if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
99 |
|
|
# # /sbin/e-smith/signal-event conf-userpanel |
100 |
|
|
# #fi |
101 |
|
|
# |
102 |
|
|
#fi |