1 |
unnilennium |
1.2 |
# $Id: smeserver-updates.spec,v 1.1 2013/03/04 00:30:56 unnilennium Exp $ |
2 |
unnilennium |
1.1 |
# Authority: dungog |
3 |
|
|
# Name: Stephen Noble |
4 |
|
|
|
5 |
|
|
Summary: Update system panel for SMEserver 7 |
6 |
|
|
%define name smeserver-updates |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.2 |
9 |
unnilennium |
1.2 |
%define release 4 |
10 |
unnilennium |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: System/Administration |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
unnilennium |
1.2 |
Patch0: smeserver-updates-1.2-patch0.patch |
16 |
unnilennium |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArchitectures: noarch |
18 |
unnilennium |
1.2 |
Requires: e-smith-release >= 8.0 |
19 |
unnilennium |
1.1 |
BuildRequires: e-smith-devtools |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
unnilennium |
1.2 |
Update system panel for sme server 8 |
24 |
unnilennium |
1.1 |
permitting the uploading and installing of .rpms |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
unnilennium |
1.2 |
* Tue Jun 25 2013 JP Pialasse <tests@pialasse.com> 1.2-4.sme |
28 |
|
|
- fix yum path [SME: 7478] |
29 |
|
|
- patch0 |
30 |
|
|
|
31 |
unnilennium |
1.1 |
* Tue Jan 23 2007 Stephen Noble <support@dungog.net> |
32 |
|
|
- install with 'yum localinstall' |
33 |
|
|
- [1.2-3] |
34 |
|
|
|
35 |
|
|
* Mon Mar 13 2006 Stephen Noble <support@dungog.net> |
36 |
|
|
- sme7 version |
37 |
|
|
- uploading and installing an rpm fixed |
38 |
|
|
- [1.2-2] |
39 |
|
|
|
40 |
|
|
* Tue Dec 13 2005 Stephen Noble <support@dungog.net> |
41 |
|
|
- sme7 version |
42 |
|
|
- removed all functions except for uploading and installing a rpm |
43 |
|
|
- yum is usually a better option |
44 |
|
|
- [1.2-1] |
45 |
|
|
|
46 |
|
|
* Tue Feb 19 2002 Darrell May <dmay@netsourced.com> |
47 |
|
|
- initial release based on: |
48 |
|
|
- eneo-update-1.0-01.noarch.rpm |
49 |
|
|
- Vendor: Eneo Tecnologia SC. |
50 |
|
|
- Packager: Juan Jesus Prieto <juanprieto@jazzfree.com> |
51 |
|
|
- [0.0.1-1] |
52 |
|
|
|
53 |
|
|
%prep |
54 |
|
|
%setup |
55 |
|
|
|
56 |
|
|
%build |
57 |
|
|
perl createlinks |
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
61 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
62 |
|
|
/bin/rm -f e-smith-%{version}-filelist |
63 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
64 |
|
|
|
65 |
|
|
%clean |
66 |
|
|
cd .. |
67 |
|
|
/bin/rm -rf %{name}-%{version} |
68 |
|
|
|
69 |
|
|
%files -f %{name}-%{version}-filelist |
70 |
|
|
|
71 |
|
|
%defattr(-,root,root) |
72 |
|
|
|
73 |
|
|
%pre |
74 |
|
|
|
75 |
|
|
%post |
76 |
|
|
#new installs |
77 |
|
|
|
78 |
unnilennium |
1.2 |
#echo " If panel doesnt appear run /etc/e-smith/events/actions/navigation-conf" |
79 |
unnilennium |
1.1 |
|
80 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
81 |
|
|
# for db in $DBS ; do |
82 |
|
|
# r=`/sbin/e-smith/db $db get update-system` |
83 |
|
|
# if [ -z "$r" ] ; then |
84 |
|
|
# /sbin/e-smith/db $db set update-system panel Description "Update system" DescriptionWeight 4390 Heading "Administration" HeadingWeight 4000 |
85 |
|
|
# fi |
86 |
|
|
# done |
87 |
|
|
|
88 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
89 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
90 |
|
|
#fi |
91 |
|
|
|
92 |
|
|
%preun |
93 |
|
|
|
94 |
|
|
%postun |
95 |
|
|
#uninstalls |
96 |
|
|
#if [ $1 = 0 ] ; then |
97 |
|
|
# |
98 |
|
|
# DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
99 |
|
|
# for db in $DBS ; do |
100 |
|
|
# /sbin/e-smith/db $db delete update-system |
101 |
|
|
# done |
102 |
|
|
# |
103 |
|
|
# #if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
104 |
|
|
# # /sbin/e-smith/signal-event conf-userpanel |
105 |
|
|
# #fi |
106 |
|
|
# |
107 |
|
|
#fi |