1 |
slords |
1.1 |
Summary: Panels to let users to change server settings. |
2 |
|
|
%define name smeserver-userpanels |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.0 |
5 |
slords |
1.6 |
%define release 6 |
6 |
slords |
1.1 |
Version: %{version} |
7 |
slords |
1.3 |
Release: %{release}%{?dist} |
8 |
slords |
1.2 |
License: GPL |
9 |
slords |
1.1 |
URL: http://www.dungog.net/sme |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
slords |
1.6 |
Patch0: smeserver-vacation-1.0-esLocalePasswd+Fwd.patch |
13 |
|
|
Patch1: smeserver-vacation-1.0-svLocalePasswd+Fwd.patch |
14 |
slords |
1.1 |
BuildArchitectures: noarch |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
16 |
|
|
Requires: e-smith-release >= 7.0 |
17 |
slords |
1.6 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
slords |
1.1 |
AutoReqProv: no |
19 |
|
|
|
20 |
|
|
%description |
21 |
|
|
Provides additinal userpanels that allows user settings to be altered. |
22 |
|
|
Change password,Forward mail, Backup users home directory, |
23 |
|
|
Delegate creation of users with restrictions. |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
slords |
1.6 |
* Thu Dec 6 2007 Stephen Noble <support@dungog.net> 1.0-6 |
27 |
|
|
- swedish translation, thanks Chrille |
28 |
|
|
|
29 |
|
|
* Thu Dec 6 2007 Stephen Noble <support@dungog.net> 1.0-5 |
30 |
slords |
1.1 |
- remove Requires: smeserver-userpanel |
31 |
|
|
|
32 |
slords |
1.6 |
* Mon Oct 29 2007 Stephen Noble <support@dungog.net> 1.0-4 |
33 |
|
|
- update spanish translations, thanks Normando Hall [SME 3503] |
34 |
|
|
|
35 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
36 |
|
|
- Clean up spec so package can be built by koji/plague |
37 |
slords |
1.1 |
|
38 |
|
|
* Mon Oct 30 2006 Stephen Noble <support@dungog.net> |
39 |
|
|
- forwarding lexicon updated for de |
40 |
|
|
- [1.0-3] |
41 |
|
|
|
42 |
|
|
* Sun Mar 26 2006 Stephen Noble <support@dungog.net> |
43 |
|
|
- forwarding and password lexicons updated for de |
44 |
|
|
- fix, error in logs starting httpd-admin [sme 1991] |
45 |
|
|
- [1.0-2] |
46 |
|
|
|
47 |
|
|
* Sun Mar 26 2006 Stephen Noble <support@dungog.net> |
48 |
|
|
- Userpanel-forwarding lexicons for de, fr |
49 |
|
|
- Partial forwarding lexicons for es, it |
50 |
|
|
- [1.0-1] |
51 |
|
|
|
52 |
|
|
* Fri Mar 17 2006 Stephen Noble <support@dungog.net> |
53 |
|
|
- FormMagick version for Userpanel-forward, english only |
54 |
|
|
- Userpanel-password updated to current FM style |
55 |
|
|
- [0.9-3] |
56 |
|
|
|
57 |
|
|
* Wed Sep 21 2005 Stephen Noble <support@dungog.net> |
58 |
|
|
- FormMagick version for Userpanel-password, Languages included |
59 |
|
|
- [0.9-2] |
60 |
|
|
|
61 |
|
|
* Wed Sep 21 2005 Stephen Noble <support@dungog.net> |
62 |
|
|
- initial release, contains |
63 |
|
|
- userdata-backup, useraccounts, forward mail, change password |
64 |
|
|
- [0.9-1] |
65 |
|
|
|
66 |
|
|
%prep |
67 |
|
|
%setup |
68 |
slords |
1.6 |
%patch0 -p1 |
69 |
|
|
%patch1 -p1 |
70 |
slords |
1.1 |
|
71 |
|
|
%build |
72 |
|
|
LEXICONS1=$(find root/etc/e-smith/web/functions/userpanel-password -type f ) |
73 |
|
|
LEXICONS2=$(find root/etc/e-smith/web/functions/userpanel-forwarding -type f ) |
74 |
|
|
LEXICONS3=$(find root/etc/e-smith/locale/ -type f ) |
75 |
|
|
|
76 |
|
|
for lexicon in $LEXICONS1 $LEXICONS2 $LEXICONS3 |
77 |
|
|
do |
78 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
79 |
|
|
done |
80 |
|
|
|
81 |
|
|
#/sbin/e-smith/generate-lexicons |
82 |
|
|
|
83 |
|
|
perl createlinks |
84 |
|
|
|
85 |
|
|
%install |
86 |
|
|
rm -rf $RPM_BUILD_ROOT |
87 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
88 |
|
|
rm -f %{name}-%{version}-filelist |
89 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
90 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
91 |
|
|
|
92 |
|
|
%clean |
93 |
|
|
cd .. |
94 |
|
|
rm -rf %{name}-%{version} |
95 |
|
|
|
96 |
|
|
%pre |
97 |
|
|
%preun |
98 |
|
|
|
99 |
|
|
%post |
100 |
|
|
#new installs |
101 |
|
|
if [ $1 = 1 ] ; then |
102 |
|
|
|
103 |
|
|
globalUP=`/sbin/e-smith/db accounts get globalUP` |
104 |
|
|
if [ "x$globalUP" = "x" ]; then |
105 |
|
|
/sbin/e-smith/db accounts set globalUP userpanelglobal FirstName "global user" LastName "panel access" AdminPanels userpanel-forwarding,userpanel-password || : |
106 |
|
|
fi |
107 |
|
|
|
108 |
slords |
1.6 |
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
109 |
slords |
1.1 |
|
110 |
|
|
fi |
111 |
|
|
|
112 |
|
|
#upgrades (and new installs) |
113 |
|
|
|
114 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
115 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
116 |
|
|
#fi |
117 |
|
|
|
118 |
|
|
#notice |
119 |
|
|
echo 'smeserver-mailsorting has procmail and maildrop' |
120 |
|
|
echo 'smeserver-vacation has vacation' |
121 |
|
|
|
122 |
|
|
%postun |
123 |
|
|
#uninstall |
124 |
slords |
1.6 |
if [ $1 = 0 ] ; then |
125 |
slords |
1.1 |
|
126 |
slords |
1.6 |
DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
127 |
|
|
for db in $DBS ; do |
128 |
|
|
/sbin/e-smith/db $db delete userpanel-password 2>/dev/null |
129 |
|
|
/sbin/e-smith/db $db delete userpanel-userbackup 2>/dev/null |
130 |
|
|
/sbin/e-smith/db $db delete userpanel-forwarding 2>/dev/null |
131 |
|
|
/sbin/e-smith/db $db delete userpanel-useraccounts 2>/dev/null |
132 |
|
|
done |
133 |
|
|
fi |
134 |
slords |
1.1 |
|
135 |
|
|
%files -f %{name}-%{version}-filelist |
136 |
|
|
%defattr(-,root,root) |