1 |
slords |
1.1 |
Summary: Panels to let users to change server settings. |
2 |
|
|
%define name smeserver-userpanels |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 1.0 |
5 |
|
|
%define release 7 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
URL: http://www.dungog.net/sme |
10 |
|
|
Group: SMEserver/addon |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
Patch0: smeserver-vacation-1.0-esLocalePasswd+Fwd.patch |
13 |
|
|
Patch1: smeserver-vacation-1.0-svLocalePasswd+Fwd.patch |
14 |
|
|
Patch2: smeserver-userpanels-1.0-frLocale.patch |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
17 |
|
|
Requires: e-smith-release >= 7.0 |
18 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
19 |
|
|
AutoReqProv: no |
20 |
|
|
|
21 |
|
|
%description |
22 |
|
|
Provides additinal userpanels that allows user settings to be altered. |
23 |
|
|
Change password,Forward mail, Backup users home directory, |
24 |
|
|
Delegate creation of users with restrictions. |
25 |
|
|
|
26 |
|
|
%changelog |
27 |
|
|
* Tue Dec 25 2007 Stephen Noble <support@dungog.net> 1.0-7 |
28 |
|
|
- add french translation, thanks Sylvain Gomez |
29 |
|
|
|
30 |
|
|
* Thu Dec 6 2007 Stephen Noble <support@dungog.net> 1.0-6 |
31 |
|
|
- swedish translation, thanks Chrille |
32 |
|
|
|
33 |
|
|
* Thu Dec 6 2007 Stephen Noble <support@dungog.net> 1.0-5 |
34 |
|
|
- remove Requires: smeserver-userpanel |
35 |
|
|
|
36 |
|
|
* Mon Oct 29 2007 Stephen Noble <support@dungog.net> 1.0-4 |
37 |
|
|
- update spanish translations, thanks Normando Hall [SME 3503] |
38 |
|
|
|
39 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
40 |
|
|
- Clean up spec so package can be built by koji/plague |
41 |
|
|
|
42 |
|
|
* Mon Oct 30 2006 Stephen Noble <support@dungog.net> |
43 |
|
|
- forwarding lexicon updated for de |
44 |
|
|
- [1.0-3] |
45 |
|
|
|
46 |
|
|
* Sun Mar 26 2006 Stephen Noble <support@dungog.net> |
47 |
|
|
- forwarding and password lexicons updated for de |
48 |
|
|
- fix, error in logs starting httpd-admin [sme 1991] |
49 |
|
|
- [1.0-2] |
50 |
|
|
|
51 |
|
|
* Sun Mar 26 2006 Stephen Noble <support@dungog.net> |
52 |
|
|
- Userpanel-forwarding lexicons for de, fr |
53 |
|
|
- Partial forwarding lexicons for es, it |
54 |
|
|
- [1.0-1] |
55 |
|
|
|
56 |
|
|
* Fri Mar 17 2006 Stephen Noble <support@dungog.net> |
57 |
|
|
- FormMagick version for Userpanel-forward, english only |
58 |
|
|
- Userpanel-password updated to current FM style |
59 |
|
|
- [0.9-3] |
60 |
|
|
|
61 |
|
|
* Wed Sep 21 2005 Stephen Noble <support@dungog.net> |
62 |
|
|
- FormMagick version for Userpanel-password, Languages included |
63 |
|
|
- [0.9-2] |
64 |
|
|
|
65 |
|
|
* Wed Sep 21 2005 Stephen Noble <support@dungog.net> |
66 |
|
|
- initial release, contains |
67 |
|
|
- userdata-backup, useraccounts, forward mail, change password |
68 |
|
|
- [0.9-1] |
69 |
|
|
|
70 |
|
|
%prep |
71 |
|
|
%setup |
72 |
|
|
%patch0 -p1 |
73 |
|
|
%patch1 -p1 |
74 |
|
|
%patch2 -p1 |
75 |
|
|
|
76 |
|
|
%build |
77 |
|
|
LEXICONS1=$(find root/etc/e-smith/web/functions/userpanel-password -type f ) |
78 |
|
|
LEXICONS2=$(find root/etc/e-smith/web/functions/userpanel-forwarding -type f ) |
79 |
|
|
LEXICONS3=$(find root/etc/e-smith/locale/ -type f ) |
80 |
|
|
|
81 |
|
|
for lexicon in $LEXICONS1 $LEXICONS2 $LEXICONS3 |
82 |
|
|
do |
83 |
|
|
/sbin/e-smith/validate-lexicon $lexicon |
84 |
|
|
done |
85 |
|
|
|
86 |
|
|
#/sbin/e-smith/generate-lexicons |
87 |
|
|
|
88 |
|
|
perl createlinks |
89 |
|
|
|
90 |
|
|
%install |
91 |
|
|
rm -rf $RPM_BUILD_ROOT |
92 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
93 |
|
|
rm -f %{name}-%{version}-filelist |
94 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
95 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
96 |
|
|
|
97 |
|
|
%clean |
98 |
|
|
cd .. |
99 |
|
|
rm -rf %{name}-%{version} |
100 |
|
|
|
101 |
|
|
%pre |
102 |
|
|
%preun |
103 |
|
|
|
104 |
|
|
%post |
105 |
|
|
#new installs |
106 |
|
|
if [ $1 = 1 ] ; then |
107 |
|
|
|
108 |
|
|
globalUP=`/sbin/e-smith/db accounts get globalUP` |
109 |
|
|
if [ "x$globalUP" = "x" ]; then |
110 |
|
|
/sbin/e-smith/db accounts set globalUP userpanelglobal FirstName "global user" LastName "panel access" AdminPanels userpanel-forwarding,userpanel-password || : |
111 |
|
|
fi |
112 |
|
|
|
113 |
|
|
/etc/e-smith/events/actions/navigation-conf 2>/dev/null |
114 |
|
|
|
115 |
|
|
fi |
116 |
|
|
|
117 |
|
|
#upgrades (and new installs) |
118 |
|
|
|
119 |
|
|
#if [ -d /etc/e-smith/events/conf-userpanel ] ; then |
120 |
|
|
# /sbin/e-smith/signal-event conf-userpanel |
121 |
|
|
#fi |
122 |
|
|
|
123 |
|
|
#notice |
124 |
|
|
echo 'smeserver-mailsorting has procmail and maildrop' |
125 |
|
|
echo 'smeserver-vacation has vacation' |
126 |
|
|
|
127 |
|
|
%postun |
128 |
|
|
#uninstall |
129 |
|
|
if [ $1 = 0 ] ; then |
130 |
|
|
|
131 |
|
|
DBS=`find /home/e-smith/db/navigation -type f -name "navigation.*"` |
132 |
|
|
for db in $DBS ; do |
133 |
|
|
/sbin/e-smith/db $db delete userpanel-password 2>/dev/null |
134 |
|
|
/sbin/e-smith/db $db delete userpanel-userbackup 2>/dev/null |
135 |
|
|
/sbin/e-smith/db $db delete userpanel-forwarding 2>/dev/null |
136 |
|
|
/sbin/e-smith/db $db delete userpanel-useraccounts 2>/dev/null |
137 |
|
|
done |
138 |
|
|
fi |
139 |
|
|
|
140 |
|
|
%files -f %{name}-%{version}-filelist |
141 |
|
|
%defattr(-,root,root) |