1 |
jpp |
1.1 |
%define name smeserver-virtualbox |
2 |
|
|
%define version 5.0.0 |
3 |
|
|
%define release 3 |
4 |
|
|
%define rpmver 5.0.0 |
5 |
|
|
Summary: smserver rpm to install virtualbox |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source: %{name}-%{version}.tar.gz |
10 |
|
|
License: GNU GPL version 2 |
11 |
|
|
URL: http://mirror.de-labrusse.fr |
12 |
|
|
Group: SMEserver/addon |
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
14 |
|
|
Prefix: %{_prefix} |
15 |
|
|
BuildArchitectures: noarch |
16 |
|
|
BuildRequires: e-smith-devtools |
17 |
|
|
Requires: e-smith-release >= 10.0 |
18 |
|
|
Requires: VirtualBox-5.0 |
19 |
|
|
#Patch0: smeserver-virtualbox-4.3.1_fix_vboxdrv_kernel_module.patch |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
smserver rpm to install virtualbox |
24 |
|
|
|
25 |
|
|
%changelog |
26 |
|
|
* Wed Aug 07 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 5.0.0-3 |
27 |
|
|
- vboxweb-service start now at S99 |
28 |
|
|
|
29 |
|
|
* Thu Aug 06 2015 stephane de labrusse <stephdl@de-labrusse.fr> 5.0.0-2 |
30 |
|
|
- require virtualbox-5.0 |
31 |
|
|
|
32 |
|
|
* Wed Mar 19 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-1 |
33 |
|
|
- added a script to verify if the vboxdrv module is compiled for the kernel used by the system |
34 |
|
|
|
35 |
|
|
* Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-5 |
36 |
|
|
- changing naming of contrib for import into buildsys |
37 |
|
|
|
38 |
|
|
* Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-4 |
39 |
|
|
- change name to match the virtualbox version |
40 |
|
|
|
41 |
|
|
* Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-3 |
42 |
|
|
- Initial release |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
%setup |
46 |
|
|
#%patch0 -p1 |
47 |
|
|
%build |
48 |
|
|
#perl createlinks |
49 |
|
|
|
50 |
|
|
%install |
51 |
|
|
rm -rf $RPM_BUILD_ROOT |
52 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
53 |
|
|
rm -f %{name}-%{version}-filelist |
54 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
55 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
56 |
|
|
|
57 |
|
|
%clean |
58 |
|
|
cd .. |
59 |
|
|
rm -rf %{name}-%{version} |
60 |
|
|
|
61 |
|
|
%pre |
62 |
|
|
/etc/init.d/vboxdrv stop >/dev/null 2>&1 |
63 |
|
|
|
64 |
|
|
%preun |
65 |
|
|
|
66 |
|
|
%post |
67 |
|
|
if [ $1 > 1 ] ; then |
68 |
|
|
/bin/ln -fs /etc/rc.d/init.d/vboxdrv /etc/rc7.d/S20vboxdrv >/dev/null 2>&1 |
69 |
|
|
/bin/ln -fs /etc/rc.d/init.d/vboxautostart-service /etc/rc7.d/S35vboxautostart-service >/dev/null 2>&1 |
70 |
|
|
/bin/ln -fs /etc/rc.d/init.d/vboxballoonctrl-service /etc/rc7.d/S35vboxballoonctrl-service >/dev/null 2>&1 |
71 |
|
|
/bin/ln -fs /etc/rc.d/init.d/vboxweb-service /etc/rc7.d/S99vboxweb-service >/dev/null 2>&1 |
72 |
|
|
/bin/ln -fs /etc/rc.d/init.d/fix_vboxdrv_kernel_module /etc/rc7.d/S19fix_vboxdrv_kernel_module >/dev/null 2>&1 |
73 |
|
|
fi |
74 |
|
|
/etc/init.d/vboxdrv start >/dev/null 2>&1 |
75 |
|
|
/usr/bin/vboxmanage setproperty websrvauthlibrary null |
76 |
|
|
|
77 |
|
|
%postun |
78 |
|
|
#uninstall |
79 |
|
|
if [ $1 = 0 ] ; then |
80 |
|
|
/bin/rm -rf /etc/rc7.d/S20vboxdrv |
81 |
|
|
/bin/rm -rf /etc/rc7.d/S35vboxautostart-service |
82 |
|
|
/bin/rm -rf /etc/rc7.d/S35vboxballoonctrl-service |
83 |
|
|
/bin/rm -rf /etc/rc7.d/S99vboxweb-service |
84 |
|
|
/bin/rm -rf /etc/rc7.d/S19fix_vboxdrv_kernel_module |
85 |
|
|
fi |
86 |
|
|
%files -f %{name}-%{version}-filelist |
87 |
|
|
%defattr(-,root,root) |
88 |
|
|
%attr(755,root,root) /etc/rc.d/init.d/fix_vboxdrv_kernel_module |
89 |
|
|
|