1 |
%define name smeserver-virtualbox |
2 |
%define version 5.2 |
3 |
%define release 4 |
4 |
%define rpmver 5.2 |
5 |
Summary: smserver rpm to install VirtualBox |
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %{release}%{?dist} |
9 |
Source: %{name}-%{version}.tar.gz |
10 |
License: GNU GPL version 2 |
11 |
URL: http://mirror.de-labrusse.fr |
12 |
Group: SMEserver/addon |
13 |
BuildRoot: %{_tmppath}/%{name}-buildroot |
14 |
Prefix: %{_prefix} |
15 |
BuildArchitectures: noarch |
16 |
BuildRequires: e-smith-devtools |
17 |
Requires: e-smith-release >= 10.0 |
18 |
Requires: VirtualBox-5.2 |
19 |
Requires: kernel-devel |
20 |
Requires: gcc |
21 |
AutoReqProv: no |
22 |
Patch0: smeserver-virtualbox-5.2-move_vbox_dir.patch |
23 |
Patch1: smeserver-virtualbox-5.2-multiple_changes.patch |
24 |
|
25 |
%description |
26 |
smserver rpm to install VirtualBox-5.2 |
27 |
|
28 |
%changelog |
29 |
* Fri Mar 10 2023 Trevor Batley <trevor@batley.id.au> 5.2-4.sme |
30 |
- change log directory to /var/log/virtualbox and give correct permissions |
31 |
- add password generation and storage for vboxweb runtime user (for use by phpvirtualbox) |
32 |
- template /etc/default/virtualbox.conf |
33 |
- add 50koozali.conf for vboxweb-service |
34 |
- include migrate fragment for vbox user password |
35 |
|
36 |
* Thu Oct 20 2022 Trevor Batley <trevor@batley.id.au> 5.2-3.sme |
37 |
- remove storage of vbox password |
38 |
|
39 |
* Wed Oct 19 2022 Trevor Batley <trevor@batley.id.au> 5.2-2.sme |
40 |
- change vbox user to system user and change the home directory |
41 |
|
42 |
* Tue Oct 11 2022 Trevor Batley <trevor@batley.id.au> 5.2-1.sme |
43 |
- first import to sme10 |
44 |
- requires VirtualBox-5.2 |
45 |
- create vbox user and run vboxweb-service as vbox user |
46 |
- create vbousers group and add admin,vbox as members |
47 |
- add vbox & vboxusers as full sme accounts so tha they are in ldap (for ldap authentication) |
48 |
- use systemd for vboxdrv |
49 |
- move fix_vboxdrv_kerenel_module.sh script into /usr/lib/virtualbox and include as pre step in vboxdrv service start |
50 |
|
51 |
* Fri Aug 07 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 5.0.0-3 |
52 |
- vboxweb-service start now at S99 |
53 |
|
54 |
* Thu Aug 06 2015 stephane de labrusse <stephdl@de-labrusse.fr> 5.0.0-2 |
55 |
- require virtualbox-5.0 |
56 |
|
57 |
* Wed Mar 19 2014 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.1-1 |
58 |
- added a script to verify if the vboxdrv module is compiled for the kernel used by the system |
59 |
|
60 |
* Mon Dec 30 2013 JP Pialasse <tests@pialasse.com> 4.3.0-5 |
61 |
- changing naming of contrib for import into buildsys |
62 |
|
63 |
* Tue Nov 05 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-4 |
64 |
- change name to match the virtualbox version |
65 |
|
66 |
* Sat Oct 19 2013 stephane de labrusse <stephdl@de-labrusse.fr> 4.3.0-3 |
67 |
- Initial release |
68 |
|
69 |
%prep |
70 |
|
71 |
%setup |
72 |
%patch0 -p1 |
73 |
%patch1 -p1 |
74 |
|
75 |
%build |
76 |
perl createlinks |
77 |
|
78 |
%install |
79 |
rm -rf $RPM_BUILD_ROOT |
80 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
81 |
rm -f %{name}-%{version}-filelist |
82 |
mkdir -p $RPM_BUILD_ROOT/var/log/virtualbox |
83 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
84 |
--dir /var/log/virtualbox 'attr(755,vbox,vboxusers)' \ |
85 |
--file /usr/lib/virtualbox/fix_vboxdrv_kernel_module.sh 'attr(755,root,root)' \ |
86 |
> %{name}-%{version}-filelist |
87 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
88 |
|
89 |
%clean |
90 |
cd .. |
91 |
rm -rf %{name}-%{version} |
92 |
|
93 |
%pre |
94 |
if ! id "vbox" |
95 |
then |
96 |
echo "Adding VBoxWeb runtime user (vbox)" |
97 |
/usr/sbin/useradd -c "VBoxWeb runtime user" -m -N -s /bin/bash -g vboxusers vbox >/dev/null |
98 |
fi |
99 |
|
100 |
%preun |
101 |
/sbin-e-smith/systemctl stop vboxweb-service |
102 |
/sbin/e-smith/systemctl stop vboxdrv |
103 |
|
104 |
%post |
105 |
/sbin/e-smith/systemctl start vboxdrv |
106 |
|
107 |
%postun |
108 |
#uninstall |
109 |
%files -f %{name}-%{version}-filelist |
110 |
%defattr(-,root,root) |
111 |
|